Announcements

Help Wizard

Step 1

NEXT STEP

Connect - Autoplay DISABLED, but still ACTIVE

Solved!

Connect - Autoplay DISABLED, but still ACTIVE

Plan

Premium

Country

Germany

Device

Samsung Galaxy A51, Windows 10 notebook

Operating System

Android 11, Windows 10

My Question or Issue

I'm listening on several Sonos speakers via Connect. Recently, Spotify has started playing other music once the album I listen to has finished - i.e. it's using the Autoplay feature. Problem is: Autoplay is DISABLED on all devices, but it's still being used. How do I fix this? (I've already reinstalled Spotify on all devices.)

 

Reply
327 Replies

Seems to still do this. I've checked all my devices and turned everything autoplay related off and it still keeps shoving stuff in "Next up", even worse, when I remove these from the queue it adds them right back.

 

This is absolutely driving me up the wall. I've tried logging out and back in, but that didn't do anything. Is there any proper fix?

I am having the same problem here. Spotify suddenly starts playing random music in the middle of the night when I am asleep and not using my phone. Very frustrating.

 

I have tried everything offered in this thread but no solution. I will uninstall and get rid of this app. Honestly.

How do you clear the next up items in the queue that keep playing?

 

There is no way to clear those except one by one

Hey @1234567891011111,

 

Thank you for joining the conversation.

 

The "Next up" section shows the tracks that are going to be played next after the one currently playing. Those songs shown are from the same playlist/album you're listening to and cannot be mass removed.

 

But in case you want to listen to just a single song without the "Next up" section, we'd recommend searching for the individual track by using the search button and playing it directly from there. This way, if you have the Autoplay feature turned off, the app will only play that song you select with no "Next up" section.

 

Hope this helps. If anything else comes up, don't hesitate to ask.

OscarDCModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!
Marked as solution

UPDATE 2-7-2023:

 

The "Autoplay" setting was recently updated. The single "Autoplay" setting in the desktop and mobile apps will now enable or disable Autoplay across all devices on your account. This change makes it easier to manage instead of there being 2 different settings.

 

You only need to change the Autoplay setting in one of the apps, either desktop or mobile, and it will apply to your account on all devices including the Web Player and Spotify Connect devices.

 

You can read the support article for more information about the Autoplay feature.

 

At the end of 2021 a second setting was added to turn on/off Autoplay on the Web Player and Connect devices, but now it's just one single setting.

MattSudaSpotify Star
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.

I am still getting the Spotify recommended songs in my queue, that pauses my playlist, when using the Spotify player app for Windows 11, and only resumes playing my chosen playlist after 43 songs that are played from outside the playlist.

 

I have disabled autoplay in my settings within the app on PC but is entirely useless.

 

I can however play my chosen playlist through both Google Chrome, Microsoft Edge and other web browsers on my PC with no pausing of playlist.

 

Edit: I also have random play enabled before I start playing the playlist I want to listen to, even having that enabled doesn't work.

Hey @MrMoo1985,

 

Thanks for letting us know!
Could you please take a look if maybe Enhanced or Smart Shuffle are enabled?

Keep us posted! 

VasilModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

This has not been fixed. Autoplay continues to occur even though it's disabled on all devices .this is messed up. You are bad

Hey @dmunkvold,

 

Thanks for your reply.

 

In this case, we'd like to gather some additional info. Would you mind sharing the make/model and OS version of the affected device along with the Spotify version you're running there.

 

On another note, have you already checked what @Vasil Mentioned above? If you haven't yet, we'd suggest checking if enhanced and/or smart shuffle features are disabled within the playlist. We understand that you already make sure the feature is disabled within your devices. Would you check again that Autoplay is switched off on all your devices?

 

Lastly, if after checking the above you continue noticing this behavior, it'd be really helpful if you sent us a video recording of what's happening. You can attach the video to your next reply in mp4 format, or you can also upload it to YouTube or Google Drive and make it public, so we can visualize it.
 

Keep us in the loop!

AlejaRModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.

This new setting does not work for me. On Spotify Premium, I get to the end of my playlist and it just carries on with random songs. Useless for sleep.

 

S23 Ultra 

Smart Shuffle off

Enhance isn't even a button I have

 

Also if I go to the queue, it won't even let me delete the songs. I can select them and click delete, but all that happens is it unselects the selected songs, they do not get removed 

Hi @jcomley,

 

Thanks for the reply. Can you send us the Spotify version and a video of the behaviour as described by @AlejaR? That would greatly help us investigate this.

 

Keep us posted.

JoanModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

This update is not working. Autoplay is disabled, but continues to function when a playlist finishes. Also does it even if the playlist is on repeat more than once, so the playlist should technically never finish then.

It's not turning off on my phone on August 23, 2023. Autoplay setting is off, but it just keeps playing at the end of a playlist. 

 

I'm not really sure if you're on a crack pipe right now but turning off auto play I still get song suggested to me and they play the songs so your answer above is absolutely **bleep**ing useless

Me too**bleep**

I'm having the same problem. I turn off Autoplay Similar Content in settings and in does nothing. I'm highly considering changing service provider. Does anybody knows if Apple Music or Deezer do a better job at this?

I actually might have found A solution. After trying several things, logging out and back in on my spotify account on my phone made it finally work. As I heard once, if cars had evolved like computers... when you had an issue with them all you had to do was to turn them off, open and slam the doors a few times and it should work as previous. What an annoying app this one. 😞

"me too". Latest app from Google Play. Phone played random recommended tracks all night when I had selected a single album to fall asleep to. Why have a setting if it's going to be ignored?

@pss-p This did it for me, thanks!

My dear god, you're a genius man. And also Spotify sucks. How is possible that you need a log-off and re-log-on to apply this setting!?
Bad design. But alas, it works now. Thanks for sharing this!

Suggested posts