Announcements

Help Wizard

Step 1

NEXT STEP

FAQs

Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...

VIEW ALL

Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...

VIEW ALL

Connect - Autoplay DISABLED, but still ACTIVE

Solved!

Connect - Autoplay DISABLED, but still ACTIVE

Plan

Premium

Country

Germany

Device

Samsung Galaxy A51, Windows 10 notebook

Operating System

Android 11, Windows 10

My Question or Issue

I'm listening on several Sonos speakers via Connect. Recently, Spotify has started playing other music once the album I listen to has finished - i.e. it's using the Autoplay feature. Problem is: Autoplay is DISABLED on all devices, but it's still being used. How do I fix this? (I've already reinstalled Spotify on all devices.)

 

Reply
Top Answer
AlejaR
Moderator

Hey folks,

 

Thanks for all your replies.

 

@Primordial_Radiance, we'd like to confirm, is your account on free service? If yes, keep in mind our free experience on mobile is different: music on-demand is a Premium feature, so it's expected for the app to add suggested tracks within the same album/playlist. This is not the same as Autoplay. You can read more about it here. Keep in mind, these recommendations are going to appear, even if you disable Autoplay.
 

If your account is Premium, it'd be really helpful if you sent us a video recording of what's happening. You can attach the video to your next reply in mp4 format, or you can also upload it to YouTube or Google Drive and make it public, so we can visualize it.

 

Keep us in the loop!

Top Answer
MattSuda
Spotify Star

As mentioned by @JalapenoMunich 

 

An update has been posted. An option to disable Autoplay on connected devices will soon be coming to the desktop app first and then the mobile app at a later time. The setting works globally so if you turn Autoplay off in the desktop app for connected devices, it will also be off in the mobile app when playing to connected devices.

 

More info here:

 

https://community.spotify.com/t5/Live-Ideas/AutoPlay-Option-to-toggle-Autoplay-on-off-across-all-devices/idc-p/5303176

328 Replies

@pss-p, I really hope that your workaround will keep on working for all Spotify subscribers. I can't check by myself as I do not use neither the app nor the web player as as paying subscriber anymore. I switched to another provider in November 2021, a little after this crappy feature had been enforced no matter your personal choice to set it on or off. And because Spotify remained unable to fix it in a few weeks. Good luck to all of you, Spotify fans!

This didn't work. I have autoplay, automix, and all other settings that could cause this to happen disabled on ALL devices and it still randomly plays songs.

Hey folks,

 

Thanks for all your replies.

 

@Primordial_Radiance, we'd like to confirm, is your account on free service? If yes, keep in mind our free experience on mobile is different: music on-demand is a Premium feature, so it's expected for the app to add suggested tracks within the same album/playlist. This is not the same as Autoplay. You can read more about it here. Keep in mind, these recommendations are going to appear, even if you disable Autoplay.
 

If your account is Premium, it'd be really helpful if you sent us a video recording of what's happening. You can attach the video to your next reply in mp4 format, or you can also upload it to YouTube or Google Drive and make it public, so we can visualize it.

 

Keep us in the loop!

AlejaRModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.

Hey bud. I'm still having this problem. The setting is turned off but still playing random songs. Sometimes more than one and in the middle of the playlist, but that part is more recent.

Me too

Broken here too. Paid account, all autoplay settings off, logged out and in again, and smart speakers connected via the desktop app still keep playing random stuff after the end of my queue.

This started happening again. Unacceptable! Get it sorted!

Please get this bug sorted once and for all. It obviously resurfaces every once in a while. Just remove this stupid and buggy feature if you can’t get it fixed. Please!

Hallo, ich wollte auch die Autoplay Funktion deaktivieren, weil ständig über Bluetooth das Handy sich mit dem Auto koppelt und dann Spotify sich öffnet und einfach den letzten Song abspielt. Ich habe in allen Einstellungen gesucht aber es gibt bi mir weder auf der App noch im Web die Funktion Autoplay, diese ist absolut nicht da. Ich brauche hilfe.

Suggested posts