Announcements

Help Wizard

Step 1

NEXT STEP

FAQs

Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...

VIEW ALL

Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...

VIEW ALL

Connect - Autoplay DISABLED, but still ACTIVE

Solved!

Connect - Autoplay DISABLED, but still ACTIVE

Plan

Premium

Country

Germany

Device

Samsung Galaxy A51, Windows 10 notebook

Operating System

Android 11, Windows 10

My Question or Issue

I'm listening on several Sonos speakers via Connect. Recently, Spotify has started playing other music once the album I listen to has finished - i.e. it's using the Autoplay feature. Problem is: Autoplay is DISABLED on all devices, but it's still being used. How do I fix this? (I've already reinstalled Spotify on all devices.)

 

Reply
Top Answer
AlejaR
Moderator

Hey folks,

 

Thanks for all your replies.

 

@Primordial_Radiance, we'd like to confirm, is your account on free service? If yes, keep in mind our free experience on mobile is different: music on-demand is a Premium feature, so it's expected for the app to add suggested tracks within the same album/playlist. This is not the same as Autoplay. You can read more about it here. Keep in mind, these recommendations are going to appear, even if you disable Autoplay.
 

If your account is Premium, it'd be really helpful if you sent us a video recording of what's happening. You can attach the video to your next reply in mp4 format, or you can also upload it to YouTube or Google Drive and make it public, so we can visualize it.

 

Keep us in the loop!

Top Answer
MattSuda
Spotify Star

As mentioned by @JalapenoMunich 

 

An update has been posted. An option to disable Autoplay on connected devices will soon be coming to the desktop app first and then the mobile app at a later time. The setting works globally so if you turn Autoplay off in the desktop app for connected devices, it will also be off in the mobile app when playing to connected devices.

 

More info here:

 

https://community.spotify.com/t5/Live-Ideas/AutoPlay-Option-to-toggle-Autoplay-on-off-across-all-devices/idc-p/5303176

328 Replies

Same here. When I play an album on my phone, the playlist is the album only, but when I play the same album on my WiFi speakers, the autoplay function is adding songs to my playlist (while the autoplay function is off)

Me too.   Driving me spare today, I am exploring artist back catalogues by album, I don't want random additions. 
If I'd wanted autoplay I would have selected it.
Really do not appreciate having settings changed without my permission, especially when there is no available option to revert them.  Please fix this. 
Using web player, Edge browser, Windows 10.
Work computer so cannot use app.

 

It's related but it's not the same issue it seems.
The issue linked is that when broadcasting the stream of a queue to a connected speaker type chromecast, the speaker uses the web stream which doesn't support no autoplay anymore.

However, the decision to remove that option had to be a conscious one. This issue is just a side effect of that decision, which could be resolved by detecting the source for the command of starting the stream, and not fixing the autoplay, which is the real issue here.

Hi there folks,


Thank you for reaching out to the Community and for sharing your feedback.

 

We're always testing things by adding or removing features to make Spotify better overall and we’re constantly aiming to improve our features. We’re sorry that this means you’re not able to use Spotify like you wish to do at the moment.

 

You can read more about how your feedback reaches Spotify here.

 

Once again - thanks for the feedback, we appreciate it. Let us know if we can help you with anything else. 

 

Take care!

JeremyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Live, love, laugh and listen to music 🙂

CarlosE or Jeremy, can you please just confirm or deny that this is intended behavior? Your barely applicable canned responses are incredibly unhelpful.

Glad you've been able to reproduce the issue.

 

I'm facing this issue too:

Issue 1: Spotify autoplay is active when Spotify Connect is used to play though Google Speakers, despite being disabled:

  • Spotify 8.6.72.1121 on Samsung Galaxy S10
  • Spotify 1.1.70.610 on PC running Windows 10
  • Google Nest Mini, Google nest audio, firmware version 1.54.250118

Whenever Spotify connect is used (either using my PC or my mobile phone) to play music through my Google Home speakers, the autoplay feature is active despite being disabled on all devices (the issue is not present when requested by voice).
I have tried restarting all devices and toggling all autoplay settings.

I can also confirm this is a new issue which as not present last week.

On a personal use-case level, this is a big deal since it destroys my ability to throw on an album to fall asleep to.😅

 

Relatedly, there is also a simultaneous new issue:

Issue 2: Spotify autoplay is active when Spotify Web is used to play music:

  • Spotify Web on Chrome 95.0.4638.54 on PC running Windows 10

Again, this was not an issue last week.

 

Thanks!

 

 

Same here.

Spotify for Windows 1.1.70.610 (and for Mac) streaming to Sonos.

I have the same problem. Listening to albums on my Windows laptop and Android tablet works as expected. The album plays and is followed by nothing. When I'm casting to Chromecast, as soon as I start playing the album, another 50 or so random tracks are added to the queue and which start playing after the album, and more random tracks are added to the queue indefinitely.

 

I am a Premium user and have the dreadful autoplay feature switched off.

I have the same problem on Spotify Connect. Very annoying!!

Same issue here when casting either to Chromecast or to Roku TV. As soon as I connect to either, from Windows player or Android app, an extra 50 songs are added at the end of the album or playlist and if they are allowed to play through additional songs are added indefinitely.

 

This is different behaviour to when Autoplay is used within the app when the auto-songs are added to the queue once the playlist or album is through. These are added as soon as the external device is connected. Also these continue in exactly the same way if all the controlling apps/devices are closed down, so it appears to be a server-side rather than a client-side issue.

 

[EDIT: Just tested in the Web Player and the unexpected Autoplay behaviour is occurring there too. And if I start playing from the Web Player, extra tracks appear in the queue, but if then, via the WebPlayer devices button, send the output to my Android tablet, the extra tracks then disappear from the queue—until the output is sent back to the WebPlayer, when they appear again.]

having same issue on browser version. So so annoying. I want total control over my music.

If it is intended behaviour that is horrific frankly. There should be an option to enable/disable Autoplay in the web player, simple as that.

Spotify is run like Soviet Russia. One day a feature just disappears. You've known the feature for years, you've been living with it, enjoying it. And then, nothing. Everyone just keeps acting like its normal. The officials won't tell you what's going on. But they probably don't know the truth either. Did the feature move? Did it get a job in another software? Did it find another user. Was it a bad feature and was sent to jail? Is it happy? Or something more sinister. No one knows. It just disappeared. And this is normal.

Same here, I started having the same issue recently on my work computer, which is where I'm using Spotify the most. I've never experienced this before, and I don't understand why this setting has changed and why there is no way to revert back, especially as a premium user.

I don't understand why anybody would want to have random songs by random artists start playing immediately after an album has ended ; I understand that some people enjoy listening to playlists (which I don't), and maybe this is a useful feature for them, but it makes no sense to me that this feature also applies when listening to albums. This feature alone is currently ruining the whole Spotify experience for me.

I use the web player at work (premium account), and I am now stuck with this unwanted autoplay feature. It was irritating enough having to periodically re-disable it in the desktop client. This is a bummer.

Won't let me delete this comment. Added in error.

I use Spotify to fall asleep at night, by playing a single album of my choice. The new infinite playlist makes this impossible. Do I need to use a different music service to achieve this now?

I use Spotify on iOS (Premium, newest App, newest iOS 15) to play music and audiobooks on my Sonos. When I play an album, the playlist on Sonos automatically gets some additional tracks after the album itself. It looks like Autoplay adds those songs. 

However, Autoplay is deactivated on all my devices. When I play on my iPhone it only has the album in the next tracks overview. As soon as I change to play on my Sonos, additional tracks are added. When I change back to play on iPhone those tracks are removed. 

The sonos app shows that control is by Spotify and I cannot change anything there. In Spotify I cannot activate/deactivate Autoplay for devices like Sonos. The tracks are always similar to the album playing so it’s not a playlist from somewhere else. 

I’m stuck with how to disable Autoplay when I play on external devices. 

thank you!

 

My Question or Issue

 

Hey folks,

 

Thanks for all that info.

 

We've gone ahead and passed this on to the right teams. We'll let you know as soon as we have an update.

 

Cheers!

CarlosEModerator
 
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 

Suggested posts