Announcements

Help Wizard

Step 1

NEXT STEP

[Desktop] Can't connect to Google Nest Mini

[Desktop] Can't connect to Google Nest Mini

Plan

Premium

Country

Canada

Device

Desktop / Google Nest Mini (2nd Gen)

Operating System

Windows 10

 

My Question or Issue

For some time now I've been having problems using the "Connect to a device" function in the desktop app (version 1.1.97.962).
When selecting to connect to the Google Nest Mini, a message appears saying that Spotify is trying to connect, and I hear a beep on the device, but the connection doesn't occur.
However, when I try to connect to the same device using my Android, no problem occurs.
I've already tried reinstalling Spotify on my computer, and even resetting my Google Nest Mini, but nothing has changed.

Reply
15 Replies

Hey @Julio_Pradera,

 

Thanks for posting in the Community and welcome.

 

In this case, we'd like to gather as much info as possible. Did you notice if the same is happening if you try to connect the speaker to the web player? It'd be awesome if you could check. Make sure both your computer and the Google Nest are connected to the same internet red.

 

On another note, can you check if you notice any difference if you change the internet red you're using? If possible, you can create a hotspot from your phone and connect both devices. Give it a try and let us know how it goes.

 

Lastly, we'd suggest you reinstall the app on your computer to see if you notice any difference. By doing that the app can be up-to-date and you can make sure the cache is not leading to this inconvenience. You can find out the steps to do it here.
 

Keep us in the loop!

AlejaRModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.

Hello AlejaR.

 

I tried connecting to Google Nest Mini as you suggested, and everything worked normally.

 

All my devices are connected to the same network.

 

As for reinstalling Spotify on my computer, I already tried that.

Hi there @Julio_Pradera,

 

Thanks for the reply. Could you please test the connection in a different network and see if it works there? You can make a hotspot as described by 

@AlejaR above. Also some screenshots or a video of the behavior would help us a lot.

 

Keep us posted 🙂

Kiril Moderator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Hello Kiril.

I created the hotspot, connected both the computer and the Google Nest Mini to it, but nothing changed.

Untitled.png

Hey @Julio_Pradera,

 

Thanks for getting back to us!

 

Have you tried recreating this issue with a different account? If a friend or a family member has a Spotify account it'd be a good idea to ask them to log in on your computer to see if the app will behave the same way.

 

In case the above is not possible, you can try creating a free account for testing purposes and try connecting to see if you'll experience the same. This will help us understand if it's account related or not. 

 

Let us know how it goes.

LyubkaModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.

Hello Lyubka.

 

I created a new account, but the problem remained the same.

Hey @Julio_Pradera,

 

Thanks for your reply and for all the info shared along this thread.

 

In this case, is this happening on another computer? It’d be awesome if you could check. You can ask for the computer of a relative or a friend to open your account and check.

 

On another note and just to confirm, did you use a VPN? If yes, try switching it off.

 

Lastly, it might help if you unlink your Spotify account from your Google Nest Mini and link it again to check if you notice any difference. To do it, you can follow these steps:

  1. In the Google Home app, tap Account in the top-right.
  2. Tap Settings.
  3. Tap Music under services.
  4. Tap UNLINK.

Then you can check if your Spotify account is connected to your Google voice assistant as well. If yes, try unlinking them as well:

  1. On your Android phone, go to Assistant settings, or open the Google Assistant app and say "Assistant Settings".
  2. Scroll up and select Music.
  3. If you see Spotify there, unlinked.

Once you've done that, try linking your accounts again by following the steps in this article

 

Keep us in the loop!

AlejaRModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.

Hello AlejaR.

 

1- I didn't understand how asking a friend to sign in with my Spotify account could help. Ignoring the lack of security when giving my password to someone else, the person wouldn't be able to connect to my Google Nest Mini as they will not be on the same network. For this test to work, I would need to have a second computer in my house (which I don't).

 

2- I'm not using any VPN.

 

3- I unlinked my Spotify account from my Google Nest Mini and then re-linked it, but nothing changed.

Hey @Julio_Pradera,

 

Thank you for keeping in contact.

 

The process of logging your account on someone else's PC is to make sure that the issue is not account-related. We apologize if this information could cause any misunderstanding, but this can be done if a friend or a family member brings a laptop to your place. You don't need to share the password either, you can borrow the PC while logging in (and make sure to log it out as soon as the test ends.)

 

In the meantime, we can try something else to complement the previous unlinking process: After unlinking your Spotify account from your Google Home and linking it again:

 

1. In the Google Home app, set the DNS server address to 8.8.8.8 or 8.8.4.4.

2. Reboot your device.

 

Alternatively, you can try setting the DNS server address to 8.8.8.8 or 8.8.4.4 in your router's settings as well to see if it makes any difference.

 

Hope this helps. Keep us posted!

OscarDCModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Hello OscarDC.

 

Considering that testing my account on another computer isn't possible, as is changing the DNS on my router (as it will cause problems for other tools I use for work), how do I change DNS on my Google Nest Mini?

I googled it but only found posts from people saying this isn't possible.

Hey @Julio_Pradera

Thank you for keeping in contact.

The steps to change the DNS settings on your Google nest can be found on this article of the Google support page. However, if you have any issues seeing the article, the steps are:

 

  1. Open the Google Home app OscarDC_0-1668382604354.jpeg.
  2. Tap Wi-Fi OscarDC_1-1668382627284.png> SettingsOscarDC_2-1668382646638.png> Advanced Networking.
  3. Tap DNS.
  4. Choose your desired public DNS server. If you choose a custom DNS server, enter a primary and secondary server address.
  5. Tap SaveOscarDC_3-1668382671763.png.

Hope this helps. Let us know how it goes. 

OscarDCModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Hello OscarDC.

 

Actually, this article you're referring to is for Google Wifi and Google Nest Wifi, which are different devices than the one I use, the Google Nest Mini.

Google Wifi and Google Nest Wifi are mesh routers.

Hey @Julio_Pradera,

 

Thanks for getting back to us.

 

Apologies for the error, the article that @OscarDC sent is indeed about Google WiFi and changing the DNS settings on your Google Nest Mini is currently not possible. 

 

We've now forwarded your issue to the relevant team for further review, however we can't confirm when or if it will be addressed. In the meantime, make sure to keep your app up-to-date.

 

Cheers,

MihailYModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Plan

Premium

Country

Finland

Device

Samsung galaxy s22, Desktop, Google nest audio

Operating System

Android 14, windows 11

 

My Question or Issue

When trying to connect to my speaker (google nest audio) the speaker makes the connecting tune but never connects. The speaker starts playing the song I was playing but it never connected and wont change songs if I do. If I change accounts it works completely fine, so the issue is with my account. Help????

 

I have tried to unlink my spotify account from my google account and vice versa. I have factory reset the speaker ( the issue is not with anything else but with my account)

aZgXGr.png

Hi @PeIi,

 

Welcome to the Spotify Community!

 

Could you check if the issue persists with your account over another network? If possible, try creating a mobile hotspot from your phone and connecting to it to see if there's a difference. Something else you can try is changing your the DNS in your router's settings to one of the public DNS' listed below:

  • 8.8.8.8
  • 8.8.4.4
  • 1.1.1.1
  • 9.9.9.9

In case the issue persists, you can create a new account and transfer your playlists by following the steps in this article.

 

The Community is always here if there's anything else we can assist with.

 

Cheers 💚

YordanModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a "Like".
Are you new to the Community? Take a moment to introduce yourself!

Suggested posts