Help Wizard

Step 1

NEXT STEP

Enable Web Player on Edge

Solved!

Enable Web Player on Edge

I can't use the web player anymore for a few months now. I hoped this problem solves itself after some time, but it doesn't. I'm using Edge on Win10. When I go to the Spotify Web Player website it tells me after logging in, that I need to enable the web player, but there is nothing I can do (see attached screenshot). The only button on the website is a link to the support FAQ, where it tells me to download a Microsoft Media Feature Pack for Windows N-Editions, but I don't have a Windows N-Edition and the Media Feature Pack won't install because of this.

 

Any help?

Enable Spotify Web Player.PNG
Reply

Accepted Solutions
Marked as solution

@QuiGon1

 

Alright, that's a rather weird message in this case.
I'll quicly clarify one misinformation I gave earlier - Internet Explorer is not supported. Edge is.

 

Seems like it might be blocked somehow either by antivirus/firewall or even the hosts file.

This shows how to edit the hosts file. There could be entries containing spotify or fastly in them...
(some programs may edit the hosts file for extra security, that's the best explanation I have for finding these entries in mine...)

There are Advanced Settings, and in there, downward, is a slider for allowing sites to save protected media licenses on your device.. Is that on?
Does Youtube work for you?

 

I suppose you have updated everything too, right? Windows updates, especially for Win10 can fix a lot of issues.

If nothing works for you, I'll steal my friend's Win10 machine to find something that should. 🙂

View solution in original post

7 Replies

Hey @QuiGon1,

 

Right now, the web player is supported by the following web browsers:

Chrome 45+
Firefox 47+
Edge 14+
Opera 32+

 

It seems like Microsoft Edge is currently not one of the supported web browsers, so you'll have to use one of the supported web browsers or download the desktop app at https://spotify.com/download. 🙂

MaximSpotify Star
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.

Thanks for responding Maxim, but your answer is contradicting. You list Microsoft Edge as one of the supported browsers and then you say it is not supported?

 

Please clarify.

Hey @QuiGon1

 

Edge is actually a fully supported browser and I can say it works on the local win10 machine.

Internet Explorer should be working too, in my opinion...

 

N and KN versions of Microsoft have media packs available.
What version of Windows 10 are you using?
Could you try opening the web player on another browser?

 

 

It should be working, but it is not for me.

I'm using Windows 10 Education, which is the same as Enterprise. No K or KN version.

I only have Edge and IE available. Same problem on both.

Marked as solution

@QuiGon1

 

Alright, that's a rather weird message in this case.
I'll quicly clarify one misinformation I gave earlier - Internet Explorer is not supported. Edge is.

 

Seems like it might be blocked somehow either by antivirus/firewall or even the hosts file.

This shows how to edit the hosts file. There could be entries containing spotify or fastly in them...
(some programs may edit the hosts file for extra security, that's the best explanation I have for finding these entries in mine...)

There are Advanced Settings, and in there, downward, is a slider for allowing sites to save protected media licenses on your device.. Is that on?
Does Youtube work for you?

 

I suppose you have updated everything too, right? Windows updates, especially for Win10 can fix a lot of issues.

If nothing works for you, I'll steal my friend's Win10 machine to find something that should. 🙂

Thank you! You solved it!

 

I knew immediately, when I read your suggestion about the advanced setting for media license protection, that this is probably the solution for my problem, because I was already suspecting some DRM problems. And it was the solution!

This should probably be added to the FAQ: https://support.spotify.com/us/using_spotify/system_settings/enable-the-spotify-web-player/

 

I also checked the host file, but there were no entries at all. Just the default text that in comments.

 

So again, thank you very much!

@QuiGon1

 

Excellent news, I'm glad this got sorted out! 🙂

I'll ask about adding this step in the article.

 

Have a great week!

Suggested posts