Error code 4 when connected to wifi

Solved!
Reply

Error code 4 when connected to wifi

YargMonster
Music Fan

I recently moved into a new apartment and got  a different wifi router. My roommates and I cannot connect spotify on any of our devices even though the wifi is working perfectly fine in every other regard. The applications says it is offline when connected to wifi, the phone also says offline but works fine when switching to data, and the webplayer does not work. Spotify is working fine and normal when connected to any other wifi. Ive tried some proxy workarounds and none of them have worked.It is looking like I will just have to cancel my premium as there seems to be no working solution out there. 

1 ACCEPTED SOLUTION

Accepted Solutions
Solution!

YargMonster
Music Fan

If anyone stumbles onto this thread with the same issue in the future and you happen to have recently transferred to a new crappy college internet, then call your service provider. Turns out mine was blocked by the isp rather than the router. 

View solution in original post

18 Replies

driveflanger
Community Legend
Hello. It seems that your firewall router is preventing you from connecting. I'd suggest to check your firewall router settings if you know how to do it, otherwise call your internet provider and ask them to do it for you.

YargMonster
Music Fan

I looked in the router manual and there isn't much mentioned about the firewall, but I did see something about NAT settings which I changed from secure to open, however that had no effect and it still said I was offline. I think this may be a proxy problem but I have already tried all of those workarounds and nothing has worked for me. 

driveflanger
Community Legend
The same happens with spotify's web player?

YargMonster
Music Fan

Yeah, https://play.spotify.com/?http=1 does not work for me and neither did changing the proxy settings and editing the prefs file. 

driveflanger
Community Legend
Ok. Make sure you are not behind a firewall which it can be on your router, operative system or even an antivirus. You know I'm behins a router with the firewall disable and I didn't have to NAT any port. It should be easier.

YargMonster
Music Fan

Since spotify works on any other internet it couln't be a firewall on anything but the router. I did control f on the router manual pdf and there were very few mentions of firewall, and there is no way that is described in the manual to toggle it on or off.

I did find a mention of the default factory settings which said

 

Inbound (communications coming in from the Internet) Disabled (except traffic on port 80, the HTTP port)

Outbound (communications going out to the Internet) Enabled (all)

Source MAC filtering Disabled

 

So the firewall is only enabled by default on outbound communications and we have already tried reseting the router which had no effect. 

Dreadlord
Community Legend

Hello @YargMonster,

 

Can you open up Spotify and execute the following command in CMD :

 

 

netstat -a -n | find "4070"

What I am looking for is in the 3rd and 4th column. It should look like this :

 

 

TCP   Local.Address.Is.Here 193.182.7.83:4070      ESTABLISHED

 

P.S. You need to enable outbound and inbound traffic on ports 443, 80 and 4070.

 

If this solved your issue - Mark it as a solution!
Twitter | Website |
What's a Spotify Rock Star, and how do I become one?



YargMonster
Music Fan

when i typed in 

netstat -a -n | find "4070"

It didn't do anything, so i just ran  

netstat -a -n 

and I did not find 4070 on any of the ports.

 

How would I go about enabling inbound and outbound traffic on those ports? I tried messing around with QoS and port forwarding on the router but nothing worked.

Dreadlord
Community Legend

Hello @YargMonster,

 

Can you please let me know what model is your router?

If this solved your issue - Mark it as a solution!
Twitter | Website |
What's a Spotify Rock Star, and how do I become one?



YargMonster
Music Fan
Yeah, it's a netgear r7000 nighthawk

Dreadlord
Community Legend

Hello @YargMonster,

 

Login to your router and Select ADVANCED > Advanced Setup > Port Forwarding/Port Triggering.

 

Click "Add custom service"

  • Service name : Spotify
  • Service type : TCP/UDP
  • External Starting Port : 4070
  • External EndingPort : 4070
  • Check Use the same port range for Internal port
  • Check the device on the list ( 192.168.X.X )
  • Click Apply

Select Spotify in Service Name

Add the following IP Addresses

193.235.0.0

Select Spotify in Service Name

Add the following IP Addresses

194.132.0.0

 

Select HTTP in Service Name

Add the following IP Addresses

193.235.0.0

Select HTTP in Service Name

Add the following IP Addresses

194.132.0.0

 

If you run into problems, let me know : )

If this solved your issue - Mark it as a solution!
Twitter | Website |
What's a Spotify Rock Star, and how do I become one?



YargMonster
Music Fan

Thank you for all this help, I added spotify as a custom service but after adding that Spotify is not showing up in the drop down menu under service name and when I try to enter the IP addresses it "Invalid IP address, please enter again."

 

Heres a screencap 

 

router.png

Dreadlord
Community Legend

Hello @YargMonster,

 

Hm odd, I am not that familiar with netgear router ( I prefer CISCO routers lol ).

Can you try running Spotify now? Adding Spotify as service should allow connection on that port. 🙂

If this solved your issue - Mark it as a solution!
Twitter | Website |
What's a Spotify Rock Star, and how do I become one?



YargMonster
Music Fan
Still not working....
I'm starting to think it may be blocked by my internet service provider.

Dreadlord
Community Legend

@YargMonster just few more things before giving up.

 

Can you confirm how many devices are there on device list ? If you have more then one device, there is chance you are allowing the wrong device. 🙂

 

P.S. You can just click "Add custom service" and screenshot the output.

If this solved your issue - Mark it as a solution!
Twitter | Website |
What's a Spotify Rock Star, and how do I become one?



YargMonster
Music Fan

Yeah I added it to the internal IP on my laptop which is what I'm using right now, the other devices are my roommates and none of us can connect to spotify. 

port forward.PNG

Dreadlord
Community Legend

Hey @YargMonster,

 

Everything looks good.

 

If you wish, you can pass me your IP via PM and I will try to connect to you via telnet on port 4070 to check if the port is working, if there is no success then indeed your provider is blocking the port. 🙂

If this solved your issue - Mark it as a solution!
Twitter | Website |
What's a Spotify Rock Star, and how do I become one?



Solution!

YargMonster
Music Fan

If anyone stumbles onto this thread with the same issue in the future and you happen to have recently transferred to a new crappy college internet, then call your service provider. Turns out mine was blocked by the isp rather than the router. 

View solution in original post

SUGGESTED POSTS