Announcements

Issue enabling spotify web player for google chrome on Mac

Issue enabling spotify web player for google chrome on Mac

JerryGuy

Hello,

I'm using a mac computer with google chrome version 49 and get this screen whenever I try to login to the spotify web player:Screen Shot 2018-01-09 at 9.22.19 AM.pngWhen I go to the support site it brings up this page:Screen Shot 2018-01-09 at 9.22.55 AM.png

The issue is, when I enter the link into my address bar "Protected content" does not appear anywhere under content section of settings and therefore I can not make sure "Allow site to play protected content" is enabled. I have instead allowed plugins from spotify through the plugin section which does appear under the content section of settings, but it does not enable the web player.

 

Is it possible to run the spotify web player through google chrome on a mac? If so how can I enable it?

 

Thank you

Reply
4 Replies

Sebasty

Hey @JerryGuy

 

You're having a pretty old Chrome - my version is 63. That aside, Chrome is supposed to have the DRM plugin installed by default, and it's actually permanently on starting from version 57.

 

Since you're on a version so sold, I believe you can access chrome://plugins and see if you have Content Decryption Module, and if it's enabled.

 

Let me know how it goes! 🙂

SebastySpotify Star
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.

JerryGuy

So I checked chrome/plugins & I don't see anything with that name. Just pdf viewer and flash player

Sebasty

@JerryGuy

 

I couldn't find any (official or safe) places to download this plugin from, so at this point all I can suggest is updating/reinstalling Chrome to a newer version. It should come with the browser now.

 

You can also try Firefox. It relies on the same plugin, but the browser comes with it.

 

Keep me posted. 🙂

SebastySpotify Star
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.

vnguyen1

I had the same issue. This is what I did:

 

I clicked the 3 dots on the type right of the browser --> more tools --> extensions --> scrolled down to 'Spotify' --> selected 'devloper website' --> I went to #2, and made sure my Adobe Flash player was enabled. 

 

After doing that, I was able to use the web player. 

Suggested posts

Env: prod