Issue with Echo Connect

Solved!
Reply

Issue with Echo Connect

LexTertia
Music Fan

Last week my Echo in my kitchen broke. It's name was "Küche". I got a replacement and also called it "Küche". Then something weird happend.  The old device shows up in Spotify like "Küche)(&(/%/=/)=(&(%"  now (see attached picture). I logged every device off through the website, I deactivated the Alexa Skill but I can't get rid of this weird device. I need assistance.

Screenshot_20210625-195750_Spotify.png
1 ACCEPTED SOLUTION

Accepted Solutions
Solution!

LexTertia
Music Fan
I'm not sure if this is a problem with Spotify itself, Spotify-Skill or Amazon but I solved it. I copied the name "Küche��@}L��sL�����" and pasted it as a name in the Alexa-App to one of my others Echos. Then on the phone "Küche��@}L��sL�����" showed up as available on the Spotify-App and I could successfully log off this device from there.



If this problem is on your side then you should give us the possibilty to log off from devices which are not available.

View solution in original post

31 Replies

Eisnah3204
Regular

After adding one new Amazon Echo Dot, spotify connect shows TWO new devices in the „Connect“ tab. 

The actual Echo Dot is indicated as online, I can select it for music playback. 

The second device has some weird symbols in it’s name. It is shown as offline and cannot be removed from the device list. 

No matter which platform I use (iOS, Web, Windows) the duplicate Echo Dot is always shown.

I already removed „Amazon Alexa“ from the Apps page in my userprofile and reset the Echo Dot to factory defaults, but the duplicate remains in the list. 

3C896B65-95D5-4732-B4D2-A7F45121173D.png

Eni
Moderator
Moderator

Hey there @LexTertia

 

Thanks for getting in touch about this here in the Community. 

 

We'd recommend heading over to Settings > toggling the Show local devices only off/on to check if that makes the difference. 

 

If it doesn't, could you try logging out and then logging back in twice? We know this sounds odd, but it's how the app forces a cache refresh.

 

Keep us posted on how it goes.

EniModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 
“Music acts like a magic key, to which the most tightly closed heart opens.”– Maria von Trapp

LexTertia
Music Fan
Show local devices only hides All Echos.
Logging out and in twice doesn't change anything.

Eni
Moderator
Moderator

Hi @LexTertia

 

Thanks for getting back in touch. 

 

In this case, we suggest that you perform a clean reinstall of the app on your phone to check if that does the trick. This one is more thorough than the usual one. 

 

If the issue still persists, would you mind letting us know if this is only happening on your phone or on other devices as well?

 

Lastly, we suggest that you check if the OS of your device has any pending updates. 

 

Keep us in the loop.

EniModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 
“Music acts like a magic key, to which the most tightly closed heart opens.”– Maria von Trapp

LexTertia
Music Fan
I tried all your steps but no change. This device also shows up my PC and the web-Player. On the web-Player I can actually tell Spotify to play music on this device. No music plays anywhere but all my devices say they are playing on "KücheOIUZ)/Z=)TG(IOZU=()". On Android I can then select forget this device but this doesn't work either.
The new device "Küche" also behaves weird. When I relogin to Spotify, it is greyed out, as well as "Küche?)=(U=/(/F(/=)". I can't select it to play music, until I walk over to the kitchen and tell Alexa to play Spotify. Then is available until the next time I reboot this Echo-Device or relogin to Spotify.

Some more details on how this issue started: I had two Echo Dots Gen3 called "Küche" and "Bad". When "Bad" broke, I renamed "Küche" to "Bad" and the new replacement, a Dot Gen4, became "Küche"

Ivan
Spotify Legend

Hey @LexTertia

 

Thanks for keeping us posted. 

 

Just to confirm, is this happening only when your devices are connected to a certain Internet connection? If possible, we'd suggest connecting them to a different network. 

 

If it works with another connection, it’d be a good idea troubleshooting further the original one (for example, by restarting your router). You can also reach out to the service provider of the original network so that they can take a look on their end as well.

 

We'll look out for your reply. 

LexTertia
Music Fan
Hey Ivan,
I just restarted my router. But no change and then I switched from my VDSL to 4G. Still same behaviour. I'm not sure if you understood the Problem. It's not that anything is not working but the device "KücheJ=)&Z/(R)/(=)(ZU?=)" which I can't get rid off.
Solution!

LexTertia
Music Fan
I'm not sure if this is a problem with Spotify itself, Spotify-Skill or Amazon but I solved it. I copied the name "Küche��@}L��sL�����" and pasted it as a name in the Alexa-App to one of my others Echos. Then on the phone "Küche��@}L��sL�����" showed up as available on the Spotify-App and I could successfully log off this device from there.



If this problem is on your side then you should give us the possibilty to log off from devices which are not available.

View solution in original post

Ivan
Spotify Legend

Hey @LexTertia

 

Thanks for sharing the good news with us. 

 

We're glad to hear that things are now working properly for you. If you have any questions we're always one post away. 

 

Еnjoy your music! 

LexTertia
Music Fan

Seems to be a new problem, I had a very similar issue yesterday.

Try the solution from my thread

 

Copy paste from the Spotify is a bit tricky. So basically rename one of your other Echos in the Alexa-App to:

Echo Dot (Schwarz)�#��3)R�

 

then "Echo Dot (Schwarz)���#��3)R�" should be white and available again. Click on the 3 dots and select log off. Now you can give it a proper name in the App again. If this works you should click on "me too" on my post to give it some attention, I'll do the same on your post.

LexTertia
Music Fan

Eisnah3204
Regular

Hey!

Thanks for your suggestion!

 

I tried your steps but had no luck unfortunately. The device showed still twice with the weird name in the device list. 

I dug a little deeper and checked the source html of the spotify connect window in chrome. 

The „faulty“ Echo has an invisble symbol in the name, which isn‘t displayed in the iOS app. Even after I copied the whole string from the Chrome developer window and renamed the echo, it still would show two.  

Guess I have to live with it for now 😞

Eni
Moderator
Moderator

Hi @Eisnah3204

 

Thanks for reaching out about this.

 

First up, it's well worth running a clean reinstall to get rid of any cached files that might be causing trouble. This one is more thorough than the usual one. 

 

If the issue still persists after that, could you go to the app Settings > toggle the Show local devices only off/on and check if that makes the difference?

 

Also, just to confirm, is this only happening on your phone or on other devices too?

 

Keep us posted.

EniModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 
“Music acts like a magic key, to which the most tightly closed heart opens.”– Maria von Trapp

Eisnah3204
Regular

Hey @Eni

 

1. Cached files deleted

2. when „show local devices only“ does hide the device. 
3. it happens on my phone (iOS App), Windows-App and Web-Player. 

Ver
Moderator
Moderator

Hey @Eisnah3204,

 

Thanks for getting back to us 🙂

 

It's a good idea to try unlinking the Echo from your Amazon Alexa account. Then you can also factory reset the Echo Dot to see if anything changes.

 

In case it disappears when "Show local devices only" is turned on, it could be that outside of the local network environment it is stored and connected to the account with this odd name.

 

We're not sure on which end of the integration this occurs. If we get more reports we can try and collect the data in order to investigate this further.

 

Let us know how it goes. 

VerModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
"Difficult roads often lead to beautiful destinations." ―Zig Ziglar

Ivan
Spotify Legend

Hey @LexTertia

 

Thanks for keeping us posted. 

 

We've merged the two threads in order to keep track of this issue in one place. This way other users experiencing the same could easily find the thread and report their experience. 

 

Feel free to keep us updated here if you notice any changes or issues. 

 

Cheers! 

kevink98
Regular

Hello,

 

I just set up a echo dot and got a minor naming issue:

I have two entries for one echo dot. One which is correctly named and usable. And a second entry, but with weird symbols attached and i can't select it.

 

How can i get rid of this optical issue?

 

Thanks in advance,
Kevin!

Screenshot 2021-07-06 at 01.50.00.png

Eisnah3204
Regular

Hey!

 

I am having the same issue. 
There was a similar thread recently with a possible solution. 

https://community.spotify.com/t5/Other-Podcasts-Partners-etc/Issue-with-Echo-Connect/m-p/5227973#M80...


You could give it a try. 

Unfortunately, this didn‘t work for me. 

kevink98
Regular

I don't know how long it will last, but as of now, this hint works for me too!

 

Thanks! And hopefully Amazon/Spotify will solve it soon.

 

Just out of curiosity, are you all using the Echo Dot 4.Gen (maybe also with clock)?

 

BR
Kevin

SUGGESTED POSTS