Help Wizard

Step 1

NEXT STEP

FAQs

Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...

VIEW ALL

Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...

VIEW ALL

More devices button is gone

Solved!

More devices button is gone

I updated the Spotify-app on my Ipad (I am a premium user) and now the ”more devices” ("meer apparaten” in Dutch) button is gone when I want to connect to a device (devices available)

I normaly connect to my Denon hifi receiver. Normaly I open “connect to a device” and then I have to click on “more devices” in order to select my hifi receiver. The hifi receiver is/was never available in the main screen “connect to a device”/“devices available”. Now the button is gone and Spotify can’t find my Denon receiver anymore. 

Does anyone has the same problem, or can someone tell me why the “more devices” button is no longer available? 

 

Thanks!

Reply

Accepted Solutions
Marked as solution

@DMaessen

 

Please do the following:

 

  1. Find out if there is a Firmware update available for the receiver
  2. Reinstall the Spotify app using these instructions
  3. Unplug the receiver and router for a few minutes and connect everything again
  4. Confirm if the receiver is connected to the network by trying to use a different internet service
  5. Try to play something on the receiver again

Let me know if that helps, thanks!^^

Peace

View solution in original post

10 Replies

Hey @DMaessen! Welcome to the Spotify Community. ^^

 

That's odd.

The feature should be there as usual. Could you try to check if that happens on other devices as well? And keep in mind that both of the devices need to be in the same Wi-Fi network. ^^

 

Let me know how it goes!

Peace

Thanks you for your reply!

I tried it on my iPad and on my Nokia 7.1 on both devices the button was not there...

They where both on the same wifi as my Denon by the way...

IMG_20190305_184922.jpg
Screenshot_20190305-184843.png

@DMaessen

 

I've escalated your issue to the support.

I will reply on this thread with help soon. ^^

 

Peace

Marked as solution

@DMaessen

 

Please do the following:

 

  1. Find out if there is a Firmware update available for the receiver
  2. Reinstall the Spotify app using these instructions
  3. Unplug the receiver and router for a few minutes and connect everything again
  4. Confirm if the receiver is connected to the network by trying to use a different internet service
  5. Try to play something on the receiver again

Let me know if that helps, thanks!^^

Peace

Thank you very much! After following your advice the “more devices button” magically reappeared! I hope it keeps working 🙂

@DMaessen

 

I'm glad it's working for you again. ^^

What can I say except..

spotify:track:1gAqEg0gMyxJrM4DOOaYEA

 

Screenshot_20240229-221304.pngI'm having the same issue. And after following all of these steps it's still not working.

Hey there @dani-p,

Thanks for reaching out in the thread!

Just to check, how are you trying to link to the speaker? Are you using Connect or Bluetooth?

It would also be helpful if you could let us know the make & model of your speaker, as well what mobile device you're using.

We'll keep an eye out for your reply.

MariaModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a "Like".
Are you new to the Community? Take a moment to introduce yourself!

So I was finally able to connect it through bluetooth, but unfortunately,
Alexa will still not play Spotify. She tries to. I will say, "Alexa Play
Music", and she will say, "Playing music through Spotify" and then nothing
happens. Just radio silence.

I have really tried everything to make this work. And, from looking at your
forum, it seems this is not a me problem, but an everyone who owns an Alexa
problem. It's odd that your company allows Amazon to advertise that you can
play music from Spotify on the speaker, when you clearly cannot.

I am using a Pixel 4
All apps are up to date
Alexa is bran spankin' new (a 5)
I've disconnected, reconnected, removed apps, redownloaded apps, patted my
head, rubbed by belly, stood on one foot with my eyes closed, prayed to the
Alexa gods, but it does not work.

Very disappointed with this user experience.

Thanks for the additional info @dani-p!

We had a look into this, and what you're experiencing sounds similar to what's mentioned in this thread. Feel free to have a look and leave your details there, should it be what you're experiencing as well. This will help us check this further with our teams.

We're just a post away if you have any questions!

MariaModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a "Like".
Are you new to the Community? Take a moment to introduce yourself!

Suggested posts