Announcements

My embed playlist is not updating

My embed playlist is not updating

shortyhouse

I just created a new playlist to embed in my website, but everytime I add a new album in the app, it does not update in the website.

I already purged Wordpress cache but it doesn't change anything.

Isn't it a dynamic URL? Should I update it everytime the playlist content changes?

 

Thanks

Reply
4 Replies

Ver

Hey @shortyhouse,

 

Thanks for posting here 🙂

 

We'd suggest you give the steps mentioned here a go to see if anything changes.

 

We'll be right here if you have any questions.
 

 

 

 

Ver Moderator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

thejetsetter

@Ver: This link is dead. I'm having the same issue. Can you try again with another solution?

 

Alex

Hey there @thejetsetter,

 

Thanks for flagging this.

 

I've updated the link in @Ver's post. You can also access it here. You can find more info on embeds here.

 

If you have more specific questions you can look for answers or create a new topic on the Developer Forums

 

Hope this helps.

AlexModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

spookidiga

@shortyhouse and @thejetsetter I understand those "answers" are not helpful.  I'm running into the same issue myself and doing some debugging.  If you grab the Spotify URL in your embed code, and visit the Spotify page directly, does the Spotify page reflect the latest changes to your playlist?  If so, and your website does not, it may be a caching issue.  If you already tried to a HARD REFRESH of your site in your web browser to force a download of the latest content, and your site is still not updated, the stale data is likely due to a server side cache with your web host or CDN.  You will need to contact your website admin / webhost to get that cache flushed.  Going forward, adding code like this to your site may help:  

<meta http-equiv="Cache-Control" content="no-cache, no-store, must-revalidate" />
<meta http-equiv="Pragma" content="no-cache" />
<meta http-equiv="Expires" content="0" />

 

 

Suggested posts

Env: prod