Help Wizard

Step 1



Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...


Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...


Play Button stopped working

Play Button stopped working

Hi There, 


The Play Button is broken. It doesn't change stop/play state visually, also and the progress bar is not updated. It doesn't work anymore on any website, including spotify's own. Take a look at the example in de developer section. Also this example is broken.


Hope to hear soon. 


Kind regards, 

Maarten Rein

9 Replies

I have this problem also. When I try to select any album play button next to the song track, nothing happens. 

In the debug window I see these errors: 


Screenshot 2023-07-07 at 2.51.44 PM.pngScreenshot 2023-07-07 at 2.51.20 PM.png


I've been using the web player for a long time and I've disabled all web ad blockers. This happens on Chrome and fresh install of Firefox, so this is not a caching issues. 

The fraud token is interesting, but not sure if that is related.

I can play the master album play button and use the skip one song forward or backward as all these buttons are working.

Hey @foozlereducer,


Thanks for your reply here and for the info shared. 


Just to confirm, is the same happening when using the desktop app on your computer? It'd be awesome if you could check. If possible, you can install the app on your device to check if you can replicate it from there. You can download the app from our website here.


On another note, we'd suggest checking if perhaps the browsers you're using have any pending updates. If yes, try updating them to see if you notice any differences in this behavior.


Lastly, can you replicate this same behavior or a different computer? It’d be awesome if you could check. You can ask for the computer of a relative or a friend to open your account there and check.


Keep us in the loop!

Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.

Hi @AlejaR,


I am not allowed to install the Spotify app as it is a work computer; otherwise I don't have a home laptop or any device other than a phone where it will be a different type of app from the web.

I am using the most up-to-date Chrome and Firefox stable releases. 

I will ask my wife to try on her iPad.


Hi @foozlereducer,


Thanks for keeping in touch. 

We understand that you don't have another computer to try with, but you can check from your mobile device using the Web Player. If the app opens up when going to the Web Player from your browser, try doing it from an incognito tab. On another note, would it be possible for you to try with a different internet connection from your work computer?

Lastly, send over a video or recording of the issue.


We'll keep an eye out for your reply!

Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a "Like".
Are you new to the Community? Take a moment to introduce yourself!

I have the same issue. It happens on multiple computers, or in any browser.


Exactly as described by others. The play button on individual tracks do not work when you're viewing an album, but do work on playlists.

You asked if this happens on the web player through a mobile device. You cannot perform the same action on the web player through mobile. Those play buttons do not exist. You only have the shuffle play button for the entire album.

You asked about the desktop app and this is where it gets interesting. If I open the web player and I play some tracks and I open the desktop app the desktop app knows that my active output should be the web player, so if I attempt to play something via the desktop player the web player is being controlled and is the output.

This also produces the same issue. Individual tracks cannot be played, but the album play button or individual tracks on playlists work.

However, if I close the web player or if I select the desktop app as the listening device you *can* play individual tracks from an album. And that goes both ways - I can go to the web player and select the desktop device as the listening device and I can play tracks.

Hi folks,


We thank you all for the info and your replies in this thread.


Sounds like you’re seeing a recent change we’ve made. We’re always testing possible improvements, so you or someone else may see something new or get a limited feature temporarily on the app. We’d love to hear your feedback so we can pass this along to the proper team. We appreciate your comments as it helps inform our decisions going forward.


Additionally, you can try using the desktop app. You can download it from this link. On another note, @bobbobby, it is normal for the app to recognize you're playing on the WebPlayer and let you control the playback from there, so you can simply change the device you're playing on from the device tab.


Hope this clears things up. If you need a hand with anything else, we're always a post away.

Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a "Like".
Are you new to the Community? Take a moment to introduce yourself!

Yeah, no, this is not some new feature. This is functionality that used to work but doesn't any longer. And remember it also doesn't mark the track as playing when viewing the album should you play it from another source like a playlist or the album's play button.

Those aren't new features, they're bugs.

@Susan_GP you say that it is normal for the app to recognise the web player - I know that, and I am giving you that information because it is pertinent to the issue.

If you control the web player through the desktop app the desktop app does not permit you to play a track. But if you control the desktop app through the desktop app it does work and also if you control the desktop app via the web player it does allow you to play tracks.

So we can conclude it is not an issue with the web player specifically, because the play buttons do work - just so long as you aren't controlling the web player, and the play buttons cease to work in other apps if that app is controlling the web player.

As @foozlereducer originally showed, when a request is sent to send the command to the web player to play a track, the back end returns an error.

Same problem for me, little play button next to individual tracks on albums doesn't work, and when an album is playing it doesn't show any track as highlighted. Using Firefox version 115.0.2 and tried disabling various addons, nothing impacted it.


Also tried the desktop version, not sure if it's related but it doesn't play either when clicking the little play button next to a track but it says "Spotify can't play this right now. If you have the file on your computer you can import it."

Clicking on the little arrow next to individual tracks does work in playlists though.

Today when I tried the album play buttons they worked! Not sure if this is a permanent fix or I got lucky 😉 

I did check the chrome inspector and it no longer shows an error.

I am cautiously optimistic that this issue has been resolved.



Suggested posts