Help Wizard

Step 1


Streaming with Roberts Radio

Streaming with Roberts Radio

Just bought a Roberts istream 93i radio, which is meant to stream Spotify seamlessly from ipads, iphones etc, if you have a premium Spotify account, (which I do).

The internet radio on the Roberts works fine, so it's connected to the router fine. I can play Spotify from my ipad to my ipod fine. I just can't stream from the ipad or ipod to the Roberts.

I phoned Roberts, and the first call resultedin a new radio being sent out. Same thing happened. Phoned Roberts again, still no idea, and said they would call me back, but they didn't. So I'm still here without my streamed Spotify...

Does anyone have any idea why this might be happening? There is nothing appearing in the connect box within the Spotify app, so it's as though the device and radio aren't recognising each other, although both are connected to same router.

21 Replies

On your Radio, do you have the "Keep network connected" option enabled in the settings?

Spotify Community Mentor and Troubleshooter

Spotify Last.FM Twitter LinkedIn Meet Peter Rock Star Jam 2014

If this post was helpful, please add kudos below!

Yes, I did that, as it said in the brochure, when I first tried it. Nothing. 😞

I've had the same problem, finally resolved this morning.
1) Whilst radio is on, pull mains lead out of radio
2) Download latest Spotify app on iPhone. Whilst this is loading, put the mains lead back in the Roberts and let it re-boot.
3) Open Spotify on your iPhone, and start playing a downloaded song. Choose Spotify on Radio.
4) At the bottom of the iPhone screen on the RHS Is a speaker icon; press it and it will come up with your iPhone details, and about 30 secs later the Roberts iStream logo will appear. Press it and your music will play.

It took me a day of playing to get it to work, and this was the way I eventually did get it to work.

Thanks this worked straight away for me 🙂 Thanks



I have the same problem. I've gone through all the steps you suggest, but i can't see a speaker icon on my iphone. can you explain? i've got an iphone 5



Never mind . . .   just found it! Only took me 3 days!


worked!! thanks a million!!

Just to say that WoolPackBoot solution also works for Android!

Does this work all the time or do you have to g through this every time you switch it on?


I tried your method. No microphone on  rhs and roberts just kept 'waiting for users' on screen.

emailed Robertts Radio twice with no response so I think they know there's an issue with connectivity to Spotify.

Has anyone else got this issue? I've wasted 2 month of aging for Spotify Premium but it worked with the free trial........

puzzled of Tonbridge


Been advised by Roberts to set wifi to be not connected all the time?

Excuse my ignorance, but what is "RHS"?


Also what is RHS? I am looking for the speaker icon on the iPhone and don't understand this step. Can someone do a photo please? My radio connected fine and now won't work at all thanks

Me too. Can't connect although the Roberts shows up as a device on my phone. Did connect during free trial ok?!

Yes. It worked ok during the free trial but not when I started paying.
We've managed to sort it now after doing a factory reset then reinstalling the wifi connection.
It's perfect now.
Hope this helps.

Yes. It worked ok during the free trial but not when I started paying.
We've managed to sort it now after doing a factory reset then reinstalling the wifi connection.
It's perfect now.
Hope this helps.

Thanks Sue, I've tried that to no avail. It just keeps showing waiting for users every time I try. The device appears on my phone on the Spotify app but won't connect. Did you ever discover what RHS was and the icon somebody mentioned?

Try unplugging your Roberts radio once you've reverted to factory settings.
Then delete Spotify and reinstall. I think that by reading Spotify Forums eventually helped me suss it out but it wasn't easy and surely there must be a problem here. Now I've sorted it, I get the best music on a fabulous tone radio. Worth pursuing. Don't give up. It took me months to sort.

Thanks. Will try again.

Suggested posts