Announcements

Web Player Not Working with Mozilla on Linux

Web Player Not Working with Mozilla on Linux

When trying to play the web player for firefox on a linux, it is saying the following:

 

"Firefox is installing components needed to play the audio or video on this page.  Please try again later"

 

I updated to a version of firefox that says is suitable. I have checked that DRM is enabled, untoggled it, and put it back on.  I have also cleaned cache and history, as well as tried it in a private window.  The issue was not resolved.

 

Any other ideas??

Reply
8 Replies

I'm using Fedora with Firefox 55. The Spotify web player is working flawlessly. So it seams not to be a general problem with Spotify an Linux.

 

I also have this issue. I have also tested a fresh firefox with 0 extentions

Which version of firefox are you running?  Or which version did you upgrade to?

 

I also tried both uinstalling and reinstalling and it still didn't fix the issue.  Curious as to the other guy in this chain, who isn't having issues with his OS and firefox spotify web player...

 

 

 

 

Mi exact Firefox version is 55.03 from the oficial Fedora repository. I've installed a couple of addons. I didn't configured anything, it just works.

 

Could it be, that you haven't installed the Widevine CDM for the DRM? Have you activated "content with DRM" in preferences/content?

 

I attach you a screenshot of spotify web in my Firefox.

Bildschirmfoto von »2017-09-26 20-07-54«.png

Thanks for your input!

 

Yes, I have made sure DRM content is active.

 

How do I install the WIdevine CDM?  I've tried searching for this add-on and I don't see it litsed as an option.

The widevine plugin should be listed in about:addons / plugins

I already had it installed befor I started using Spotify Web for amazon prime video and netflix.

I think it was installed either when y activated drm content in settings or when y used netflix the first time.

 

SO both the widevine and DRM enabled.  still no dice on getting the web player to work.  Even tried to install the app client on the machine.  That also won't work.  I dont know what is going on with spotify but man, this sucks.  My discover playlist also hasn't updated in forever.  This was an issue I had a while ago, which was then corrected, and now it's back.  I'm so over paying for something that doesn't work!!!

 

Which distro are you running? This could be due to a missing audio codec. I had to add the RPMFusion free repo on my Fedora 26 and install the ffmpeg package. Otherwise songs just wouldn't play without any obvious reason.

 

You could try to open the web console in Firefox (Ctrl+Shift+K) to check if any errors are logged when you play a song. I got the following message showing the missing codec.

 

The video on this page can’t be played. Your system may not have the required video codecs for: audio/mp4; codecs="mp4a.40.2"

Suggested posts