Help Wizard

Step 1



Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...


Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...


Web Player won't work on Chrome


Web Player won't work on Chrome






Dell Inspiron 14 Chromebook

Operating System

Chrome OS


My Question or Issue

Web Player will not load on Chrome, instead only showing a blank black page. (Attached) Since I'm on Chromebook, Chrome is my only option. Tried clearing cookies but alas, no luck. Used to work perfectly fine, not sure what the issue is. 

Screenshot 2019-10-09 at 2.28.28 PM.png

Accepted Solutions
Marked as solution

Hey there folks,


Thanks for reposrting this here in the Community!


This sounds like something our tech teams were looking into however it should be fixed now. 


If you're still having troubles, we'd recommend making sure to clear your browser's cache and cookies and give it another try. 


If you're using a Chromebook, you can also make sure that your browser is on the latest version available - you can follow the steps here to double check that.


Keep in mind that if you are using a Chromebook managed by your school/university/workplace etc., you'll need to reach out to your network administrators to request for the Chrome update on Chromebook.


Let us know how you get on! We'll be right here if you need more help.


Have a lovely day 🙂

Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself! 

View solution in original post

41 Replies








Operating System

ChromeOS 77



My Question or Issue

The player for ChromeOS hangs. I uninstalled Spotify from my computer and can now repro by going to and clicking on "Chromebook". At that point the page doesn't load and the below error appears in the console:

Screenshot 2019-10-09 at 9.54.48 AM.png

The ChromeOS player has worked in the past couple weeks (can't remember exacly when I last used it).


EDIT: A better repro is to go to and click "Open Web Player". Same error message as above.

This also is an issue for me. Attempting to use the webplayer on a chromebook, and I get a black screen and the same error in chrome's network console. This chromebook does not have access to android apps, so the web player is the only way to access spotify, which now does not work. Worked yesterday just fine.

Ditto for me. Worked fine on my chromebook (acer, Chrome OS version 77.0.3865.105) yesterday, blank screen today. Restarting didn't work, opening in app version and browser version both don't work, clearing the cache didn't help. 

App still works on my Android phone, desktop version still works on my office PC, web version still works in chrome on my office PC. All of these devices are currently logged in to the same wifi network. It's only my chromebook that shows nothing atm.


Edit: looks like the folks on this post are having the same problem


Edit 2: I've tried opening on my chromebook in a different wifi network and it still won't connect. Blank black screen.

Same problem here. Have tried the usual fixes. Could it be something to do with the new Chrome OS and expiry of support period for our machines?

Yep I am having the exact same issue. Tested on 2 different Chromebooks.


See the following screenshot for the JavaScript error thats happening:

Screenshot 2019-10-09 at 20.56.13.png

Same here today. In chrome on chromebook. Just after update chrome os.
"" only gives a black screen (BSOD :-)).
The error visible in developer tool (like in the screenshot above):
web-player.a7c412a8.js:formatted:14731 Uncaught (in promise) DOMException: Failed to execute 'add' on 'DOMTokenList': The token provided ('Chrome OS') contains HTML space characters, which are not valid in tokens.
Happy debugging!
PS Tried playing a song on android app and on chrome on PC: no effect on chromebook. Deleted history & cookies on chromebook: no use.

I have the same problem on an ACER Chromebase. Worked great until today

We're all having the same problem over in this post too: 

Definitely think the new Chrome Update must have something to do with it. Never any issues before and people with different hardware but still using Chrome are having the same issue. 

Yes, this same issue here on LG Chromebases as well.

This has happened to me too. My Chromebook is managed and all the posts have been 2018 and below. This is really annoying for someone who came from Youtube Music so I might be switching back to it.

So, I did a bit of research and this link might help for being able to use the Spotify web player

You will have to back up your data to the cloud (probably on Google Drive) and re-login I'm not sure if this will work because I haven't tried it yet and since my Chromebook is managed I'm not trying to risk losing my data. (This might not work on other Chromebases because this is from the Samsung site).

Sadly I got the same problem on my Chromebook Samsung pro.

The same exact thing is happening with me.

I'm having this issue as well :))
Is there any way to fix it or do we just wait?



Same issue here but since I use a Asus C300 it doesn't get any update for Chrome OS since August so I'm not sure it's an update issue on Chrome's part. Same error message. Looks like someone coded the version for 'Chrome OS' with a space and it's not working anymore but we're so few it's going to take a while...
People with this issue please show yourself with a like at least so Spotify acknowledge us!! We don't have an app, can't run the web player anymore..... Help?!

It would work on other Chrome OS since this is simply the powerwash feature. You can do one by going to settings, advanced and powerwash (see Google help here It brings your Chromebook back to factory settings. But it'll update once it starts again so I'm not sure it'll actually help with our problem and it's a lot of trouble for people who don't own their Chromebook or have quite a lot of data stored outside the Cloud.

My Spotify is not working it is all black on my Acer Chromebook 15, and when I use the app it does the same thing. So now I have to use my phone which my phone hates Spotify altogether. It closes it when I don't want it too plus there's way too many ads on the phone than there is on the web, that's why I use the website for Spotify.

Screenshot 2019-10-10 at 4.51.59 AM.png

Suggested posts