Announcements

link error with Amazon Echo

Solved!

link error with Amazon Echo

Just set up Amazon Echo and upgraded Spotify to Premium.  All running well via Sonos.

However, Amazon and Echo will not link and just says "an error ocurred while attempting to link Alexa with external provider"

Any help happily accepted?

Thanks

Reply
48 Replies

For my part I had to create a new amazon.com account with an address in the United States. Then I recorded again my echo dot with this new account amazon and everything works since with Spotify 😉

Hey Guys, 

 

I just made it work suddenly. The solution was to play around with the languages. That means I logged out from Spotify. Logged in again. Had some problems with the log in and had to change the language to US English and to enter my adress, with postal code and street. Then I could log into spotify again. After that I chose Spotify as my standard player, but it did not work. So I changed back the language into German and worked. Hope I could help someone. Cheers. 

THANKS! IT Worked!

I've just spent a good 8 hrs on trying to get spotify to link no success check the web for anything until I stumbled on this post    Thanks up and running 

 

Great news! Glad you found something that works! 🙂

I have the same issue! did you find an answer?

That works for me, thanks!!!!

After I did everything it told me to do i press okay and it takes me to this. Why is it in a different langauge? Everything else is English
image.jpg

Same here, worked 2nd time around.

Thank you so much! was loosing my cool trying to figure this out.

OH DEAR LORD! This fixed it for us! Thanks so much!

You are a genius THANKS!!
one note for the techo challanged- the SETTINGS is in the right side menu

Change Language on App to English US (I live in London) this worked for me

Guys, try to go to Spotify and Revoke Access to Alexa and re-try the setup. It works for me after I installed a new Echo on top my Echo Dot.

Have fun!

My issue was caused by the EchoDot being on the 5G Wifi and the iphone I was using to configure being linked to the 2G Wifi.

 

Once I made sure the iphone was connecting to the same wifi network as the Echodot it worked fine via the App.

I know this is going back to 2016 but just for anyone that has the same fault I had the same error and it was the email address I had saved on Spotify wasn't the same as I was using for Alexa and when I updated so that both were the same it connected ok and all working ok now 🙂

Have just done the same on a Mac (Chrome), worked perfectly.

This error continues to happen CONSTANTLY. For some reason my two echo dots seem to connect more regularly and are viewable in the available devices list (but not 100% of the time) while my brand new 2nd gen Echo is almost never available or drops out of availability in the middle of listening to a song.

 

The only solution I can find is to unlink and relink the Spotify account in the Alexa app, but I have to do this constantly. I’m talking every single time I want to play music only Echo. 

 

Im highly disappointed in this software. It’s making me want to return my Echo and cancel my Spotify. Honestly, very disappointing. 

THANK YOU SO MUCH !!!!!!! (Capital letters are not an error, its just I was looking for solution and never imagine the solution without you!)

Suggested posts