Unable to process payment

Unable to process payment

nzgrover

 I have (had) a family plan, today we got an email saying "we couldn't process your payment". I am paying via credit card. The credit card is still valid. I tried to re-enter the credit card details but just get an error message saying "failed to process...". My wife tried her credit card and got the same error message. Is this a known issue? What can we do here. I don't have a paypal account and will not create one.

 

Reply
4 Replies

nzgrover
Just replying to myself to say:
In New Zealand.
Windows 10.0.19043
Tried in Firefox, then installed Chrome and tried there. No difference.

MafeG

Hi there @nzgrover,

 

Thank you for posting on the Community and welcome!

 

If you've tried to make the payment many times during the same day, we suggest you wait 24 hours until you try again. 

 

In case the issue persists, could you try using a different device and an incognito window? If possible, also try connecting to a different internet network.

 

If it doesn't work either, please contact the folks from Customer Support who can take a deeper look into your account and its payments. Here is the link.

 

Let us know if you have any questions.

MafeGModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

nzgrover

I don't see how what browser I used, time of day, etc is applicable. Payments were made using this credit card for years, then it suddenly stopped working. I'll contact support.

Jeremy

Hi there @nzgrover,

 

Thank you for your reply and confirmation.

 

You can contact out customer support here.

 

Let us know how everything goes.

 

Have a great Friday and a wonderful start of your weekend 🙂

Take care!

JeremyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Live, love, laugh and listen to music 🙂

Suggested posts