Help Wizard

Step 1


Local files not visible in My Library

Local files not visible in My Library






Macbook Pro late 2019

Operating System

Big Sur


My Question or Issue

According to this post, I should find my local files under my library:


However, I have local files on both the desktop version and on my ios ( iphone13 pro device )  but it's not showing under my library. I have added more files and wanted to create a playlist with the new mp3 files. 


Any idea?


1 Reply

Hey there @tord00


Thanks for reaching out about this here in the Community. 


First up, we suggest that you head over to the app settings on the desktop app > toggle on Show Local Files > toggle on all the sources that appear there.


Additionally, could you go to the settings of the Spotify app on your iPhone, scroll down to Local Files and make sure Desktop Sync / Local audio files is enabled? 


If the issue persists after following those steps, it's well worth running a clean reinstall by following these steps on your devices to see if that helps.


Keep us posted on how it goes.

Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
“Music acts like a magic key, to which the most tightly closed heart opens.”– Maria von Trapp

Suggested posts