Announcements

Saved songs are no longer under Artist in "Your Library"

Saved songs are no longer under Artist in "Your Library"

ithlei

 

Plan

Premium

Country

U.S.A.

Device

Dell XPS 13

Operating System

Windows 10

Spotify Version

1.1.54.592.gc0b20638-a

My Question or Issue

Cannot see saved songs under Artist in "Your Library" on desktop--clicking on their profile or on the play button just starts playing from their General Artist page. This issue seems like it is a perennial one, as there are a bunch of help threads about it--the most recent one, marked as fixed, told me to make a new thread if the problem was seen again, so here I am. I will note that everything is working as it should on my Android app, this only seems to be a desktop/web player problem.

 

Obviously, this is super frustrating when you only like some songs/albums from an artist and don't want to just start on their most popular, or with classical composers who have a bajillion songs and you've carefully curated which recordings you like best.

 

Reply
1 Reply

CarlosE

Hey there @ithlei,

 

Thanks for reaching out to the Community and welcome!

 

We're sorry to hear that your experience with the app hasn't been as expected. We can confirm that this option isn't available at the moment in the New Desktop Experience, which is the one you're using.

 

We appreciate your feedback on the matter, though, and encourage you to check out this thread. There you can leave your thoughts and feedback about it so it gets more visibility. The right folks are constantly monitoring that thread and taking the feedback into consideration for upcoming updates.

 

We really value your comments as it helps us improve the app and the overall experience, so thanks for sharing them with us.

 

If you have any questions or need anything else, we're always a post away.

 

Cheers 🙂

CarlosEModerator
 
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 

Suggested posts

Env: prod