Help Wizard

Step 1



Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...


Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...


App shows random serial numbers instead of Alexa/Echo device names

App shows random serial numbers instead of Alexa/Echo device names

I have devices all through the house, they are all named and for a time they all showed up in the Spotify app,  but now almost all of them show a really long serial number (a mix of letters and numbers) so I can’t tell which device is which.


Any ideas on how to fix?

16 Replies

I have the same exact issue after updating spotify. Super annoying. Spotify tech team - any solutions on this??? 


I've had the exact same problem....if you deregister the Echo Dot and then set it up again it fixes the problem for a little while but then it seems to go back to the random string of numbers and letters. I've also noticed that it doesn't seem to do this when you are controlling the Echo Dot through the app itself but once you switch to voice commands it will change the name.


Fix image.JPEG

Here is a Reddit thread of people experiencing the same issue:

Thanks ivanripley22 !


I did what the guy on Reddit did, and it worked 


in other words, rename your devices in the Alexa app with a 1 or something at the end 


then check it’s back in spotify app, then remove the 1 




Family Premium





Operating System



My Question or Issue

"Listening On"  used to show all my devices by name, whether they were, laptops, PCs, Google or Alexa devices.    Recently the names of my Alexa devices have disappeared to be replaced by strings of numbers and letters which are NOT Mac  addresses.  (No idea what they are !!)   If I select the "numbers"  the various Alexa devices respond, but it is really annoying not knowing to which device the numbers apply.  Is there a good reason for this?  Can we go back to displaying names please?





But this bug now exists for weeks, not to say months (first google result for this problem here roots from 2018!) - where is a permament solution, not a workaround I have to repeat every several days?
Really annyoing.

Hey there @johnf52,


Thanks for reaching out to the Community about this. No worries! We're here to help.


First off, we suggest deleting the Alexa app and reinstalling again. It would also be great if you could unlink your Amazon and Spotify accounts. Once you link them again following the steps in this article, the names should be displayed correctly again.


If that doesn't do the trick, could you get back to us with a screenshot showing how your Alexa devices are appearing in the list? Once we have that, we can investigate this further.


Keep us in the loop 🙂

Hi Peter.

Deleting the app did not achieve anything. As you know the Alexa data is
cloud based, nothing is stored in the app or on the phone, it is merely a
"conduit", so if the app is installed on a different phone the account data
is still "there".

However unlinking and linking Spotify did change some things.
First of all, my account name now appears as a string of letters and
numbers, though only on the phone not on my web account (Spotify) Secondly
as you can see from the before and after screenshots; "before" shows all
three Alexa devices showing as alphanumeric strings, "after" now shows two
of them identified as Echo Dot but with no names (or locations in my my


Hi @johnf52,


Thanks for following our troubleshooting steps and the additional info!


Seems like your screenshots weren't successfully uploaded, though. It would be great, if you can try attaching them again, so we can look into this.


The string of letters and number you see as your account name, indicates that you've got an automatically generated Spotify username and either a manually chosen display name that appears in the app or your account is linked with Facebook, in which case your Facebook name is displayed instead of your username.


Looking forward to see your screenshots 🙂

Screenshots attached again

If they dont come through, please give me an alternative "proper" email
address, as this "Reply" format address may be blocking the attachments.


Hello again John,


Unfortunately there are still no images attached to your post. Do you mind trying one more time, maybe from another browser or incognito window


I'm afraid it's not possible to send attachments via email to the Community. Just make sure your files don't exceed the max. size of 5 MB and wait until the upload is complete before posting your reply.


Thanks in advance for your efforts!

Same issue. 3 echo dots, all with GUIDs instead of names. Renaming via the Alexa app only works temporarily, then new GUIDs show up in Spotify.


Not sure if this is the fault of Spotify or Alexa, but would really like it fixed!



What I have been attaching is a Word docx file with the screen print images
embedded. Note, these are being emailed form a PC not a phone.

Is it possible that this "Reply" address does not accept Word files and
should I therefore send the screen shots as jpg files.

It is inconceivable that there is anything wrong at my end of the system,
certainly not after two attempts.

Many thanks

Hey @johnf52,


Don't worry, we've gathered all the necessary info now, so no need to send anything - thanks 🙂


We just wanted to let you all know that this is being looked into by the right teams.


Make sure to keep your Spotify app and your Alexa device software up-to-date and keep an eye out for any updates which could contain a fix for the issue.



Any progress to be communicated here after being looked into by the right teams during 4 weeks now?

Cause it seems to work now again (at least regarding the device name issues), it would have been nice to be communicated here and not to be forgotten.

However, I still have two problems:
1) several multiroom-groups set up in the alexa app (meaning the cloud to be more precise) do not show in the spotify in "connect" and can't be used for playback - neither spotify app nor spotify desktop
2) the multiroom-group "everywhere" containing all echo dot devices exists, playback is visualised by "playing" (play button changes to pause button, status bar and time moves), but none of the devices play music actually.

Any help with that?

Standard procedures like disconnecting spotify via voice command "alexa, disconnect spotify" on every echo device, editing the group(s), deleting and new set up of the group(s), unlinking and relinking the spotify account to alexa, and all imaginable constellations and orders of doing so did not help.
Each device is able to playback spotify on its own, either solo or in other groups.
All devices and spotify app are in the same wifi and SID.

So, for many people removing the spotify / alexa app and reinstalling still isn't working, but I've finally figured out the root of the issue and how to fix this problem for at least Amazon Echo devices.  Here is the solution:



Suggested posts