Announcements

Can't play podcasts-Couldn't Open Link

Solved!

Can't play podcasts-Couldn't Open Link

For some reason, whenever I want to play a podcast on my ipod touch, whatever podcast I try to access, I keep getting the following message.

 

Couldn't Open Link

Spotify can't open this type of link on this device

 

I Have a 6th Generation Ipod touch (it's about 3 years old), and I have the newest IOS system (10.3), and have the 8.1.0.623 Spotify app version. Songs and playlists work perfectly fine. I tried restarting my ipod (by holding down the power button until it said slide to power to off, then doing so), there are no available updates for either the IOS or Spotify app, and I have removed and reinstalled the Spotify App. I'm running out of ideas, and any suggestions would be appriciated!

Reply

Accepted Solutions
Marked as solution

Hey guys,

 

Just to let you know that there's an idea for this in the Idea Exchange - make sure to add your vote to it here!

 

Take care 🙂

View solution in original post

30 Replies

I have the same issue on my iPod touch, cannot open any podcasts. Help!

I have the same issue on mine.I bought my iPod few days ago and it runs on the most recent iOS update which is 10.3.1 and I also updated Spotify to its recent update (8.4.623) so I don't know what the issue is.Has anyone found a way to fix this?
IMG_0019.PNG

Having this problem on my iPad Pro as well.  Aug 31, 2017

Hey guys, apologies that no one responded to this sooner. @Octobercrow are you able to let us know what version of iOS you are running and what version of the Spotify app you have installed? 

 

If you can provide that, I will escalate this up to see if we can get a response from the Spotify devs on this!

Same issue. iOS 10.3.3

Hey @BigRedRev, can you try on different networks and see if that makes any difference? (e.g. try on different wifi networks or on mobile data if your device has it)

Also if you can let us know what device and what version of the Spotify app you're running, that'd be awesome!

@swanny,

 

I'm using an iPad Air 2.

Spotify version:  What is in the iTunes Store.  Just downloaded to the iPad an hour ago.

 

Tried on my phone (using data) and no problem.  On the iPad via wifi, no go.

Thanks for that info @BigRedRev, I will pass that onto the staff!

I'm having the same issue on my iPad mini and I, too, have the most current release of Spotify. I updated just this week with the newest version. I get the same error message described. I'm using wi-if, my iPad doesn't have a mobile plan.

Podcasts aren't working on my iPod Touch 6th generation. I am getting the same error message as the others posting here. I have the most recent iOS and most recent version of Spotify. I've emailed Spotify about this and they have not gotten back.

image1.PNG

Same issue on my iPod touch, latest generation, everything up to date...

My iPod won't play podcasts either! It's about three years old. I have it updated and I have the newest version of Spotify. Help!

I think the only available options at this stage are either to use the podcast app that comes with the iPod or to download an alternate podcast up such as Stitcher, Soundcloud or Podbay.I really hope the Apple technical team will find a way to solve this.Has anyone contacted their local Apple Store regarding this issue?

 

Same platform, same issue. I have Premium family, latest version of Spotify and iOS 11.2.2. 

I get this same error when attempting to open the Spotify web player in Safari on my iPad mini.

iPod 6th generation. iOS 11.3. As of April 23 2018. Still no fix. The message still says "Spotify can't open this type of link on this device". 

I hear what you are saying - I can't get podcasts on my ipod 6th generation - what can we do?

Same with me: iPod Touch Sixth Generation on 11.3 

 No-go on Podcasts. 

I cant get spotify pod casts on my ipod 6th gen - I hear it also does not work on ipads as well....

Suggested posts