Help Wizard

Step 1


Can't swipe to add song to queue when searching in my playlist

Can't swipe to add song to queue when searching in my playlist






iPhone 6

Operating System

iOS 12.1.3


My Issue

As the title says, whenever I search for a song in one of my playlists, I can't swipe right on any of the search results to add a song to the queue easily. I have to instead tap the ellipses to the right of the song title to add on to the queue, which is time-consuming and cumbersome. I'm hoping this gets fixed soon! 

3 Replies

Hi there!

I know it sounds simple, but it's often overlooked. Could you try restarting your device? If that doesn't help, try a quick clean reinstall of the app. Just follow these steps.


I tried that on my end and it works. Could you also try updating to iOS 12.1.4?

If you're still having trouble, could you let me know the exact version of Spotify and the exact version of the operating system you're running?

I'll see what I can suggest next!

I have the same issue on my iPhone and iPad, I tried everything but still not working. 

I've tried restarting my device and I've reinstalled Spotify, still nothing. I'm pretty sure this is an actual functionality bug programmed within the app. Either it was just overlooked in one of the recent Spotify updates or they knowingly removed the functionality.


Does swiping to add to queue on search results work for anyone else or am I the only one that can't do this?

I'm using Spotify (I assume the latest version) and I'm on the latest version of iOS (12.2).

Suggested posts