Announcements

Disable repeat and autoplay

Disable repeat and autoplay

armcknight

Plan

Premium

 

I wanted to disable the automatic enabIement of repeat, and gather from this post (https://community.spotify.com/t5/iOS-iPhone-iPad/Change-Repeat-Default-to-Off/m-p/2840077#M87691) that the only way to do so is to enable autoplay. 

 

I just want a way to play just an album or playlist and then stop playback when that's done.

Reply
15 Replies

DanifC

Hi armcknight,

 

If I'm not mistaken, the post you linked is saying the opposite of what you're thinking! Have you tried unchecking the autoplay toggle and seeing if that fixes things? Make sure the repeat button is turned off as well. 

armcknight

No, I want a way to do what they want (disable automatic repeat) without having to enable autoplay (the accepted solution there).

 

I just want a way to listen to one album/playlist and have it stop playback after that. 

DanifC

Yes, toggle autoplay off, and also make sure repeat is toggled off. Both should be off. That should be what you're looking for. 

armcknight

I've always had Autoplay disabled, so that's fine.

 

But as the author of the post I referenced mentioned, it seems like repeat always becomes reenabled again. It seems to happen every day. I never enable repeat myself, but I always find myself disabling it. Why?

DanifC

I see, I didn't realize the issue was that it kept reenabling itself. I'm not sure why that's happening.  Have you tried a clean reinstall of the app?

armcknight

No I haven't, let me try now and I'll check back in a day or two!

armcknight

Confirming that the repeat button still becomes enabled on its own after a fresh install of the app. I never enabled it. Surely this is the intended functionality. There needs to be a way to disable this.

DanifC

Hello again,

 

Sorry that this is still happening. As far as I know, this isn't intended -- I tested it out on my own devices with repeat and autoplay both turned off and playback stopped after the playlist or album ended. Let's try to figure this out. 

 

I know you just did a reinstall of the app. Please let me know what your version number is (cog on home screen > about > version) and the device are you using (iPhone 7, 8, etc.). Also, have you restarted your device lately? I know that's a simple step, but sometimes it's overlooked! 

 

Here's a list of basic troubleshooting for iOS: https://community.spotify.com/t5/iOS-iPhone-iPad/iOS-Troubleshooting-Spotify/td-p/105341. I've touched on a couple of the steps above, but please follow those and let me know if anything works! If not, we'll go from there. 

armcknight
My device has restarted a few times since I performed the clean install of the Spotify app, most recently a few days ago, but I still observe the behavior after that. I'm currently on version 8.5.7.601.

Perhaps clearing the app cache (settings -> storage -> cache) could help? Not sure what kind of stuff is cached or where. Is the loop option stored in NSUserDefaults, and does clearing the cache clear those? If so, hopefully it still knows how to remove settings the app no longer actively sets but may have in the past?

I have a premium family plan, would someone else enabling looping on their device somehow leak onto mine?

DanifC

Good afternoon, 

 

Clearing the cache is a good idea, that might help. Here is the page that tells what the cache is used for: https://support.spotify.com/using_spotify/system_settings/storage-and-data-information/. Clearing the cache can sometimes fix problems. 

 

You should be able to keep your preferences separate on a family account, so it shouldn't be a problem with that as far as I know. If we can't get this figured out with the cache, I'll escalate the post and see if a moderator or Rock Star can help us out here. 

DanifC

Also try logging out and back in to Spotify on your devices. You can do this individually on each device or on all your devices by accessing your account page: https://www.spotify.com/is/account/overview/

SeanGunns

I have had this same issue with Repeat auto-enablifng itself and have narrowed the issue down to my car's bluetooth system. I drive a Ford Everest/Endeavour and every single time my phone/spotify connects to the in-vehicle entertainment system it enables repeat. It is HIGHLY annoying but I can't seem to find anyway to sort it out on Spotify or in the Ford entertainment system. Perhaps you have a vehicle that connects to spotify automatically too and it's causing it to enable Repeat like mine does?

armcknight
I’ve been using a USB connection for some time, since before I created this report initially, so maybe. I only started using the Bluetooth connection in the last few weeks so that definitely isn’t it, but what I can say is that Spotify’s interface on the phone is different between when I use USB vs Bluetooth methods. With USB, it seems to just send audio like an AUX output; with Bluetooth, it looks like CarPlay.

Dan159

It is your car (or possibly another Bluetooth device) that does it. In my car, VW2017, the settings button that shows while media is playing from the phone has a checkbox for “repeat/shuffle”. I unchecked that and now it doesn’t happen anymore!

Mihail

Hey there @armcknight,

 

Thanks for searching for the answer you need here!

 

Just to make sure that we're on the same page - you tried performing a clean reinstall using the steps here and disabled repeat and autoplay as described here and here, right?

 

We also understood that you're also connecting to a car system . Does the option reenable itself only after you connect to your vehicle or at random? 

 

We'd also appreciate it if you leave a post with your Spotify version and the make, model and operating system of your device. 

 

We'll be keeping an eye out for your reply.

Mihail Moderator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Suggested posts

Env: prod