Help Wizard

Step 1



Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...


Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...


How can I listen to just one podcast episode (Autoplay is disabled)?

How can I listen to just one podcast episode (Autoplay is disabled)?





Operating System

iOS 15.2


My Question or Issue

According to related posts it would seem that many users prefer to listen to several episodes of a podcast on autoplay. I am the opposite. One of my scenarios: Play a particular podcast episode and go to sleep. The sleep timer is a great feature for music, but it does not work well with podcasts because episodes rarely come in exact durations of 5, 10, 15 etc. minutes. So using the sleep timer would mean that the app stops playing before the episode is over or start the next and stop while playing it. I don't want a history of half-played episodes on my phone.


According to this fix report , an issue with podcasts not autoplaying was recently fixed. That's great for those who want it, but is it possible that this correction is having an adverse effect on how podcasts interact with the queue if Autoplay is disabled in settings?


I can see three ways of starting a podcast episode:

  1. Go to the podcast and tap Play for an episode while looking at the list of episodes.
  2. Tap the title of an episode so that it's details are displayed, then tap Play.
  3. Add an episode to the queue in the same way you add a song.

According to a post I read, but cannot find anymore, procedure no. 2 should only play that particular episode, then stop. Only that it doesn't (anymore).


I need a reliable way of achieving this that would ideally also work over CarPlay. Ultimately, having two Autplay switches in settings (one for music, one for podcasts) might be the best approach and give everyone the flexibility they need.


Please let me know what you think.




14 Replies

Additional information:

  • I confirmed that procedure no. 2 as described in my original post leads to the same result on my iPad (lots of other episodes are added to the queue). 
  • I tried the same in the Windows desktop app and here only the episode I  start is added to the queue. 

Hi there @Heddy,


Thanks for reaching out to the Community.


We can confirm that this is expected, as when you play an episode, the following episodes to the currently playing one are queued up automatically in the mobile app. As you mentioned, this doesn't happen in the desktop app, though.


As a workaround, you could try adding only the episode(s) you want to listen to to a playlist, and play them from the playlist, so only that or those episodes will play.


In the meantime, we also suggest adding your +Vote to the idea you linked to, if you haven't already, as that's the best way to provide feedback on new feature requests.


Hope this helps. If you have any questions or need anything else, the Community is here for you.



Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.

Thanks Carlos for your reply and confirmation that this is expected behaviour. I don‘t understand though why this has been implemented differently in the desktop app. We are not talking about a variation in the feature set but rather the basic design, which I would expect to be consistent. 
Anyways, I‘ve voted for the idea and will find a different approach while this is being processed.
Thanks again 


It is kind of ridiculous such a simple feature, that most podcast apps have, is missing.  Sometimes we are stuck using Spotify for podcasts, even though we don’t want to use it.  At least have the basic features.  


For music I want autoplay on.

For podcasts I want autoplay off.

So need setting per category of content type not overall setting.

When filtering by "unplayed" podcasts, the autoplay removes the next episode from the list because a few seconds were played before I could stop the next episode. 

I also have this issue and it's infuriating. Please fix this! If I have said I want autoplay off why are you making the app autoplay?

Also agree that this is an issue.


I listen to meditations on Spotify, and it's quite jarring to have another when play immediately after. 


I've some saved in separate playlists, but it doesn't allow for spontaneity, is a bit of a process I don't want to do each time (especially when I'm trying to calm the mind), and clogs up my playlists.


Autoplay off for podcasts please 🙏

Same issue here! And it is very annoying. Please fix.

I hate not being able to play podcasts without autoplay. How hard can it be to fix?

My workaround, as most of the podcast are also available in other platforms listen them from there.

I have the same need, while I like having a continuous music stream, I listen to some daily radio podcast before going to sleep on a google home speaker. 

Any other option works better than spotify for this. 

This is really frustrating for me as well. Is it that hard to implement?
Will have to consider moving to another music provider if it doesn't get solved 😕

As easy as changing autoplay configuration options to "podcasts, songs, all, disabled".

C'mon guys, I'm a software engineer. This is an easy one and everyone will be satisfied.

I have the same issue; I want ro sleep to one podcast and not wake up at 3am in a rabbit hole of suggested podcasts.. The unfortunate answer is they dont care. They want more episodes to play because they get more ad revenue.. it doesn’t matter to them if you are asleep, it’s simply the more ads that get played the more $ they make.

I have exactly the same problem. I just want to listen to one podcast episode and sleep, I only select one and this trash keeps playing forever and I can't find a way to avoid this bug. Spotify app is really hateful.

Suggested posts