Help Wizard

Step 1



Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...


Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...


My G3 iPod touch isn't syncing with Spotify.

My G3 iPod touch isn't syncing with Spotify.

About a month ago, I suddenly got a message on my iPod that I had too many 'offline devices' registered and all my playlists stopped working. Since then I have had my 'offline devices' rebooted. But since the reboot, I have been unable to get my iPod to sync to Spotify whether it is via WiFi or through a USB hook up. I know it's registering on my computer because I can find it in the C: menu, but it doesn't show up under devices. I'm paying for a premium account and would really like to use what I'm paying for.




7 Replies


Hmmm that's weird...Have you tried a clean install? You can follow the instructions here to do that 🙂

Hope this helped 🙂

Don't forget to add your Kudos and mark as a solution if it helped you!

Follow me on Twitter

Whats a Spotify Rock Star?

Yes, I tried that before I posted the message, but just to make sure I tried it again and it still won't register under devices. I even went so far as to connect my computer wirelessly to the internet and checked to make sure they were on the same next work and it still won't show up. The same thing is happening to my android phone. It won't show up under devices either.

Have you disabled all firewalls on your computer?

Spotify Community Mentor and Troubleshooter

Spotify Last.FM Twitter LinkedIn Meet Peter Rock Star Jam 2014

If this post was helpful, please add kudos below!

As far as I know yes. The only firewall I know of is the Windows one and I tried disabling it before and it didn't work, and just tried again and still nothing.

Does anyone else have any ideas on how to fix this? I love the service and I really want to keep using it but if I can't get this fixed I'm going to have to cancel my subscription since I don't see the point in paying for something I can't use.

  • Turn off your firewall
  • Enable UpNp on your router
  • Turn off any other antivirus and security programmes
  • Restart your router, desktop client and mobile devices
  • (Don't connect the touch with a USB cable)

Thanks for the suggestion, but it's still not working. I even had my boyfriend, who is much more tech savy then I am take a crack at it and nothing seems to be working.

Suggested posts