Help Wizard

Step 1



Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...


Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...


Radio doesn't work - "This playlist was deleted"

Radio doesn't work - "This playlist was deleted"






iPhone SE

Operating System

iOS 13


My Question or Issue

I can't get the app to play radio stations. I click on the dots, select radio but I get a message saying "This playlist was deleted" - have I done something wrong? (I'm newly converted to Spotify)

17 Replies

Hi @Joeincardiff,

thanks for reaching out to the Spotify Community !


I would like to point this thread out, discussing the radio playlist feature just so you'd have a bit more knowledge on how it works.


In addition, it would be great if you could send a screenshot of what you see on your screen while trying ?


Thanks for your cooperation 🙂

I’ll have a look at the thread, thanks. 

I’ve attached a screenshot. 


Sorry, just to add some extra info here - this seems to be a problem with my account as I’m able to access radio stations with another premium account. 

Hi @Joeincardiff

thanks for the extra info !


Please follow the steps provided here and perform a clean reinstall of your app which is a bit different than the regular one.


Let me know how it goes 🙂

Well there’s been progress of a sort...

Tried three different artists - all with this result. 

Forgot the screenshot


Also, I can play radio via the browser app. So there's something about the combination of the iOS app and my account that's all to pot.

Hi @Joeincardiff

thanks for bearing here with me !


As none of the above helped solving the issue, it might be connected to the ongoing issue mentioned here.


I would recommend you add your +VOTE and subscribe to get updated on any changes.

In the meanwhile, you might find some more useful steps in there which can help solving the issue.


Let me know how it goes 🙂


I have the exact same issue. I found a random track, clicked"play radio", and this message showed up. 


Went to Google and it took me here. This is obviously a bug with Spotify.




Hi there @simplenoteasy,


Thank you for your reply and screenshots in this thread.


Can you confirm if you followed the steps that @OneByBoo provided?


Another useful step is to remove any hosts files.


If you're using Windows, these steps:

  1. Open Notepad as an administrator (right-click - Open as Administrator)
  2. go to File - Open and navigate to C:\Windows\System32\drivers\etc
  3. Choose "All Files" instead of "Text Documents" next to the File Name box. You'll see a handful of files. Pick hosts and click on Open
  4. When the file is open, you will see a block of text with # in front of each line and might see entries like website.com127.0.0.1
  5. Check for any entries with Spotify in the address. Examples may look like: weblb-wg.gslb.spotify.com0.0.0.0
  6. If you do find any lines with Spotify, please remove them
  7. Save your changes and restart Spotify

If you're using a Mac, follow these steps:

  1. Open Finder and, in Finder’s menu bar, select Go > Go to Folder. In the box, type the following location: /private/etc/hosts and press return
  2. A new Finder window will open and your Mac’s hosts file will be selected. Click and drag it out of the Finder window and drop it on your desktop
  3. To open it, simply double-click and it will display the file’s contents in TextEdit 
  4. Check for any entries with Spotify in the address
  5. If you do find any lines with Spotify, please remove them
  6. Save your changes and restart Spotify

Keep us posted 🙂

Take care!

Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Live, love, laugh and listen to music 🙂

I came here too because this problem occurred with one song. I tried a couple of times, then clicked the button to ‘remove from my library’, tried again, still didn’t work. But then I tried another song which worked fine, then went back to the first song and it worked now. So I guess it was a temporary glitch. I thought I should add this so people don’t do anything ‘drastic’ that may not be necessary. 

I am also experiencing this issue on multiple songs and playlists. On my mobile it states that the playlists have been deleted and on the desktop app it loads for a while with the three dots then displays "Couldn't find that playlist" on multiple song radios and even playlist radios from my playlists that I know used to work.

I'm also having this exact same problem. I have tried all of the steps above, including the clean uninstall and nothing has worked.


Hey folks,

Thank you for keeping us updated. 

To investigate this further, would you mind checking if it happens using a different WiFi network or with a mobile data hotspot?

If so, include in your next response the Spotify version and OS version you're currently running on your devices. 

We'll be on the lookout.

Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

I still have this problem. Cannot make ANY RADIO STATION. Have reinstalled, tested wifi/data, everything. Please help!!!!

just started happening with ATB radio despite me being able to listen to it repeatedly for the last month; including this morning. So odd. Same 'playlist was deleted' message. Happening on google pixel 5
Spotify username: yayamancatch

Just had this happened to me. I changed from wi-fi to mobile data and it did a trick..and back to same wi-fi to dubble ceck, works too.

Android user

Suggested posts