Help Wizard

Step 1



Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...


Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...


Siri on AppleWatch does not work

Siri on AppleWatch does not work







Operating System

(newest versions at time of writing for OSes and Spotify App)


My Question or Issue

Siri on the Apple Watch to play a Song on Spotify no longer works on the watch after the latest OS-Updates (to 17.1.1 and 10.1.1). It worked before, works still on the iPhone directly and Siri on the watch works for all other apps.


I tried restarting the apps, reinstalling the apps and recoupling my watch to my iPhone.


Any ideas what I can do?


38 Replies

Additional info: After a clean reinstall, it worked one time. I was asked to grant Siri some access on the iPhone which I did and it worked once, but it failed to work for all further requests

Same here, I've used this feature hundreds of times while driving. Since last update (I think the watch has actually been updated twice since it started happening) it no longer works

I'm experiencing the same issue. running watchOS 10.1.1 and I also posted a comment on this Reddit thread:

  • Plan





Watch ultra 

Operating System

(iOS 10,.)


My Question or Issue

Since the last update Siri on Apple Watch no longer played requested songs on Spotify. The app launches but doesn’t play the track you request. Uninstalled the app also

reset and reinstalled complete OS, still doesn’t work. iPhone works using the same commands but watch doesn’t. Was great to use when driving for obvious reasons. Be good to get it back. Any suggestions welcomed 

Having the same issue on my Apple Watch SE, very frustrating

Same here, iOS 17.1.1 and watch os 10.1.1

Hey folks,


Thanks for posting in the Community and for the info shared.


In this case, we'd like to gather some additional info, so we can investigate further. So, please send us the following:

  • Make/model of your Apple Watch.
  • The exact OS of your Apple Watch.
  • Exact Spotify version.
  • Exact troubleshooting steps you've followed so far.
  • A video recording of what's happening on your side. You can attach the videos in your next reply in mp4 format, or you can also upload them to YouTube or Google drive and make them public, so we can visualize them.

If you haven't yet, make sure to try and follow the troubleshooting steps mentioned by @SptifyUser08151.


Keep us in the loop!

Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.

Replying to this quickly, in hopes of a quick fix. 


Make/model: Apple Watch SE 2nd generation, model A2727 (Cellular, 44mm, US/CA)

WatchOS: 10.1.1 (21S71)

Spotify Version


Troubleshooting steps follows:

- Restarted iPhone (iPhone 14 Pro Max)

- Deleted and reinstalled Spotify app on watch

- Wiped and restored watchOS 10.1.1

- Deleted and reinstalled Spotify app (v8.8.86.157) on iPhone


Here is a video of the issue:

Hey @bankroll,


Thank you for providing this info.


The issue is currently being investigated by our tech team. We'll let you know as soon as we have an update.



Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Me too Thursday 

I’m also having the same problem on my 13 pro and watch SE. It’s frustrating but thanks for looking into it. We’ll wait for a response 

Works for me again after the newest update of the spotify app. Thank you!

I, too, have this issue.

- iPhone 13

- Apple Watch Series 8

All OS updated on all devices as of Nov 23. 

Been experiencing this issue for at least 2 weeks, maybe 3.

The last update solved the Siri issue for me; and it also brought back the correct localisation for the watch app, in the last six months it has been in English while now it is correctly in Italian. Please do not break it again with the next update 🙂

the last update worked for me as well. Thank you!

I'm just returning from vacation and I can also confirm that the issue is now resolved (Spotify app version


Thanks everyone!

Still not working perfectly. I very recently bought some Airpods Pro 2. Gen and linked them to my iCloud account.

Some time afterwards, the watch app insisted on coupling them or another headphone to the watch when I tried to select a new song with Siri. After I coupled the Airpods, I could decouple them and switch back to the iPhone as playback device (or to my Wiim Mini as a Spotify Connect device), but for each new song requested by Siri I had to use the Airpods first before I could switch back to another device.

Deleting the Spotify app and reinstalling it on my watch only helped to fix it, but the unwanted behaviour described above creeps back sometimes (I already did the app reinstall on the watch three times since yesterday).

It would be nice if this could be fixed occasionally, too.

Seems that every time I turn my watch off and on I have to reinstall Spotify on the watch to get Siri working again flawlessly, otherwise I am asked to connect bluetooth headphones although I can select songs for Spotify Connect devices with the watch without Siri from my watch. Very strange behaviour...




New Zealand


Apple Watch SE (2nd Generation), iPhone 15 Pro Max

Operating System

watchOS 10.2, iOS 17.2


My Question or Issue

When asking Siri to play a song on Apple Watch, it opens the Spotify app... and then does nothing.


I expected it to open the Spotify app, and play the song via the connected iPhone.

Suggested posts