Spotify Links on Instagram Not Working

Reply

Spotify Links on Instagram Not Working

frocious
Visitor

Plan

Free

Country

United States

Device

(iPhone 6S)

Operating System

(iOS 12)

 

My Question or Issue

I'm an artist that has music on Spotify and I usually promote it on my Instagram. Although I could promote through my Instagram Story, I typically leave a link in my Instagram bio so that fans can easily access it without me having to post on my story. Whenever I tap on the link, it does not open the Spotify app, neither does it open in Safari. It doesn't even connect. I copied and pasted the link from the Spotify app (I also tried doing this from a desktop to see if it'd fix the problem but it didn't). I also tried doing another form of connection by using a third party application Toneden that gathers links for an artist's music, in which it'd display the connections to several different platforms (Spotify being included). The connections to other platforms worked just fine, but when I tapped the Spotify link it gave me the same issue that I previously had when I had the link alone in my bio. Please let me know if this issue has been resolved. Thank you. Here is the music I tried putting a link to (in case this might help): https://open.spotify.com/album/3Bxykxqag9lZwNPwsiTuXP?si=n2MSPuzaSq2PFMsEaLAxxA 

2 Replies

Re: Spotify Links on Instagram Not Working

dgururk
Visitor

I experience the very same problem. I manage digital accounts of several local art and entertainment brands and haven't been able to direct Instagram users to Spotify.

I share Spotify list links on Instagram account bio, links direct to "Spotify download the app" screen.  

I double checked if it's only on mobile, it's not. Same problem is valid for destop too. Instagram could not connect to Spotify on web. Bio link directs to "page could not found" screen on Safari.

Sorry to state that it's also valid for Instagram swipe up mechanism, same problem continues. Here link direct to Spotify download the app" screen again, though Spotify app is already open. 

Is it because I try to share Spotify Lists not tracks or EPs?

I can not promote any of Spotify list's of my brands. Need help, could you be so kind to resolve this issue primarily?

Re: Spotify Links on Instagram Not Working

RossSeddon
Casual Listener

Same problem type just says oops and fails. No clue how to fix or troubleshoot can I find

Ross Seddon
SUGGESTED POSTS