Spotify not showing all Echo groups

Spotify not showing all Echo groups

dcbentley

Plan: Premium

Country: USA

 

Device: iPhone 11 Pro Max

Operating System: iOS 10

 

My Question or Issue

I want to create a new music group since I’ve added a new Echo speaker. However, the new group would not show up in the Spotify app. Reading some of the suggested “fixes”, I’ve deleted all multi room music groups in the Amazon Alexa app and re-created them. Spotify will only show the first two groups that I ever create. All subsequent groups are not shown until I delete a prior group (depending on the speakers in that group). 

 

E.g.: if I create an “Everywhere“ group followed by “Dining Room“, both groups will show in the Spotify app. Creating a third group called will not show until I delete the Everywhere group or the Dining Room group.

 

I also attempted creating groups with unique names (E.g.: Test001, Test002, Test003, etc.) for groups just in case there was some weird duplication issue but it didn’t not resolve the issue.

 

I also attempted creating groups with speakers that were only the same model and we’re not duplicated in other groups. This had the most interesting results, as it seems that speakers that appear in different groups will not show in the app unless they are included as par of the first two groups created.  

E.g.: “everywhere”, and a “stereo pair”, will show in the app.  But “dining room” won’t show up because it’s the third group and its speakers are also part of everywhere. (Of the “everywhere” group is deleted, “dining room” shows up in the Spotify app)

 

Soooo... what do I need to do to make this work so I can group other speakers together? Or is this a Spotify limitation?

Reply
26 Replies

duncan69

Similar problem here. I have two groups, one called downstairs and the other the everywhere group. Since the latest update I just can't play on any multi speaker group properly. Firstly Spotify only either sees one of the groups and even then only plays audio for a short while before going silent despite the progress bar on the song continuing, it starts playing audio again if I skip to the next track but stops again part way through. It does that on every song I play. 

I reset the connection between Alexa and Spotify, no difference. Deleted the Spotify app on my phone and reinstalled, no difference. I have the same problem occurring on all the devices I have Spotify on.

I tried removing the downstairs group, the everywhere group appeared but still the audio stops playing as before.

Cooper_da

are all speakers of the groups visible as single speakers? 

 

I have the problem, that my echo dots are not shown, neither single nor group. 

 

My sonos is shown and all speakers will play spotify on voice command.

 

Any ideas?

dcbentley
I think this is just a limitation of Spotify. I've chatted with other
friends/family that have multiple Echo devices and Spotify. They also are
only able to create two distinct speaker groups. Typically "Everywhere" and
one other speaker pair.

I've yet to find anyone that can have multiple Echo speaker groups. E.g.:
Everywhere, Bedroom, Living Room, Dining Room, etc.

Cooper_da

maybe. but i wonder why my echo dots where shown in ios app but not in android app ... 

dcbentley
That’s another interesting issue. Our household is mixed iOS, Android, MacOS, and Win10 devices and all can see the Echoes.

I know there are some router settings that can make it difficult for certain devices to discover each other. Are you running SMB or enterprise hardware? I know Ubiquiti has a couple special settings to help ensure some IoT devices see each other.

Another issue might be the current version of android you were using or the device. Tracking down these issues is definitely frustrating.

BillCaffy

Android user here. My Spotify was showing all four of my Alexa speaker groups until yesterday (5/7/2020). Now it only shows two.
Surely this can be an easy fix for Spotify. This is a dumb limitation.

dcbentley
Yeah, it's unclear why this is a particular limitation. Doesn't seem
logical to me.

Cooper_da

Hi,

Can you please post a screenshot?

Maybe I can find something that is different to mine. I just can see a Sonos speaker but non of my echos. 

Thanks

bimp

I too beginning 5/9/2020 not seeing all my Alexa speaker groups. I was seeing them fine before today but I added an Echo Show to my house and renamed, moved devices around and redid the speaker groups. After doing all that, all the individual devices appear in Spotify and ONE speaker group for all my devices but none of the other speaker groups.

dcbentley
Not really sure what is going on with the Echo's and Spotify, but I've also
recently encountered an Echo changing it's name to "AEODN", but it still
knows which room name I've assigned it if I use voice commands.

dcbentley
I'm starting to suspect it's a hard limitation of only two speaker groups.
"Everywhere" and one other "stereo pair".

boxallw

Spotify is not showing my stereo pair at all now. Just Everywhere.

 

All other devices are shown fine.

 

Boy this Alexa/Spotify integration is so dodgy. Wish someone would fix it.

dcbentley
There was one point where I also encountered this and eventually I just
needed to start from scratch and remove all groups in the Alexa app and
recreating them.

ahall411
I had same problem. I solved it by unlinking Spotify from Amazon account and then logging out of Spotify. This in itself didn't work, but I then de-registered all my Echo devices (from within the Alexa app), and then re-registered them all to my Amazon account. Then I relinked Amazon account to Spotify, signed in, and the correct names and all of the correct groups all appeared on Spotify.

boxallw
Yes, I removed the two spots from Alexa completely, added them back in and created the stereo pair. All good...for now.

Thanks heaps.

boxallw
Spoke too soon. Stereo pair shows up but nothing plays. Progress meter won't even move!!! GARBAGE!

ahall411
Oh dear.
Try DE-REGISTERING your Echo devices from your Amazon account (in Alexa app, click on Device then scroll to bottom) and then set them up again from scratch. It was frustrating for me too but this solved it in the end and I can now see all my stereo pairs and multi room groups in Spotify

Cooper_da

I solved the problem for me. 

 

I just needed to deactivate "only my LAN devices" and everything showed up...

 

hope this helped.

boxallw
Where???

Suggested posts