Help Wizard

Step 1



Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...


Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...


Track name stuck


Track name stuck



Since the last update (i'm using Spotify on my 4S iPhone under 5.1.1 iOS), the track's name on the lock screen doesn't follow the playing - a bit annoying 😉


any ideas?


thanks 😉




Accepted Solutions
Marked as solution

I have the same problem on my iPod Touch 4G and my iPad 2. Before the last update I didn't have the problem.

View solution in original post

24 Replies

The same thing is happening to me on my iPhone 4 iOS 5.1.1. Spotify please fix this. PLEASE!
Marked as solution

I have the same problem on my iPod Touch 4G and my iPad 2. Before the last update I didn't have the problem.

After 3 emails which Spotify patronized me and treated me like an idiot I decidedto cancel and go with Rhapsody.

I'm having the same issue. Same app version. iPhone 4, iOS 5.1.1.



I played around with this the other day and couldn't manage to replicate it. I'd recommend a clean installation - That might get these tracks showing up normally again. Although keep in mind that any offline playlists you have will need to be resynced afterwards. 

Airhorn Enthusiast

David this how the problem is for me. Open the app and select an album. Play the album. When you get in to the fourth or fifth track the second or third track will be stuck IN THE LOCK SCREEN. If you unlock the screen everything is fine. Lock it again and the track showing in the lock screen will still be wrong. Reinstalling the app did not fix the problem. I never had this problem until the last update.



This is definately a new problem. I am having the same issue, though I noticed through other means. In my car, I have a display that used to show the correct track title and time on the screen. Now, when my phone automatically locks while playing Spotify, the track title never updates even though the track changes several times. Also, the time never resets and just keeps counting up even though the track changes.

Hi everyone -  Earlier this week an updated version of our iOS app was released (0.5.3). Please try heading over to the App Store to install that update if you haven't already. 


Let us know how that works for you--thanks.

The Update didn't solve the problem 😞

In order to fix the problem they first have to admit it exists which they refuse to do. I will cancel again if they don't fix it by 8-15.



I applied the 0.5.3 update yesterday and the problem persists. Please let the developers know the problem happened started 0.5.2 and as of 0.5.3 still exists. Very annoying one at that.

Yeah the new version of the app doesn't fix the problem for me either. I thought it might be an issue caused by gapless playback, so I disabled that, but the problem persists.

Everytime I email them to alert them of the problem I get a reply telling me to restart my phone or reinstall the device. It is getting ridiculous.

Email from Spotify support:


Hey Michael,
Based on your reports and those of a number of other users (including those in the Community), I'd say that this is most likely a problem within the app itself.
As we've posted here - - this has been reported to our dev team and hopefully they'll be able to get it sorted asap.
Sorry for the runaround earlier, it's often tricky to tell what's a genuine issue and what's just a faulty installation (especially when you only have a handful of users reporting it out of millions). Thanks for sticking with us.
Also, it would be interesting to see if you can recreate the phenomenon David reported in the above thread, where using a playlist with a mix of artists prevented the sticking. Give that a go and let us know how you get on - we'll be interested to hear the results.
Kind regards,

The reason it works with a playlist of random stuff is because the changing of albums makes the track name change successfully. If you play two albums in a row, in order, the track name will get stuck on the second track of the first album, then once it finishes that album and starts the next one (regardless of artist, could be same or different), it will change the track name to the first track on the second album. Then it'll get stuck on the second track of that album. If you have a playlist that shuffles individual songs from all different albums, it will appear to work just fine because with each track change, it's an album change.



I am curious to know if you are still experiencing the same problem and if you have tried Rhapsody? Does their app have this issue? I just got back from a long road trip and man oh man, was this bug confusing me when I glanced up to the nav screen to see the wrong track name and time not resetting every track.


As a Spotify premium subscriber for 17 months, I am disappointed. Also, as a software developer, I find it abhorrent treatment of the paying customers. I get that development and fixes take time, but it's a different ball game in iOS world. I CANNOT go back to the working version on this platform while they sort it out. They seem to treat this like it's a minor issue ("oh, just don't play consecutive tracks on a album"). Umm, maybe I'm in the minority, but that's mostly all I do. Find artist, find album, play album.


/rant and soon to be ex-customer.

Yes I am still experiencing the problem. They have not yet fixed it.


I have both Rhapsody and Spotify. I have been trying to chose between them for months. Neither of them are perfect. Rhapsody does not have this track name problem.Rhapsody has a better library for the music I like and Spotify has better sound. Rhapsody radio is better.Rhapsody seems a little more buggy.


I am getting tired of waiting for a fix for this problem. They have till 8-15 to fix it or I will be going exclusivey with Rhapsody.

An update was released today and guess what. It does nothing to correct this problem. Thanks a lot for nothing. I am cancelling my service in 7 days.

I'm switching to Rdio until this is fixed. Once it is, I will be back.

Suggested posts