Announcements

"Next From" heading wrong if different podcast enqueued

"Next From" heading wrong if different podcast enqueued

mrjacobbloom

Plan: Premium

Spotify Version: 8.6.84.1353

Country: USA

Device: iPhone 12

Operating System iOS 15.2

 

My Question or Issue

If the currently-playing podcast is from a different show than the one playing from "episodes," the "Next From" text is wrong

 

Reproduction Steps

  1. Navigate to Podcast A
  2. Play an episode from the middle of the feed (at least 3 or 4 in)
  3. Navigate to Podcast B and enqueue an episode
  4. If you check you queue at this point it should correctly reflect that we're playing A, B is queued, and then A,A,A from episodes
  5. Skip the currently-playing episode (either by scrubbing or swiping)
  6. Navigate to the the queue
  7. Note that the heading says "Next From: Podcast B" even though the episodes are all from Podcast A
IMG_4964.jpg
Reply
9 Replies

Elena

Hey @mrjacobbloom,

 

Thanks for reaching out to the Community!

 

Could you let us know what troubleshooting steps you've tried so far so we avoid repeating them? If you haven't already, try performing a clean reinstall by following the steps here.

 

Also, does the issue occur on any other devices you might have (for example another phone or a PC)?

 

Keep us posted on this.

 

Cheers!

ElenaModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

mrjacobbloom

Hi Elena,

 

I'm seeing the same erroneous behavior on my iPhone after the clean install. I haven't really tried any troubleshooting steps per-se, since the app works just fine otherwise and the reproduction steps I provided work consistently for me.

 

I recently upgraded from an older iPhone (still running latest iOS and Spotify) and saw the same behavior before and after the switch.

 

I am NOT seeing the broken behavior on desktop or on the web-app, it seems to behave correctly there (see attached screenshots). There was some issue rendering some of the text of the queue on the web-app, but I'm pretty sure that's unrelated since the heading in question displays the right thing.

Desktop Version: Spotify for macOS (Intel) 1.1.74.631.g0b24d9ad

web-app-queue.png
desktop-queue.png

Ver

Hey @mrjacobbloom,

 

Thanks for getting back to us 🙂

 

It sounds like this could be a device-related issue. 

 

Just to double-check-does the same thing happen when you try logging in to another account on your phone?

 

In case you're using any battery optimization or power saving apps, you can deactivate them for Spotify. Are there any changes?

 

Keep us posted.

Ver Moderator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

mrjacobbloom

Hi Ver!

 

I don't use any battery-saving apps or a low-power mode (besides the one that comes on automatically when my phone is at low battery). As I said in my previous post, I've seen this error on my previous iPhone as well, so I don't think it's linked to the specific device.

 

Unfortunately I don't have a second Spotify account to test with... theoretically I could create another one with a different email address, but I'd rather not do that unless it's absolutely necessary. I already reinstalled the Spotify app which was a bit of a hassle.

Ver

Hey @mrjacobbloom,

 

Thanks for keeping us posted.

 

Just to double-check did this occur also when you were logged in to the same account on your previous phone?

 

If it did occur, then it's a good idea to try with another account on the same device. That way we can check if it's an account or a device-related issue. You can create a new account here.

 

Let us know how it goes.

Ver Moderator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

mrjacobbloom

Hi Ver!

 

As I've said in my previous 2 posts, yes, I did see the bug on my old phone as well as the new one.

 

I created a new account and was still able to reproduce the bug.

 

Jacob

Alex

Hey @mrjacobbloom,


Thanks for the reply.

 

Could you capture a screen recording of the issue and attach it to your next reply? You can attach it directly or as a link.

 

This will help us look further into the matter.

 

Cheers.

AlexModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

mrjacobbloom

Hi Alex,

 

I've posted a screen recording here: https://drive.google.com/file/d/1_adve_HGTGIlLSTZRcBkrtsqKs5ZzsTu/view?usp=sharing

I followed the reproduction steps in the original post with "After The Fact" as Podcast A and "Hidden Brain" as Podcast B.

 

Hope that helps!

Jacob

Ver

Hey @mrjacobbloom,

 

Thanks for the info.

 

We've passed it on to the right team. We're not able to provide an exact timeline for a fix, but we'd recommend that you keep your Spotify app up-to-date so you don't miss the latest fixes and improvements.

 

If you need anything else, the Community is here for you.

 

Ver Moderator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Suggested posts

Env: prod