We're aware that some of you are currently experiencing issues with redeeming your gift cards! We'll keep you posted here.

Help Wizard

Step 1



Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...


Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...


Android TV - External Keyboards Not Working Since GUI Update

Android TV - External Keyboards Not Working Since GUI Update

Plan: Premium

Country: UK

Device: Sony XF90 Android TV


My Question or Issue


Hi Spotify Community,


For the last 18 months I've been using the Spotify Android TV App on my Sony TV, in combination with an external wireless keyboard connected to the TV's USB port. This has served as a great solution for typing in track names, avoiding cumbersome entry with the TV remote. 


Within the last week my keyboard functionality has stopped working correctly - it seems to align with the recent GUI change (new sidebar etc.). I have updated the app to the very latest version (1.30), along with my TV firmware, but to no avail.


I am unable to enter text in the search box, and instead certain key presses have bizarre outcomes (e.g. caps lock causes the page to scroll down). Arrow key functionality does appear to work correctly for navigating the GUI. To confirm, I have checked the cursor is definitely "clicked" in the search box.


The results are the same across 3 different keyboards, 2 with a wireless dongle and 1 via Bluetooth. Text input on other applications, such as YouTube, is working fine - same as ever.


Any support would be much appreciated.




79 Replies

I am having the same problem, Sony TV using a Logitech Wireless Keyboard.

Same issue with sony Bravia android tv and Logitech keyboard  as soon i unplug keyboard it shows the virtual keyboard.  All other apps works fine except for spotify 

Same here with Logitech Wireless Keyboard, can't search anything

Hey folks,


Thanks for searching for the answer you need here!


It's possible that with the update some of the app's files have gotten damaged and are causing this behavior.  This can usually be remedied by clearing the cache and removing the Spotify app from your TV and then installing it again. Be sure to also unplug the device itself for a couple of seconds before installing the app anew- this is a simple, but often overlooked step.


Hope you find this useful. Keep us posted how you get on.

Mihail Moderator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Same issue here with a fresh install on an NVidia Shield TV with a Logitech K400+ wireless keyboard.

Symptoms include:
- Backspace and delete don't work in text boxes
- Caps lock scrolls down
- Text boxes need a mouse click for the cursor to appear there (and writing to be enabled) even though the widget is already highlighted

I'm positive that at least backspace/delete worked correctly before the recent GUI changes.

Version: 1.33.0

Tried the following remedies as per the instructions by @Mihail:
- Cleared app cache
- Re-installed the app with the keyboard connected
- Re-installed the app with the keyboard disconnected

None of these had an effect on the eventual functionality of the external keyboard. While doing this, I noticed another and quite severe issue: the space bar doesn't work at all. So, three very important keys don't work: backspace, delete and space. Also, the caps lock doesn't work as it's supposed to as already mentioned.

Spotify is the only app in my Shield with which I've had these keyboard issues. E.g. YouTube, Netflix, Disney+ all behave as expected.

With further testing I've found out the following:


  • With Leanback Keyboard all keys work. This is cumbersome as there is no need for a popup keyboard when using a physical one.
  • With External Keyboard Helper, which I use normally, space, backspace and delete don't function. However, if I enable "failsafe mode" in EKH settings, space starts working but the other two keys stay silent.
  • With "No Keyboard" (or any other "null" keyboard app) even the character and number keys stop working.


It seems Spotify's text box widgets are somehow different from those in other Android (TV) apps. Regardless of the input method, all other apps work without problems.

Any updates / comments on this?

Hi Mihai and Malk,


Just to update from my side that this issue is still present 4 months later. I've tried every possible permutation of uninstalling/upgrading/downgrading but to no avail. Every new version since May '20 has been eagerly installed but again without success.


As others have implied, this is more than a minor inconvenience because having a physical keyboard connected prevents the soft keyboard from appearing on the screen. In other words, if I want to type in Spotify I have to go and physically unplug the wireless dongle from the back of the TV - it's a real pain.


In the nicest way possible, I am relieved to see other platforms are impacted as at least this might gain some more visibility.





P.S. For those interested, much earlier versions of the app do still work with an external keyboard - look for the version with the jade green backdrop. Sadly the user interface is otherwise far worse (some serious horizontal scrolling which is a bit nauseating!). 


Could someone from Spotify please run this simple test on an Android TV device?


  1. Install "No Keyboard" app from Play Store
  2. Connect an external keyboard to the device
  3. Set "No Keyboard" as the input method
  4. Start Spotify and try to type something in a text box (e.g. Search)
  5. Repeat #4 with e.g. YouTube

I'm anxiously waiting for any news of your test results.



Hey @j1992e and @MalkMcJorma,


Thanks for keeping us in the loop.


We're sorry to hear that you're still experiencing this issue. Could you make sure that the Android system on your TV's is updated to the latest version? If the issue persists please leave a reply with the exact Android and Spotify version you're experiencing this on.


@@MalkMcJorma we'd appreciate it if you also share the make and model of your device. 


Keep us posted. We'll be keeping an eye out for your replies. 

Mihail Moderator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!


Thanks for the reply. Here are the details:

  • Device: Nvidia Shield TV 2017
  • Shield Android TV SW Version: 8.2.0 (32.6.435.1)
  • Spotify: 1.35.0 (

Before we go into any more details about my specific environment, which I know to be in perfect working order and using the latest SW versions publicly available, please let us know that you have at least attempted to replicate the issue with the test I suggested above.


Hi Mihail,


I've got the same issue with the very latest TV firmware and Spotify versions:


TV: Android 8.0.0 - the latest version Sony supports.

Spotify Version: 1.35.0 (




Hi @Mihail,


Has there been any progress in solving this issue?



Hey everyone,


Thanks for your patience while we looked deeper in to this.


There seems to bee a synch issue related to specific set-ups with Spotify on a smart tv and an external keyboard. We've reported this to our developer team and they are currently working on a solution. We recommend keeping an eye out for future updates to the app, but can't set a specific timeframe for when this issue will be fixed.


As a possible workaround we can suggest that you connect the wireless keyboards to a computer and Chromecast from there or remote control the app on your tv from a mobile device via Connect. You can find detailed instructions on how to do this here


Hope this info is useful. Let us know if there's anything else we can help with.

Mihail Moderator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!



Thanks for the prompt reply. I have been using Spotify Connect in the interim while waiting for this issue to be fixed. It's not a permanent solution by any means as I don't always want to keep my PC open just for controlling Spotify on the Shield.


I will keep my eyes open for an updated app version.



The app just got updated to version 1.40 and the issue still persists. Can you give us an estimate on when a fixed version will be released?

I also still have this issue after updating the app yesterday. An ETA would be appreciated.




Suggested posts