How to stop my phone from controlling volume on my computer

Solved!

How to stop my phone from controlling volume on my computer

albertus50

Hello, I have the following problem: whenever i am playing music on my computer, the volume control button on my phone is directly linked with my computer spotify volume so whenever i click less volume it just changes that of my pc spotify instead of the volume of my actual phone. How can i stop that?

Thanks in advance

Plan

/Premium

Country

Switzerland

Device

Samsung S20, Hp omen 15

Operating System

Windows 10, Android 11

 

My Question or Issue

 

Reply
69 Replies

Ver

Hey folks,

 

Thanks for getting back to us.

 

Could you also please share with us the following? We'll look into this further.

  • Device + OS version
  • Exact Spotify version
  • On what device the volume changes

Just to double-check-do you also experience the issue mentioned here?

 

Keep us posted.

Ver Moderator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

eightythreedays

iPhone 13 mini, iOS 15.1.1

Spotify for macOS (Intel), 1.1.73.517.gbef50fdb

MacBook Pro - macOS Big Sur Version 11.6

 

Yes it is the same issue mentioned in the link

CliffyPop

iPhone 13 Pro, iOS 15.1.1

 

MacBook Pro 2017 13", Monterey 12.0.1

Spotify for macOS (Intel), 1.1.73.517.gbef50fdb

 

Apple Watch 4 (A1975), OS 8.1 (19R570)

Eni

Hi folks!

 

Thanks for the info you've sent so far.

 

We've passed this info on to the right team to be looked into. As soon as we have any updates, we'll let you know.

 

Cheers!

EniModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 
“Music acts like a magic key, to which the most tightly closed heart opens.”– Maria von Trapp
Marked as solution

stonedvaper

I've found a solution to this annoying problem!! (At least I think I have...)

 

In Spotify on the iPhone, go to Settings > Devices > Devices Lock Screen, and toggle this off. This will stop you from controlling music while Spotify isn't the active app, but does seem to fix the issue with the volume controls.

In addition, if you press 'pause' in control centre, even without Spotify as active app (but still running in background) the music does pause, while still appearing unaffected by the volume buttons.

 

So far this also seems to be preventing the Spotify app from auto launching on my Apple Watch as well, but as with the iPhone, if you go into 'Now Playing' (making sure to select iPhone and not Apple Watch), it will still show the music controls, but ignore the volume control.

 

Honestly this should be the default setting... I didn't have to adjust any of my phone's internal settings (background app refresh, etc) and have finally gotten Spotify to work 'correctly', without hijacking my phones volume control, or blasting all my Google Homes if I bumped the control on my phone or watch 

Jeremy

Hi there @stonedvaper,

 

Thank you for your reply in this thread.

 

It's really nice of you to share what worked with you with the rest of the Community 🙂

Have a great continued week.

 

Take care!

JeremyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Live, love, laugh and listen to music 🙂

mljenkins

There needs to be a setting in every version of the app, web, iOS, android, macOS, and windows that simply says “volume synced with other devices?”  This is a simple logic statement and a simple button on the gui.

 

It is annoying and embarrassing when my phone volume jumps to full volume and I’m taking with someone and don’t realize this and suddenly full blast volume on notifications or media that happens to play on my phone.

 

Yeah now I just close the Spotify app, but it doesn’t matter, it’s too late after this happens.  I just tell people now “oh sorry spotify turns my volume all the way up due to a known issue in their software.”

 

 

CliffyPop
YES! Thank you. This immediately solves the problem. I'll occasionally run into wanting to control another device from my phones lock screen, but that's rare and no volume surprises FAR outweighs this minor control.

Stumpington

I was using Spotify on my Mac and I paused the song. When I starting playing it again, it blasted the song at full volume and it hurt. Somehow by itself it connected to my iPhone and started playing the volume at maximum. This is horrible design.

 

I had an alarm go off so maybe my airpods connected to my iPhone. Maybe that is related but I uninstalled the iPhone app so it doesn't happen again. You guys need to figure out why this happened.

TwstDreamscape

Wifi is causing it for me. If my pc and ipad/phone are connected to the wifi and I use spotify on either of them, it affects the volume of the other. When i disconnect the wifi on the handheld device, it stops allowing the pc to change the volume.

mhaugen

<When the app is closed from the background on a certain device, this connection breaks...>

If this were the case it'd be all good (or good enough at least), but it's not. I have self-diagnosed OCD and always close apps (including Spotify) I'm not using on my iPhone (before starting Spotify on my PC) and the volume is still changing.

 

As others have mentioned, listening to music on a desktop and maybe occasionally checking the phone only to deafen the whole room with full-on blasting volume is absurd.

 

As my computer is running Windows the only linkage here is Spotify, which is also more or less confirmed by the Spotify-logo on the lock-screens "show whats playing". Background app refresh is completely turned off - allthough, when searching for this setting it's grayed out and enabled for Spotify(?).

 

The overlay, remote control and volume sync should in my opinion only function when the app is running and background refresh is enabled - if at all. This seems most logical and intuitive to me and as far as I can understand is also what is intended behaviour, ref my above quote. However, as already stated, this is not the case.

 

The solution provided by stonedvaper (thank you!) bypasses this problem. It also means you cannot see what's playing or remotely controlling media without unlocking the phone and opening the app, but that's a remarkably great trade-off I'm more than happy with.

Smillasnowy

I fixed it by turning off AirPlay. Settings > General > Airplay

None of the other suggestions worked for me.

EZenderink

Spotify Cliënt Running On:

Xiaomi Mi 9t Pro

Android 11 (MIUI Global 12.5.1)

 

Playback Device: Marantz S5013

 

I experience the same problem with the above hardware. I like having the app running in the background to quickly change songs.

 

Was listening to music while watching something on my phone, which I wanted to play back louder. So I upped the volume while watching that video on my phone. Unaware that apparently I was going to change the volume on my receiver instead (there was no indication that I had volume control of my receiver using the default android volume controls).  This issue I had before but appears to be random. The second unfortunate thing is that the volume range of 0-100% is mapped directly to the receiver. The volume control of Android (perhaps out of your scope) can go from 0-100 in a second or so, if you hold the volume rocker. I literally almost blew my eardrums, receiver and speakers to heaven....

 

Some suggestion I hope can be looked into, for the love of my eardrums, audio equipment and sanity:

 

1. This should be a toggle option in the settings!

2. This should always work or not at all.

3. If volume of a device connected to Spotify is controlled by an active instance of Spotify in the background a CLEAR indication should be given (a pop up e.g.) .

4. Volume increase (decrease is debatable) should be done in increments over  a lengthy period of time, when the volume up button is pressed and hold. Only by manually pressing and releasing the volume up button volume increase should be able to increase faster.

 

Hope something can be done about this. 

 

 

boabw88

This thread also details a fix for this issue https://community.spotify.com/t5/iOS-iPhone-iPad/iOS-volume-linking-spotify-Connect/td-p/1629929 basically; opening the Spotify app on your phone, going to settings > devices and turning 'Devices Lock Screen' off.

yasharya11

Hello, I closed my app, and I was in a meeting so I turned my phone volume all the way down. I was browsing my social media when all of a sudden the volume went to max. When I returned to my computer I could see that even though I had the spotify app closed on my phone, my phone and my computers spotify app's volume were in sync. What the heck are you clowns coding ? You letting the interns code this whole thing without any reviews? Jesus ... hire a QA engineer they work for 8 dollars an hour out of india

mljenkins

ROFL I’m dying because I’ve had the same happen.  Please Spotify put a simple switch on the phone app to enable or disable syncing of the volume!!!!

AndresM

Hi everyone. 

 

Thanks for posting and replying to this thread. 

 

Could you send us the make/model, OS version and Spotify version of the devices related to this issue? 

 

On another note, tell us if this is happening when logging in with another account (on these devices).

 

Lastly, go to Spotify > Settings > Devices > Spotify Connect in the background, toggle it off, restart and tell us if the issue persists. 

 

We'll be here on the lookout for your reply. 

AndresMModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
"Music touches us emotionally, where words alone can't." -Henry Thoreau

halosos

I get this issue too. 

 

Spotify keeps opening itself in the background, I cannot control this without flat out uninstalling it from my phone.

 

In order to stop Spotify from taking control over my phones volume buttons exclusively to control spotify volume on *any device I am currently using*, I have to open spotify and close it again. 

 

But without opening spotify on my phone, anywhere from 10 minutes to an hour, my volume controls will be highjacked by spotify again if I am listening to spotify on another device. 

 

Examples of this behaviour:

 

I arrive at work. I turn on my work PC. I start listening to spotify on my work PC. I receive a loud notification on my phone, I go to turn my phone down, but Spotify has taken control and I turn down my music instead. So I unlock my phone, open spotify and close it. I can now turn my phone down. Fast forward 3 hours, I have not touched my phone since. It is now my lunch. I have left spotify playing music on my work machine. I step out of the room for my lunch, I have things I want to do on my phone, so I turn up the volume, only to find out that spotify has once again taken control of my phones audio. So I have to, open spotify, again and close it, again. 

 

Things like this keep happening multiple times a day, on my work PC, home PC, laptop and even my Alexa. 

 

Frankly, I would like an option to disable this feature or spofity be taught to only do it WHILE THE APP IS OPEN OR IN THE BACKGROUND. Having to open and close it each time gets old real fast.

Dian

Hey @halosos,

 

Thanks for posting your experience in the Community.

 

Could you tell us the brand/model and operating system of your phone?

 

It is also worth performing a clean reinstall of the app in the meantime, so we are sure, that you're running a fresh installation of the app. Here is how to do this.

 

Based on your description and depending on the phone brand and operating system, can you check if Spotify is set as an exception to run in the background?

 

Keep us posted,

 

Cheers!

DianModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.

TheNamesJames

Hi, I’ve experienced this same issue for several months now. The currently accepted solution is inadequate for me (as I understand it, I should manually force close the Spotify app on my phone whenever I want to play Spotify on my Mac?!)

 

I’ve tested under several different scenarios, with the “Devices Lock Screen” (the toggle in settings that allows you to control audio volume for Connect from the iOS Lock Screen). Regardless of the value of toggle, this issue persists.

 

And it’s definitely the Spotify Mac volume. I’ve intentionally set the Spotify Mac app volume to specific values and used over extended periods of time to see how it affects the volume change on my iOS device. For example, I’d use the mac app volume to 75% for a few weeks and I’d notice that my iPhone would intermittently reset its own volume to 75%. Following that test, I used Mac Spotify at 100% volume and my iPhone would follow suit, intermittently resetting iOS volume to 100%.

I’ve done these tests both with the Device Lock Screen toggle on and off. Both yielded the same result: my iPhone device volume changing unexpectedly.

 

This is a nuisance! Please help (either with troubleshooting steps or other!)

Suggested posts