Metadata Doesn't Send to Radio after using another Bluetooth Audio device (such as headphones)

Metadata Doesn't Send to Radio after using another Bluetooth Audio device (such as headphones)

McBeats

Plan

Premium

Country

 

Device

Razer Phone 2

Operating System

Android 9 (Pie)

 

My Question or Issue

So as so many others have reported, when we go to use spotify via bluetooth in our vehicles (mine being Uconnect in a Ram specifically) it doesn't send the track / artist info unless we change the AVRCP prof to 1.3. That works, which still annoying, coming from iOS where everything worked perfectly. But today I went to the gym and used my bluetooth headphones with Spotify. Turned them off on my way out like I always do. I get in the truck, turn it on, it connects, but just displays the name of my phone. Music begins playing, but no info. I can't even skip forward or go backward. The only fix is a reboot, which is silly. This all worked fine on iOS. No changing profiles, things just worked. Please don't make me go back. Google Play music DOES send the info, after a bluetooth turn off/back on. Doesn't fix spotify though. The metadata is one thing, but not being able to skip back or forward tracks? That's a bit much.... Please send help. 

 

Reply
6 Replies

McBeats

I ended up downgrading to 8.4.95 and all is well .

 

Kylejohnhenry

Same issue with my Moto G7, spotify version 8.5.2.759. Cant advance songs with bluetooth, and wont display songs. Phone calls and all other features BESIDES spotify work good, including Google Music.

 

I have a Samsung Tab E, spotify version 8.4.98.892

 

PLEASE HELP!

McBeats
Try 8.4.95 just Google Spotify old apk. You'll need to uninstall the new
one first. Disable auto update!

Kylejohnhenry

Hopefully a short term solution to a short term problem, ill see if it works! thanks for the idea! Hopefully spotify fixes this!!!!

Peter

Hey folks,

 

Thanks for reaching out to us about this, and apologies for the late reply!

This sounds like an issue which we are aware of and currently investigating.

 

Make sure to head over to this thread, where you can keep track of our progress. We'll keep you posted in the thread and let you know as soon as we have any updates.

 

Let us know if there's anything else 😉

Kylejohnhenry

My problems have worsened as Spotify keeps updating. Still no data on uconnect screen from my Moto g7. Latest version of Spotify, and phone is completely up to date.

 

NOW, Everytime I unlock my phone while in my pickup, it "pauses" the music on my uconnect, but the track keeps going along while no audible music is played through pickup or phone. I have to push the play button on the uconnect to get the music audible again in the pickup. Very very annoying. Please suggest something Spotify. This is ridiculous. I have been paying for Spotify premium for 5 years.

Suggested posts