No Internet Connection Available

No Internet Connection Available








Redmi Note 7 Pro



My Question or Issue

I keep getting 'No Internet connection available' on my Android whenever I connect to Wifi. It is working perfectly fine on Mobile Data. If I am using App on Windows or PS, it is working even on Wifi. The issue is persisting only on my Android. I have tried everything, cleared cache, installed, reinstalled, logged out of everywhere but, I am still facing the same issue.

4 Replies

Hey @Salander,


Thanks for posting in the Community.


As this is happening only on one device, it most probably is related to either the device itself or the network connection. Could you reset your router or try a different Wi-Fi connection?


What happens if you use your account on a different Android device connected to the same Wi-Fi network?


Keep us posted,



Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.

Hey Dian, 

Thank you for replying. 

I have tried resetting my Wifi and my device. It still shows the same error.

When I am connected to a different WiFi, I am facing the same error. It's not working for different Android devices on the same WiFi network as well.

Thank you.

Hey @Salander,


Thanks for your reply and for the info shared 🙂


In this case, we'd like you to check if you have enabled both Wi-Fi and Mobile Data usage in your device settings when using Spotify. To check this, you have to go to your mobile phone settings> Apps> Manage apps> Spotify> Restrict data usage> check both Wi-Fi and Mobile Data are enabled.

If this doesn't do the trick, could you share with us the exact OS version of your device along with the Spotify version you have installed?

Lastly, just to confirm, if you open your account on a different mobile device and you connect to a different Wi-Fi connection, do you receive the same error?  It’d be awesome if you could check. You can ask for the mobile device of a relative or a friend to open your account and check.

Keep us in the loop!

Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.

Hello AlejaR,


The options were already enabled but, the issue was still there. Seems like there was an issue with the OS version. I updated my OS and the app is working perfectly fine now.


Thank you so much for your support. 🙂



Suggested posts