Sleep timer not working with podcasts

Reply

Sleep timer not working with podcasts

pauldwade
Music Fan

I use some podcasts to help me get to sleep, but I've noticed that the sleep timer doesn't work with them, episodes keep playing even though I set the timer to stop playing after the episode or an hour. 

Is this a known issue? 

 

Plan

Premium

Country

UK 

Device

Google Pixel 4a 

Operating System

Android 11

 

 

23 Replies

Mihail
Moderator
Moderator

Hey @pauldwade,

 

Thanks for reaching out to the Community.

 

If the Sleep Timer feature doesn't act as expected it's a good idea to clean reinstall Spotify on the device where this occurs. This step lets you start afresh with the latest app version by removing any corrupted files from previous installations. 

 

If afterwards the issue persists, could you let us know if you can replicate this also with another account, such as friend or family members?

 

Keep us posted! We'll be happy to lend a hand if you need more help.

MihailModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 
“Music is a language that doesn’t speak in particular words. It speaks in emotions, and if it’s in the bones, it’s in the bones.” - Keith Richards

pauldwade
Music Fan

I've done a clean install and will try tonight and see what happens. I don't have access to other accounts but I can try a different device. Thanks.

pauldwade
Music Fan

Hi, I tried the sleep timer after a fresh install and still didn't work. I selected 'end of episode' and it kept playing. I also tried it on a Samsung Galaxt Tab s5e and sleep timer didn't work on that either.

I've also noticed that the playback speed doesn't work either, I tried a few speeds and playback was the same.

You'll notice from the screenshot that every episode gets added to the queue so it keeps playing.

I don't have any other accounts I can use so can you test it your end?

Screenshot_20201203-005042.png
Screenshot_20201203-005117.png
Screenshot_20201203-005059.png

Mario
Moderator
Moderator

Hi again @pauldwade,

 

Thanks for getting back in touch.

 

Could you let us know if the issue occurs also when you listen to music or only with the podcasts? We'd also like to know if the issue persists with other podcasts too or only with the ones you usually listen to. 

 

On another note, let us know if this has always happened, or if it started happening after a specific event.

 

Also, could you send us the exact Spotify version of your devices?

 

Cheers - We'll keep an eye out for your reply!

MarioModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
"There's more to living than only surviving." - Dexter Holland

pauldwade
Music Fan

I think I've worked it out. I tested some podcast episodes and played back through my phone, and the sleep timer worked fine. 

 

However I usually play them back through my Google Nest Audio, and when I tested playback through that the sleep function failed.

 

So it sounds like a bug that the sleep timer and playback speed are ignored when using a connected device for playback.

 

I also tried playback through a chromecast on a TV, the sleep timer worked but the playback speed didn't. 

 

It seems like a bug with your app or your app when connected to Google cast devices, but it's something that should be escalated for investigation as it's really annoying to not be able to use a timer when connected to a device. 

Mihail
Moderator
Moderator

Hey @pauldwade,

 

Thanks for getting back to us and for the troubleshooting you've done.

 

As we haven’t seen any similar posts about this, we feel this is most likely isolated to your device or specific setup. To that end, we would like to make sure that the behavior is not caused by errors in the connection between Spotify and the Google Nest. Could you unlink your Spotify account from the Google Home app and then clean reinstall both apps anew, before reconnecting your accounts? You can use the steps here.  We'd also appreciate it if post the Spotify version you're running as @Mario mentioned. 

 

Keep in mind that the playback speed function can't be used when streaming on another device. if you'd like this feature introduced you can post an idea about it on our Ideas exchange. The Community team is actively bringing your feedback to the internal teams at Spotify - check how here.

 

Keep us posted. We’ll keep an eye out for your reply.

MihailModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 
“Music is a language that doesn’t speak in particular words. It speaks in emotions, and if it’s in the bones, it’s in the bones.” - Keith Richards

pauldwade
Music Fan

I've tried removing Spotify from Google Home then re-attaching it and no change. Looks like I'm going to have to use a different podcast player. It seems it could also be fixed if you stopped podcasts from auto playing the next episode, as people are asking for here:

 

https://community.spotify.com/t5/Closed-Ideas/iOS-Podcasts-Disable-autoplay-on-podcasts-play-next-ep...

 

For now unless there are fixes to the app looks like I'll have to live with it. 

Gluax
Visitor
I'm definitely having the same issue. Why even have the feature shown if it's not gonna work. Should at least remove the icon showing the sleep timer function of you playback it through another device.

sbozzie
Regular

I'm having the same issue, found this thread while looking for a solution.

 

Sleep timer doesn't work when playing podcasts on another device (Google nest mini) and just continues to play though podcasts in queue.

pauldwade
Music Fan

I don't think they're too bothered, I've given up on Spotify for podcasts and now use Google Podcasts which has the same ones I'm looking for on it and sleep timer works fine when casting to a nest mini. 

deeeeekun
Regular

Hi!

I'm having the same issue. Same set up. Casting podcasts on Google Nest.
Is this currently on the list of bugs to be fixed or would I have to find a workaround?

pauldwade
Music Fan
Unlikely, better off using Google Podcasts

Mihail
Moderator
Moderator

Hey @deeeeekun, @sbozzie and @Gluax,

 

Thanks for searching for the answer you need here. 

 

Could you please list the any of the troubleshooting steps posted above that you've already tried? That way we can avoid suggesting that you repeat some of them.

 

@pauldwade we're sorry to hear you're still experiencing this issue. The fact that the sleep timer works on your phone and when casting to your TV indicates that the root cause of the problem lies with your Google nest. Have you considered performing a factory rest on the speaker? That would clear the firmware of any errors. You can use this Google guide.

 

Keep us posted!

MihailModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 
“Music is a language that doesn’t speak in particular words. It speaks in emotions, and if it’s in the bones, it’s in the bones.” - Keith Richards

sbozzie
Regular

Hi @Mihail
The speakers in question have had a factory reset.
I've tried on other Google home devices as well.
I've also carried out a clean install of Spotify.

 

Thanks,

- Sam

pauldwade
Music Fan
@Mihail actually that's not correct. Just because works through the phone doesn't mean it's not an issue with the app. It's entirely possible that the app is not sending the correct data to the nest or it ignores sleep timer settings when it is casting. As others are experiencing the same problem I'd suggest you pass this on to your tech or development teams.

Mihail
Moderator
Moderator

Hey @sbozzie,

 

Thanks for getting back to us with the requested info.

 

The next thing we can check for is uncoupling your Google and Spotify accounts, clean reinstalling them  and relinking them again. That way the connection between the profiles will get built from the ground up.  You can use the steps here

 

If that doesn't fix things, we'd appreciate it if you have the option to borrow a friend or family members account and see if it works there.

 

Let us know how things work out, we'll keep an eye out for your reply!

MihailModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 
“Music is a language that doesn’t speak in particular words. It speaks in emotions, and if it’s in the bones, it’s in the bones.” - Keith Richards

sbozzie
Regular
Hia - I have done this as part of my clean install - this also impacts my friends account - and as @pauldwade notes - a number of other users it seems!
Has the tech team there attempted to replicate this issue?

Mihail
Moderator
Moderator

Hey everyone,

 

Thanks for your troubleshooting and the cooperation so far!

 

We apologize for the confusion, but we can confirm that this expected behavior. Due to the way the app is currently set up the Podcast Sleep Timer isn't able to pause playback when connecting to another device. We recommend that you post an idea that requests this feature in on our Exchange. You can learn how to do this here.

 

The Idea Exchange is a great way for us to keep track of what changes our users are interested in and how popular a certain idea is. This page explains how exactly your feedback reaches Spotify.

 

Don't hesitate to let us know if you have any further questions!

MihailModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 
“Music is a language that doesn’t speak in particular words. It speaks in emotions, and if it’s in the bones, it’s in the bones.” - Keith Richards

deeeeekun
Regular
That's weird cause it used to work before.
So bug reports should also be posted as a "feature suggestion"?
SUGGESTED POSTS