Spotify not working correctly in car

Spotify not working correctly in car

Andrej64

Plan

Premium

Country

CZ

Device

OnePlus 7

Operating System

Android 9

 

My Question or Issue

Hello,

I have bought new Android phone (OnePlus 7) and I am experiencing issues using Spotify in my car (BMW 5/F10, 2015):
* Name of the song/artist is not visible in the car display

* I am not able to use rewind/fast forward buttons on my steering wheel. 

Additional info:

* Everything works correctly in other applications (Google Play Music, YouTube)

* I have tried uninstalling Spotify, reboot phone, and installing Spotify again. It didnt help.

* I have disabled battery optimization option for Spotify. It didn't help.

* I have changed AVRCP to version 1.5 in developer options. It didn't help.

 

Best regards

Andrej

Reply
7 Replies

theleebryan

Same goes in my Mini Cooper S. latest iOS, iPhone XS… same problems and more.

Peter

Hey @Andrej64 and @theleebryan,

 

Thanks for reaching out to us about this 🙂

This is actually an issue which we are aware of and currently investigating.

 

Make sure to head over to this thread, where you can keep track of our progress.

 

We'll keep you posted in the thread and let you know as soon as we have any updates.

 

Let us know if there's anything else 😉

Andrej64

Hello,

 

it seems that I have found the solution. Go the the Settings -> Developer options -> Bluetooth AVRCP Version  -> change it all the way down to AVRCP 1.3  -> Reboot the phone.

 

This has done the trick for me. Hope it helps!

theleebryan

Great, Ill see if I can find the iPhone equivalent and see what happens. 

 

Thuye actually had sorted the logo issue, but the steering wheel control still doesn't work, and its a real struggle to get the initial connection to the car.

StephM24

Hey,

 

I saw this thread from last year, normally my Spotify works fine in my Mini but as of today I’m currently experiencing this problem. 
Is there a current issue on this? It was fine 2 days ago. 

Many thanks

Jeremy

Hi there @StephM24,

 

Thank you for reaching out to the Community.

 

Can you confirm if you followed the troubleshooting that's been provided in the thread?

 

We also suggest that you perform a clean reinstall of the app. This will make sure there's no old cache files causing this.

 

Keep us posted 🙂

Take care!

JeremyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Live, love, laugh and listen to music 🙂

StephM24

I had tried that but I hve just gone to try again in my car and it all seems to be working again. Thank you very much for the help. Have a lovely day!

Suggested posts