Help Wizard

Step 1

NEXT STEP

FAQs

Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...

VIEW ALL

Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...

VIEW ALL

Spotify won't play on Google Home

Spotify won't play on Google Home

Plan

Premium

Country

Mexico

Device

Huawei Y9S and PC

Operating System

Android 11, Windows 10

 

My Question or Issue

I have two Google Home Mini speakers and a Google Chromecast which I used to stream Spotify to with no issues. Almost a week ago now I am no longer able to hear any music coming out of the speakers or the TV with the Chromecast. The Spotify app shows like it is linked and playing songs on the device of choice but no sound actually comes out. I skip to the next song, start another album, turn the volume up/down, but I get no sound. The devices aren't muted nor are they on Do Not Disturb. I contacted Google and explained, we tested Music and Podcast from the YouTube Music App (non-premium) and Google Podcasts and they work, I get sound and everything, but once I check with Spotify again there is no sound. I also did a factory reset on both the Google Home mini speakers and uninstalled the Spotify and Google Home app, unlinked the Spotify app from the Google Home app and set everything up again and still nothing.

 

 

Reply
16 Replies

Hey @AlexTor,

 

Thanks for posting here.

 

The troubleshooting steps that you've tried so far are very good. We'd like to suggest a few more.

 

Could you give these steps a go and run a clean reinstall? This one is more thorough.

 

We'd suggest you also try another account on the same devices to see if that makes a difference. That way we can check if this is an account-related issue. Does that make a difference?

 

Let us know how it goes.

Ver Moderator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Hi!

 

Yes I tried the clean reinstall steps and still no success. I also tried with another Premium Spotify account and I had the same result.

 

 

Hi there @AlexTor

 

Thanks for your reply. 

 

Would you mind trying with a different internet connection to see if that makes the difference?

 

On another note, we'd like to know if this started happening after a specific event such as an update. 

 

Lastly, we suggest checking if the OS/firmware of your devices are up to date. 

 

Keep us posted.

EniModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 
“Music acts like a magic key, to which the most tightly closed heart opens.”– Maria von Trapp

I've the same issue. When I try to cast music to my Google Home device (Xiaomi Mi Smart Speaker) it says "connecting" but it times out. Music plays fine on the speaker when I use voice commands.

I've the latest version of the Spotify app and I'm running Android 11 from a Pocophone X3.

Any ideas? Is this a known bug in the Spotify Android app?

Hey @aalcarazp,

 

Thanks for reaching out about this.

 

Could you let us know which troubleshooting steps you've already tried? That way we can avoid any repeating steps.  

 

On another note, would you mind letting us know if the same happens using a different phone?

 

We'll be on the lookout for your reply.

EniModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 
“Music acts like a magic key, to which the most tightly closed heart opens.”– Maria von Trapp

Hi I also have the same issue, casting Spotify to my google home, or asking google to play Spotify. It thinks it’s playing but with no sound - exactly as mentioned by the OG post.

 

no issue with my Alexa ue speaker 

 

 

The google home also makes the connection noise to say the device/Spotify is connected. It just doesn’t play the song - and then if I pull the app on my phone it has the connecting in the bottom left corner and the app has a spaz and just flicks through multiple songs and playing and pausing multiple times 

Hi there @Erendle,

 

Welcome to the Community!

 

First of all I'd recommend checking if there are any firmware updates available for your speaker and letting those install.


If that doesn't fix the issue, try unlinking and re-linking your Spotify to the speaker.

 

Here is how you do it:

  1. Open the Google Home app on your phone.
  2. Go to your Account in the top-right corner.
  3. Open Settings.
  4. Scroll down and select Music.
  5. Select Unlink.

Don’t leave this menu just yet. You’ll still have to re-pair your profile if you want to use it.

 

But before you do that, I recommend that you reboot your Google Home speaker. You can do it through the app or by unplugging it and plugging it back in.

 

Once you’re done, re-add your Spotify account. You do it through the same menu as above.

 

Note that some users report that this issue is sometimes caused by weak connection, so try moving your speaker closer to the router.

 

Let us know if that helped.

AlexModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Hi all,

This issue has just started to affect me as well, a clean reinstall of Spotify helped for a single day before the issue re-occurred. Factory reset of the home and the multiple reinstalls of the Spotify Desktop App ultimately did not help with this issue . The attempt of the unlink and relink doesn't really help in my case as Spotify will work fine if asked to be played directly on the device but when trying to cast from the desktop app is where the problems lie. Trying to cast from the phone app works as expected, for my case, this seems to only be affecting the Desktop App. Has anyone found a solution for this issue at the moment?

 

Cheers

Hi @timmythechicken,

 

Thank you for your reply and for the troubleshooting you've done so far 🙂 Great job!

 

We can see that you've reinstalled the app multiple times, however - have you followed the steps under Clean reinstall? This is different from a quick reinstall as this will make sure there's no old cache files causing this.

 

Also, can you restart your router to see if it makes any difference? If you have the possibility it would great if you could try a different internet connection as well.

 

Let us know how it goes so that we can continue to assist you if you need us to.

 

Take care!

JeremyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Live, love, laugh and listen to music 🙂

Hi @Jeremy

 

Thanks for getting back to me, yeah I have attempted the clean re-install as well where the same end output is reached where this will be functional for a single day after which the issue will be seen again. In all attempts, this endpoint was reached except the last attempt where this was non-functional from minute 1. Should note that in the last attempt there were no cached files for deletion for the clean reinstall. I am not sure if this is relevant but in the other cases that I have seen after a reinstall Spotify would not have been restarted until the following day when I would face the issue - could it have something to do with Spotify restarting? I also went ahead and tested with a different account as mentioned in another post and that did not seem to help either.

Router restart did not help either, it seems that this issue for me in particular is only seen on the desktop app as the phone app and straight ask on the home device works without question. Casting from the web app of Spotify also functions as expected from the same device that is facing the issue with the desktop app version.

 

Cheers

Hey @timmythechicken,

 

Thanks for the additional info.

 

This issue has already been reported here. Can you please add your vote and post a comment with the requested information (device model, OS and Spotify version)? We'll update the thread once we have more info to share.

 

Let us know if there's anything else.

 

Take care,

YordanModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a "Like".
Are you new to the Community? Take a moment to introduce yourself!

Same problem imposible to cast from Spotify since approx 2 weeks. Why? What is the solution?

 

Hey All,

 

Seems this issue has returned again - Has anything changed in the past update to cause this to come back? Again the issue is local to the Desktop version only. Casting from a phone works fine but trying to do it from the desktop is missing many of the potential devices seen in the other devices. Devices are on the same network and same room so not an issue with that. Seems the issue started on the 08/06. When cast to the speaker its seen on the desktop player but when moved off it there is no choice to re-cast to the device.

 

Any help on this would be great as it's just annoying not being able to cast properly from all devices.

 

Cheers

Hi there,

 

Same issue here, any solutions yet? 

It's really annoying not being able to broadcast the audio from PC to one of the 8 Google AUDIO i have at home (some 2 of them paired)

 

Thank you!

 

David

 

Hey folks, 

 

Welcome to the Community and thank you for joining the conversation.

To continue investigating this issue, would you mind checking if the Web Player has the same behavior? This will give us a better look at the issue.

Also, include in your next response the OS version of your device and the Spotify version you're currently running to continue investigating the case.


We appreciate your reports and cooperation.

We'll be on the lookout. 

OscarDCModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Suggested posts