Announcements

Steering wheel controls not working anymore (MBUX)

Steering wheel controls not working anymore (MBUX)

Plan

Premium

Country

Germany

Device

OnePlus 6 (A6003)

Operating System

Android 9 / OxygenOS 9.0.5

 

My Question or Issue

My phone is connected via bluetooth with my A-Class Mercedes (Model 2019). From November 18 to April 19 I had no problems and was able to control my Spotify app via the steering wheel and display controls (switching songs etc.). Since about April 19 I can not control the app anymore like before. When I press 10 times on "next song" on my steering wheel it changes the song maybe 1 time... And I'm only facing this problem with the Spotify app. Everything works fine with other music apps like Pi Music Player.

 

Any suggestions?

Reply
18 Replies

I also have this problem. There's a specific problem with Spotify. I have a OnePlus 6T and I have the same problem.

I have the same problem with the same car and the same phone and Spotify only! Did you reach out to Spotify yet? Do you still have this problem? 

I'm thinking about cancelling my premium account because it is driving me crazy!! 

Hello I still have the problem. I have tried with a technician from Spotify but it still do not work.  I'm also thinking to cancel my premium account: it drives me crazy!!!! Spotify do not seem really "affected" by our case! The techician was great but I still have no solutions (i have tried everything: changing phone (Samsung, Oneplus, Huawei,...), changing OS (Iphone)--> no solutions

I had a long discussion with the support of Spority and we tried out a lot of different things. But nothing fixed this issue. They told me that a tech team had a look at this and it will be fixed with an upcoming update of the app.

Therefore we have to wait...

 

 

I fixed it!! Download the "android auto" app if it's not in the app store just download it from the internet. I couldn't get the android auto on my car screen but nevertheless having and using the app just on my phone fixed it! I can pause and play rn skip tracks whenever i want 😁😁

Thanks alot. It's a good workaround. But it does not fix the problem itself. I'm still waiting for a bugfix.....

I just got A-Class today and can confirm this problem. It's really sad it experiences such issues. Tho this could be caused by some Android 9+ security stuff. Despite the other apps work just fine...

I also have this problem, anyone found a solution?


Please Spotify solve this problem ASAP.

No solutions for the moment and Spotify doesn't feel concerned by this problem. We are just few people in this case and they don't care even if we stop our accounts.

I had contact with the Support again after nothing happened for a few months. They told me to inform the dev team, again. But as soey77 said they dont really care about this bug. I will switch to Google or Apple music because I dont want to wait any longer...

 

I stopped bothering. I just use Android Auto built in my MBUX. Tho I can imagine that not everybody has the option whilts Media is available everywhere.

I found some walkthrough in android and it works (more or less) …

First you must put your phone with developer option, then in networking area at Bluetooth AVRCP version, put it in 1.3 instead of 1.4 that’s the default.

Then you can control in MBUX but the album image doesn’t showScreenshot_20191010-001846.png

Hello yes i have done that but sometimes it works sometimes not :'( 

Hey guys, do we all have a oneplus phone?? Could be a oneplus problem! After a oneplus update last week it finally worked. I could play/pause and skip tracks! It worked for a whole week. But now it doesn't work anymore. So i use the android auto app again...

No, in my case I have a Nokia 7.1 with android one and the last update.

It's now working for me again after I upgraded to Android 10.

I have had this issue since 2015 (worked fine in 2014) i spoke to someone on live chat twice and they haven't been able to help. 

Hey there @Shel_15

 

Thanks for reaching out about this. 

 

The team in charge is aware of this issue and they're looking into it. 

 

In this case, we’d recommend adding your +VOTE to this Ongoing Issue. You can also subscribe to it by clicking the three-dot menu next to the title and we’ll keep you updated with any relevant updates there.

 

If anything else comes up, we're always a message away. 

 

Have a good one.

NovyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Suggested posts