Help Wizard

Step 1

NEXT STEP

Weird behavior while playing music

Weird behavior while playing music

Hi. Since seveal days I have some problems with Spotify. At the moment a song is playing which is actually the next one in the playlist. But the player still shows the last played song at 3:53 of 4:33. It also happens that the player counts the time further when a song is finnished. It shows something like 7:54 of 4:34, while playing the next song. And after that song the music stops completely. Then I have to start it again. If I press "next song" the last played song starts again.

 

It's weird. And somtimes it works again for a few hours or days and then the problem occures again.

Plan

Premium

Country

Switzerland

Device

Samsung Galaxy S22 / Galaxy Tab S7

Operating System

Android 13

 

My Question or Issue

See above.

How can I solve this? I already tried the following:

  • Rebooting devices
  • Deleting App-Cache
  • Resetting App
  • Uninstallin App and reinstalling

Same problem can happen if I use Spotify on my Windows 11 PC.

Reply
14 Replies

Hello @emma139 

 

Let's try and resolve this

Firstly, I'll need you to provide a video recording of this behavior, so we can check more thoroughly what exactly is occurring on your end. And also, it'll help if we can see how this behavior is on each of your affected devices.

 

Next up, I need to know the exact Spotify version you're running on the affected devices.

By the way, is there interruptions to the playback or is it just a visual problem on your screen ?

 

Lastly, would you kindly check if the same happens when you open a different account on the affected devices. A relative/friend's account would do.

 

I'll be waiting for your response, take care 💚

TaylithSpotify Star
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.

Hi Taylith

I sent you a lot of information responding to the email I received...Later I saw that it is a noreply-address. But I haven't received any delivery error back. Have you received them?

Anyway. Here is the information I sent you by email:

The following happend just now after a few days without a problem:

  • I heard the song "Kommissar" from Falco. Everything was ok
  • After the song the music stopped
  • I checked what the Spotify app on my Galaxy S22 shows
  • The app showed the song "Beat it" from Michael Jackson playing (see video 1). Playing at 4:44 of 4:18.
  • While I checked this the music started again without pressing the play button
  • But the song I heard was "I'm so exided" from The Pointer Sisters
  • After a while the app showed the song "Come on Eileen" from Desys Midnight Runners
  • But I still heard I'm so exided (video 2)
  • Since then the app always showed "Come on Eileen" but it was playing "It's raining men"
  • Now the music has stopped but the app still shows "Come on Eileen". Playing at 08:05 of 03:25 (video 3)

For the moment I only have documented it on my S22.

I haven't had the chance to test it with another account.

The S22 runs with Spotify 8.8.25.409

 

Btw. At the moment the app still shows "Come on Eileen", playing at 11:50 from 3:25. But there is not music playing.

 

Link to the videos: https://photos.app.goo.gl/dii2wxTtXNZfnxS79

Me again. Had the chance to record some errors with my Galaxy S7. 

  • I heard "More than this" from Roxy Music
  • After this song there was a short break
  • Then the song *Don't go" from Yazoo started playing
  • The app still showed "More than this". Playing at 06:24 of 04:30 (video1)
  • After this song the music stopped
  • The app still showed "More than this". Playing at 09:05 of 04:30 (video2)

Sorry. I forgot to activate the microphone of my devices. If you need a proof of the wrong playing songs let me know.

 

Spotify version on my S7 is 8.8.28.409


Link to the videos: https://photos.app.goo.gl/kL3sH4NP5qaCNLpj9

In the meantime I had the chance to test another thing. My wife took over Spotify with her phone while my list was playing. Since then everything works fine.

Hi @emma139,

 

Thanks for all the info. So has the issue now disappeared? Is everything working as expected again for you and your wife? In case the issue comes back, please attach the videos using Google Drive or as unlisted YouTube videos as we were unable to access your link. 

 

Hope everything works for you now, let us know if you need anything else.

JoanModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Hi Joan. No. The opposite happended. Yesterday I had the same issue. My wife took over and expected the same issue too. The music stopped to play while the app counts forward (8:23 of 4:15....). When that happened she pressed "next song". After a few times doing so the playback worked again. 

But we are far away from "solved"...

 

Hi @emma139,

 

Thanks for letting us know. In that case, please send us the videos one more time as previously described. Then, we will gladly investigate this further.

 

Thanks in advance.

JoanModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Hi Joan. The links to the videos still work. You can download them there...

Hi @emma139,

 

Most likely so, but because of security restrictions, we cannot open that link. Please send the videos via Google Drive or upload them as unlisted on YouTube.

 

Thanks in advance.

JoanModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Please find the videos here: https://drive.google.com/drive/folders/1eB2hOwEVyQq6wPnOytf4NtdS24RZ8VkK?usp=sharing

 

Folder 1 -> My post beginnig with "Anyway. Here is the information I sent you by email"

Folder 2 -> My post beginning with "Me again. Had the chance to record some errors with my Galaxy S7"

Hey @emma139,

 

Thanks for getting back to us and providing the requested videos.

 

This looks odd and we'll do our best to help you out here.

 

We've noticed that you mentioned your Spotify version is 8.8.28.409, which is not the most recent one. Could you please try to update your Spotify app on your phone and test if you'll still experience this?

 

We'd like you to try couple of things on your PC as well. First off, open the Desktop App's Settings and turn off "Enable hardware acceleration". This setting is located under Compatibility.

 

As a second step, we'd suggest that you disable any antivirus or ad-blocking software on your PC, and turn off VPN if in use. 

 

Lastly, it's worth checking your hosts files - steps can be found here for Windows device and here for MacOS devices.

 

If the issue still persists, would you mind checking if this happens when using the Spotify Web Player?

 

Hope this does the trick for you, reach out if you need more help!

LyubkaModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.

Hi Lyubka. I think you overread that I'm talking about the Spotify app on Android. I don't find any newer version of the app and it doesn't help to go through any steps in the desktop app:-).

 

What I found out is that the problem only appears while playing Spotify on Sonos. Bluetooth connection in my car work normally as far as I can say that. Because I don't check if the display is showing the correct song with the correct time when I'm driving...

Hey @emma139,

Thanks for getting back to us.

As a last measure, can you please try factory resetting the Sonos speaker?

Let us know how it goes.

MihailYModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Suggested posts