Reply

Blank window after installing

TechieAndroid
Casual Listener

Just installed on Kubuntu 18.04 LTS and it's not loading one bit, just sits there as a blank window.

 

Terminal outputs this when trying to run Spotify:

mkdir: cannot create directory '/run/user/0': Permission denied
ln: failed to create symbolic link '/root/snap/spotify/16/snap/spotify/16/Documents': No such file or directory
ln: failed to create symbolic link '/root/snap/spotify/16/snap/spotify/16/Desktop': No such file or directory
ln: failed to create symbolic link '/root/snap/spotify/16/snap/spotify/16/Downloads': No such file or directory
ln: failed to create symbolic link '/root/snap/spotify/16/snap/spotify/16/Music': No such file or directory
ln: failed to create symbolic link '/root/snap/spotify/16/snap/spotify/16/Pictures': No such file or directory
ln: failed to create symbolic link '/root/snap/spotify/16/snap/spotify/16/Videos': No such file or directory
ln: failed to create symbolic link '/root/snap/spotify/16/snap/spotify/16/Templates': No such file or directory
No protocol specified

(spotify:8580): Gtk-WARNING **: cannot open display: :0
1 ACCEPTED SOLUTION

Accepted Solutions
Solution!

TechieAndroid
Casual Listener

I initally used the snap install spotify method, which had problems. I just tried the debian installation since it said it was better at supporting the LTS versions of Ubuntu and it worked.

https://www.spotify.com/us/download/linux/

View solution in original post

3 Replies

awfulshot
Music Fan

Mine was fine until today. I launch and get a blank window as well.

 

I have Ubuntu Mate 18.04 and the latest Spotify snap package installed.

 

oddly I get a different error:

Gtk-Message: Failed to load module "appmenu-gtk-module"
Gtk-Message: Failed to load module "gail"
Gtk-Message: Failed to load module "atk-bridge"
Gtk-Message: Failed to load module "canberra-gtk-module"
ATTENTION: default value of option force_s3tc_enable overridden by environment.
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
[0613/133107.172894:ERROR:gl_context_glx.cc(227)] Couldn't make context current with X drawable.
[0613/133107.172927:ERROR:gpu_info_collector.cc(62)] gl::GLContext::MakeCurrent() failed
[0613/133114.062826:ERROR:browser_gpu_channel_host_factory.cc(120)] Failed to launch GPU process.
Solution!

TechieAndroid
Casual Listener

I initally used the snap install spotify method, which had problems. I just tried the debian installation since it said it was better at supporting the LTS versions of Ubuntu and it worked.

https://www.spotify.com/us/download/linux/

llaen
Regular

Same issue on openSUSE except the debian packages aren't an option for me. Strange (but not exactly shocking from what I've seen) that this issue has persisted since mid-June.

SUGGESTED POSTS