Dear Spotify dev: Spotify 32-bit deb build should use libssl1.00 rather than libssl0.9.8

Solved!
Reply
Highlighted

Dear Spotify dev: Spotify 32-bit deb build should use libssl1.00 rather than libssl0.9.8

villagedude
Casual Listener


As the 32-bit build now has hard dependency on libssl0.9.8, this makes spotify unable to be installed on Ubuntu 15.10 and onwards as libssl0.9.8 is no longer available in their package repo and has been superceeded by libssl1.00. You should update spotify dependency requirement to use libssl1.00. This won't be a problem for old Ubuntu LTS releases which are still being supported by Canonical because the releases too have libssl1.00 in their repo


Also I checked the 64-bit build, I see it lists libssl1.00 as dependency so its dependency requirements is fine for now and doesn't need to be updated.

 

 Edit. I don't know why I get those javascript codes under my post message. Maybe your forum software is borked

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Solution!

Re: Dear Spotify dev: Spotify 32-bit deb build should use libssl1.00 rather than libssl0.9.8

Dreadlord
Community Legend

Hey @villagedude,

 

Spotify latest version supports libssl1.0.0. 

Spoiler
hristo@Alpha:~$ lsof -p 1851 | grep libssl
spotify 1851 hristo mem REG 8,1 429976 138527 /lib/x86_64-linux-gnu/libssl.so.1.0.0
hristo@Alpha:~$ spotify --version
Spotify version 1.0.17.75.g8f111100, Copyright (c) 2015, Spotify Ltd

You can get the .deb package here.

 

If this solved your issue - Mark it as a solution!
Twitter | Website |
What's a Spotify Rock Star, and how do I become one?



View solution in original post

7 Replies
Highlighted
Solution!

Re: Dear Spotify dev: Spotify 32-bit deb build should use libssl1.00 rather than libssl0.9.8

Dreadlord
Community Legend

Hey @villagedude,

 

Spotify latest version supports libssl1.0.0. 

Spoiler
hristo@Alpha:~$ lsof -p 1851 | grep libssl
spotify 1851 hristo mem REG 8,1 429976 138527 /lib/x86_64-linux-gnu/libssl.so.1.0.0
hristo@Alpha:~$ spotify --version
Spotify version 1.0.17.75.g8f111100, Copyright (c) 2015, Spotify Ltd

You can get the .deb package here.

 

If this solved your issue - Mark it as a solution!
Twitter | Website |
What's a Spotify Rock Star, and how do I become one?



View solution in original post

Highlighted

Re: Dear Spotify dev: Spotify 32-bit deb build should use libssl1.00 rather than libssl0.9.8

villagedude
Casual Listener

Hey @

 

 

 

 

Version: 1:0.9.17.1.g9b85d43.7-1

 

 

Version: 1:0.9.4.183.g644e24e.428-1

 

I think this explains the reason why it always barf an error about libssl0.9.8 when the latest spotify-client in actual now uses libssl1.00. So yeah, please update the package info file for 32-bit build

 

 

Thank you!

 

Highlighted

Re: Dear Spotify dev: Spotify 32-bit deb build should use libssl1.00 rather than libssl0.9.8

Community Manager
Community Manager

Hey villagedude. Just enquiring about that strange code that got pasted below your original post. I Think I saw that once before when a user pasted something (Fairly innocent) in their post. Was hoping you could describe what exaqctly you did the first time that happened.

 

Thanks 🙂

Community Ergo Sum
Highlighted

Re: Dear Spotify dev: Spotify 32-bit deb build should use libssl1.00 rather than libssl0.9.8

villagedude
Casual Listener

Hello Per

 

I was writing my post in fully plain text and did some plain text pasting from sublime. Now I'm pasting..

 

spotify

 

Edit. Cant seem to reproduce it

Highlighted

Re: Dear Spotify dev: Spotify 32-bit deb build should use libssl1.00 rather than libssl0.9.8

villagedude
Casual Listener

or it could be the Labels which causes the code to be appended. I think that's all I did when I got the code

Highlighted

Re: Dear Spotify dev: Spotify 32-bit deb build should use libssl1.00 rather than libssl0.9.8

KevinMarkwell
Newbie

On the page www.spotify.com/uk/download/ the instructions install the older version. As many Ubuntu users will be using the latest Ubuntu version, could the new Spotify version (spotify-client_1.0.23.93.gd6cfae15-5_i386.deb) be linked to from that page, or an indication that there are new and old versions for versions of Ubuntu, or a direct link to http://repository.spotify.com/pool/non-free/s/spotify-client/ ? The new version works nicely on my Ubuntu 15.04, although I thought there used to be a Play Queue menu option to show the queue. Thanks 😄

Highlighted

Re: Dear Spotify dev: Spotify 32-bit deb build should use libssl1.00 rather than libssl0.9.8

Dreadlord
Community Legend

Hey @KevinMarkwell,

 

I don't think they are going to put the testing version anytime soon there.

If you want to add it yourself to apt, just execute the following command instead:

echo deb http://repository.spotify.com testing non-free | sudo tee /etc/apt/sources.list.d/spotify.list

If this solved your issue - Mark it as a solution!
Twitter | Website |
What's a Spotify Rock Star, and how do I become one?



SUGGESTED POSTS