Linux client barely usable on HiDPI displays

Solved!

Linux client barely usable on HiDPI displays

TurkeyBloke

I have a 4k display, and the Linux (at least?) client is practically unusable.

Is HiDPI support on the roadmap?

Reply

Accepted Solutions
Marked as solution

Tangram

Add --force-device-scale-factor=1.5 (or whatever fits your UI scale) as a command line option.

 

You could edit /usr/share/applications/spotify.desktop or wherever the .desktop file is located and change the line with Exec= to:

 

Exec=spotify --force-device-scale-factor=1.5 %U

 

Problem solved.

View solution in original post

Marked as solution

mobman02
I can confirm that this option does not have any effect on Spotify 0.9.17.1, the official version you get here: https://www.spotify.com/fr/download/linux/

View solution in original post

Marked as solution

andriesfilmer

I made a Alias in my .bashrc

 

alias spotify="/usr/bin/spotify --force-device-scale-factor=1.5"

 

This works on Ubuntu 16.04

 

 

View solution in original post

Marked as solution

jxjj

Great tip! Here's what I did on 17.10 in case it helps anyone:

  1. Open up Spotify snap desktop shortcut:
    $ sudo gedit /var/lib/snapd/desktop/applications/spotify_spotify.desktop
  2. Add --force-device-scale-factor=2.0 (or 1.5 or whatever scale factor you want) to the Exec line:
    Exec=env BAMF_DESKTOP_FILE_HINT=/var/lib/snapd/desktop/applications/spotify_spotify.desktop /snap/bin/spotify --force-device-scale-factor=2.0 %U 

     

View solution in original post

54 Replies

Erkan_Yılmaz

Hi,

 

could you explain what "practically unusable" means?

There is a linux beta version around since 2 weeks or so (only 64bit) did you try that yet?

 

Erkan

MattSuda

https://twitter.com/felipernb/status/575669571044114432

 

There are zoom in/out options, but right now they don't save so you would have to adjust every time you launch 

MattSudaSpotify Star
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.

TeerDrei

On HIDPI display its barely usable, because everything is so small.

Linux isn't very good yet in this regard, as it could just upscale by default, but doesn't.

bobbaluba

Where is this zoom in / out option located? I have a hard time reading the menus.

MikeAbrahams

There is no zoom in / zoom out.  I hope they improve high DPI support soon.  At this rate we'll be able to zoom individual windows on Wayland first. 

Marked as solution

Tangram

Add --force-device-scale-factor=1.5 (or whatever fits your UI scale) as a command line option.

 

You could edit /usr/share/applications/spotify.desktop or wherever the .desktop file is located and change the line with Exec= to:

 

Exec=spotify --force-device-scale-factor=1.5 %U

 

Problem solved.

spacepluk

That doesn't work for me.

spacepluk

It works with the beta 🙂

Thank you!

adrianbsuy

It should be automatically. Or at least have a GUI option to set the scaling factor.

brooksa321

Unfortunately, It does not follow the scaling factor set in the OS.

fastfox07
Thank you Tangram

spacepluk

The workaround doesn't work anymore with the latest betas 😞

thomasc6

I confirm this does not seem to work with the latest beta.

spacepluk

Nevermind, it does work, I just forgot to restart gnome-shell to reload the .desktop file.

bburton

This works well for me. As I had to tweet, https://twitter.com/solarce/status/650056804987088897

 

I found that `--force-device-scale-factor=2.2` was best for me. I have Arch Linux and the Cinnamon Desktop on a 2015 Dell XPS 13" (ships with Ubuntu) with the qHD screen. I edited `/usr/share/applications/spotify.desktop` to make it *stick*

 

Thanks for figuring this out.

ecneref

also doesn't work for me on Linuxmint rafaela, Spotify client 0.9.17.1.g9b85d436

Marked as solution

mobman02
I can confirm that this option does not have any effect on Spotify 0.9.17.1, the official version you get here: https://www.spotify.com/fr/download/linux/

adrianbsuy

What about non Ubuntu/Debian distros? Should give a direct download.

dan-ator

I tried doing this but it wouldn't give me write access to actually save the change to the file. How can I override that?

Suggested posts