Help Wizard

Step 1

NEXT STEP

Not getting 24bit 48khz audio

Solved!

Not getting 24bit 48khz audio

Plan

Premium

Country

India

 

Device

Laptop

Operating System

Arch Linux

 

My Question or Issue

I have set audio to Very High Quality but I am still getting S16LE 44.1KHz Sample Rate as information pulse audio

 

ABHIRAMSHIBU_0-1615450782983.pngABHIRAMSHIBU_1-1615450821757.png

I am running pulseeffects ontop of pipewire.

ABHIRAMSHIBU_2-1615450893399.png

I have also checked in PC which uses pulseaudio. Same issue.

 

Because of this I don't difference between youtube and spotify audio. I do own AKG headphones (K70) also sony home theater (32Bit PCM 2 channel via HDMI)

 

Please do help me. I have checked everywhere about this, seems no one ether checked if they are getting high quality audio in linux or they don't have the issue.

Reply

Accepted Solutions
Marked as solution

Actually my output is configured for 32bit. But spotify is using 16bit so pulseaudio is casting to 32bit .
What about sample rate, is it still 44100hz in very high quality option?
pulse

Sink Input is provided below

ABHIRAMSHIBU_0-1615576742920.png

Sinks are listed below.

ABHIRAMSHIBU_1-1615576807318.png

 

View solution in original post

4 Replies

Hello, good day @ABHIRAMSHIBU 🙂

 

Spotify stream is 16bit 320kbps ogg (highest quality), which means there won't be much point trying for much higher audio settings.

 

I have a custom config file for pulseaudio and the only thing that changed is bit depth (it's now 32bit float instead of 16bit), but I don't really know if that would improve things much. : )

 

Hope this helps, have a lovely day!

Marked as solution

Actually my output is configured for 32bit. But spotify is using 16bit so pulseaudio is casting to 32bit .
What about sample rate, is it still 44100hz in very high quality option?
pulse

Sink Input is provided below

ABHIRAMSHIBU_0-1615576742920.png

Sinks are listed below.

ABHIRAMSHIBU_1-1615576807318.png

 

@ABHIRAMSHIBU 

 

Yes, Spotify's putting out 44.1kHz sample rate. Here's an excerpt from the log file:

unknown.png

 

If you'd like to see / confirm what your Spotify is putting out, do this:

1. Close Spotify
2. Open Terminal, type in this command:

spotify --log-file=spotify.log --trace-file=spotify.trace

3. Spotify will be called to open. Play something.

4. The log file is in your home directory. You can open it to see its contents.

 

If you close the Terminal, Spotify will close as well. Ctrl + C into the Terminal a nice easy way to terminate the task.

 

🙂

ABHIRAMSHIBU_0-1615664333393.png

Yes you are correct, this is what I wanted. I think its because of my plan is Premium Mini its not having very high quality option even though I am able to select.

 

Thanks a lot 🙂

Suggested posts