Help Wizard

Step 1



Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...


Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...


Spotify GUI freezes in Ubuntu 19.10

Spotify GUI freezes in Ubuntu 19.10




Operating System

Ubuntu 19.10 on Laptop and double display with HDMI cable


My Question or Issue



I'm using Spotify on Ubuntu 19.10 and since I installed the software (some days ago) I noticed an annoying bug: the window of the program is freezed and so non-interactable, but music goes on and even keyboard insturctions (play/pause, go on, go back) works normally. I said that the window seems to be freezed because even automatic reshaping  does not work)


It happens very frequently and the only solution that I found is to close and reopen spotify (the close button 'X' works).

119 Replies

It's a subscription-based product, people pay money for it. The justification of "not enough users" is just pure**bleep** excuse for releasing low-quality software.

Repeating myself. But according to their website :


Spotify for Linux is a labor of love from our engineers that wanted to listen to Spotify on their Linux development machines. They work on it in their spare time and it is currently not a platform that we actively support. 

Not enough paid linux users. Simple as that. 


For what it's worth, the software works well on Arch in my case.

and how did you installed it in arch? With snap?

AUR. Why?

I didn't knew there was an AUR package. I thought you were installing the snap w/o the problem. I understand the AUR is a repackage of the DEB so it shouldn't have the problem either.

This reply may already have been given, seeing as there are 104 replies, however:
The simplest fix is to install Spotify the 'old way' by adding spotify's deb repository and NOT Snap. I have tested and the apt install does not display the freezing issue for me.


Command line commands:
> curl -sS | sudo apt-key add -
echo "deb stable non-free" | sudo tee /etc/apt/sources.list.d/spotify.list

> sudo apt-get update && sudo apt-get install spotify-client

Same problem in Ubuntu 20.04

This worked for me

Same problem on Gentoo. Using native deb package

Latest .deb can be found here

I don't know why the latest can not be reached by apt.

For some reason those .deb packages can be downloaded only with wget because the server closes connection in the middle of dowload very often.

Can't paste a working wget coomand here for some reason it gets shortened.

I uninstalled spotify from snap and installed again via apt (spotify-client), its working alright now.

OS: Manjaro Linux x86_64 
Host: HP Stream x360 Convertible 11-aa0XX Kernel: 5.8.6-1-MANJARO Packages: 989 (pacman), 4 (snap) Shell: bash 5.0.18 Resolution: 1366x768 DE: Xfce 4.14 WM: Xfwm4 CPU: Intel Celeron N3060 (2) @ 2.480GHz GPU: Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Memory: 2336MiB / 3841MiB

Same issue.

The AUR package is outdated, not working for me anymore.

Only option from snap.

The drag magic is working.

Having the Same problem with snap installation in Fedora 31 and gnome. Tried reinstalling but the same keeps happening

Same issue on Kubuntu 20.04. I've tried snap and apt/deb. The application is very unresponsive and almost unusable. I can select a playlist and let it run for an hour or so until it crashes. Trying to switch songs/playlist will freeze the app. Frustrating as a long-time premium user who works on linux all day.

I got very tired uninstalling and installing the app ... there has not been a working solution since february. I still do my work on Ubuntustudio but I bough a mac book pro aside just to play spotify.

get the new update, seems fixed




I am also getting snap version of spotify on Kubuntu 20.04 freezing and crashing my system, only started recently. I can hear the fans inside my PC spinning up like it's about to start a workout. Something has changed recently it seems.


In my case it was due to some weird conflict with my GPU. Try disabling GPU to rule out a GPU issue:

spotify %U --disable-gpu

Suggested posts