Announcements

Spotify snap package permission issues on linux

Solved!
Reply

Spotify snap package permission issues on linux

Visitor

Plan

Premium

 

Operating System

GNU/Linux (5.5.7-arch1-1 x86_64)

 

My Question or Issue

I've installed spotify using snap and everything worked fine until I had this error a couple months ago and found no fix for it:

> spotify
Gtk-Message: 15:56:46.941: Failed to load module "canberra-gtk-module"
[1] 3850012 trace trap (core dumped) spotify

 

But recently I looked a bit deeper and found out it's most likely NOT a canberra-gtk problem, it's a permission problem. When I start spotify as a superuser (sudo spotify) everything works fine.

 

I think the program is trying to write somewhere and has insufficient permissions to do so.

Does anybody know how to fix this or do something about it? Running the package as a superuser is not a viable solution and should be considered dangerous.

 

Thanks for reading,

 

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Solution!

Re: Spotify snap package permission issues on linux

Roadie
Obvious solution is to install spotify from AUR or Flathub.

View solution in original post

1 Reply
Highlighted
Solution!

Re: Spotify snap package permission issues on linux

Roadie
Obvious solution is to install spotify from AUR or Flathub.

View solution in original post

SUGGESTED POSTS