[Troubleshooting] Linux Spotify


Re: [Troubleshooting] Linux Spotify

Casual Listener
Hey, thanks bro, can I do that only using commands in the terminal?
If so, what are the commands?


Re: [Troubleshooting] Linux Spotify


@Lexxidon wrote:
Hey, thanks bro, can I do that only using commands in the terminal?
If so, what are the commands?


Since you posted this I was waiting for some free time to write a small script which could do this.
You just need to install wmctrl and xdotool, then you can create a file with this inside it:


# open spotify
spotify &

# wait for a little and move it to the last workspace and 
# then back to the current workspace giving focus on it
sleep 1
wid=$(wmctrl -l | grep 'Spotify' | tail -n1 | awk '{print $1}')
num_desks=$(xdotool get_num_desktops)
curr_desk=$(xdotool get_desktop)
if [ "$curr_desk" -eq "$last_desk" ]; then
	moveto=$(echo '0')

# tried this but does not work (I don't know why)
# wmctrl -x $wid; wmctrl -r $wid -t $moveto; wmctrl -R $wid

xdotool set_desktop_for_window $wid $moveto; xdotool set_desktop_for_window $wid $curr_desk; xdotool windowactivate $wid

Then just give the right permissions and launch the client form it and you will have it automatically showing in the taskbar.

Re: [Troubleshooting] Linux Spotify

Casual Listener

How can i make so that my app does not update no matter what?
I'm using Linux Mint Rosa. Thanks! 


Re: [Troubleshooting] Linux Spotify


Which version do you want to use?
If it's the 0.9 then you should add the testing repository and instal spotify-client-0.9.17 as shown in the first post of this topic.

If you want to use 1.x then I'd recomment staying up to date, since the latest versions have been including a lot of bug fixes.

Re: [Troubleshooting] Linux Spotify

Rock Star 24
Rock Star 24



Just delete any repository you might have in the system for the app.


If you haven't installed it yet, download the deb file for the version you're interested in using for install, and it won't update.

osorniosRock Star 24
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.

Re: [Troubleshooting] Linux Spotify


Hi, I have installed ubuntu-restricted-extras, ffmpeg, libavcodec, livavutil, libavformat, zenity but doesn't work.




  1. Your device and operating system: Intel® Core™ i3 CPU M 330 @ 2.13GHz × 4, 4GB, 64bit, Ubuntu 16.04 LTS
  2. Type of Spotify account you have (Free/ Premium): Free
  3. The app version of Spotify you’re using:
  4. Brief description of the issue: Local files do not play on Ubuntu 16.04

Spotify finds the songs, but don't play and close the app. 




Solved after read this post: https://community.spotify.com/t5/Help-Desktop-Linux-Windows-Web/Can-t-play-local-files-with-current-...


So, I decided publish the solution.


1º) Install some packs: ubuntu-restricted-extras, ffmpeg, libavcodec, livavutil, libavformat, zenity.


sudo apt install ubuntu-restricted-extras ffmpeg libavcodec-extra libavcodec-extra57 libavutil55 libavformat57 zenity -y

New version to packs: libavformat57 libavcodec-extra57 libavcodec-extra libavutil55 



2º) Download some archives: (I put all in the github repository)


--> Download the package: https://github.com/ramedeiros/spotify_libraries/archive/master.zip


Or direct from the terminal: 


git clone https://github.com/ramedeiros/spotify_libraries.git

3º) Put all the files in to /usr/lib/x86_64-linux-gnu/ with root privileges.


cd spotify_libraries
sudo cp lib* /usr/lib/x86_64-linux-gnu/

4º) Execute: ldconfig


sudo ldconfig

5º) If show any problem with link, make new links.


e.g.: "/sbin/ldconfig.real: /usr/lib/x86_64-linux-gnu/libavutil.so.52 it's not a symbolic link"

So, execute command:


sudo ln -frs /usr/lib/x86_64-linux-gnu/libavutil.so.52.6.100 /usr/lib/x86_64-linux-gnu/libavutil.so.52
sudo ln -frs /usr/lib/x86_64-linux-gnu/libavformat.so.54.36.100 /usr/lib/x86_64-linux-gnu/libavformat.so.54
sudo ln -frs /usr/lib/x86_64-linux-gnu/libavcodec.so.54.71.100 /usr/lib/x86_64-linux-gnu/libavcodec.so.54


And so on...


 Original link: https://community.spotify.com/t5/Help-Desktop-Linux-Windows-Web/Linux-Local-files-do-not-play-on-Ubu...

View solution in original post

Re: [Troubleshooting] Linux Spotify

Casual Listener

I have spotify on linux ubuntu 16.04. It works properly but sometimes it fail to play some song (generaly after a pause or I navigated through spotify links). Simply the play buttons doesn't work for that sound anymore and I have to restart spotify.


I've started spotify by terminal a got these messages:


13:04:36.225 I [audio_player_queue_impl.cpp:826 ] Flush driver: 0x00003f3c97252a50
13:04:36.226 D [gaia_manager.cpp:941 ] GAIA: current state ID updated to -143172072
13:04:36.226 I [sliding_window_prefetch_strategy.cpp:212] Prefetch: looks like new context - resetting window size to 1

Re: [Troubleshooting] Linux Spotify

  1. Lenovo Thinkpad X240, Fedora 23 64bit / Acer Aspire V5, Fedora 23 64bit
  2. Premium Account
  3. Spotify Version
  4. Navigation arrows are misaligned
  5. Appears on every page

After the last update, navigation arrows are misaligned, see screenshots:



Screenshot from 2016-05-31 09-01-19.png



Screenshot from 2016-05-31 09-25-30.png


Re: [Troubleshooting] Linux Spotify

Casual Listener

I have the same issue:

Ubuntu 12:04, Premium account, Can't identify the ver of Spotify (lack of skills).

Spotify won't start from launcher, Terminal gives same result as jaanvaks

which is:


spotify: symbol lookup error: /usr/share/spotify/libcef.so: undefined symbol: g_type_class_adjust_private_offset 


I'm desperate for a fix that doesn't involve downgrading......



Also, I previously had a similar error as b584371 had:

layout: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by layout)

I found the following fix:


sudo add-apt-repository ppa:ubuntu-toolchain-r/test 
sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade


Re: [Troubleshooting] Linux Spotify


Have you installed some non-Ubuntu libraries?


I found this with google http://unix.stackexchange.com/questions/204877/symbol-lookup-error-usr-lib-x86-64-linux-gnu-libxfcon.... Maybe that helps.