Ubuntu - Music partition not showing on Local Files popup

Solved!
Reply
Highlighted

Ubuntu - Music partition not showing on Local Files popup

Mephisto
Music Fan

Ubuntu 18.10 64-bit

Spotify version: 1.0.93.242.gc2341a27

Plan: Premium

Country: UK

Device: Dell Studio 17 laptop

My Question or Issue:

Until recently I have been running Windows 10 with a separate music partition.

When I replaced Windows with Ubuntu 18.10 I mounted the music partition as /windows/music. The actually folder containing the music is mounted as /windows/music/Music.

I can access the music folder through the Ubuntu file system and it is also available through Ubuntu's Rhythmbox, so no problems there.

I installed Spotify through Ubuntu's software app and it works just fine with streaming music. Great.

However, when I click on the Local Files source in settings I get a popup of the file directories but the mounted (/windows/music) partition isn't showing up. As a result I cannot access my local music through Spotify.

I've attached 2 screen prints, one of the directory structure shown through the OS and the other of the directory structure shown through Spotify.

Any help/advice would be greatly appreciated.

Love the app and thanks to all in the development and provision of the Linux version.

Cheers.

 

os files.png
spotify files.png
1 ACCEPTED SOLUTION

Accepted Solutions
Solution! 2 people liked this

Re: Ubuntu - Music partition not showing on Local Files popup

imperialphantom
Casual Listener

I ran into this same problem, its because the Spotify app installed as a snap package and is sandboxed to that it can't see anything outside of your home directory. I worked around this limitation by installing the debian package. Note however that there are missing libraries for local playback that have to be added for local music playback, I installed them from this github repo.  :

https://github.com/ramedeiros/spotify_libraries/

Hope this helps.

2 Replies
Solution! 2 people liked this

Re: Ubuntu - Music partition not showing on Local Files popup

imperialphantom
Casual Listener

I ran into this same problem, its because the Spotify app installed as a snap package and is sandboxed to that it can't see anything outside of your home directory. I worked around this limitation by installing the debian package. Note however that there are missing libraries for local playback that have to be added for local music playback, I installed them from this github repo.  :

https://github.com/ramedeiros/spotify_libraries/

Hope this helps.

1 person liked this

Re: Ubuntu - Music partition not showing on Local Files popup

Mephisto
Music Fan

Many thanks imperialphantom, that explains everything. I wasn't aware of the sandboxing with Snap, that's a limitation I can do without especially as I haven't settled on the OS I want and I don't want to have to keep copying across my music collection. Having them on a separate partition seems the easiest option.

Anyway, I've uninstalled the Snap version and installed Spotify via the deb from the website. Installed the extra old codecs from the link you gave and Bob's your auntie, all playing nicely now.

Thanks a lot.

SUGGESTED POSTS