Help Wizard

Step 1

NEXT STEP

MacOS app doesn't work offline after update

Solved!

MacOS app doesn't work offline after update

Plan: Premium

Country: Czech republic

 

Device: Macbook Pro Mid-2017

Operating System: MacOS Catalina 10.15.4

 

After the latest update, I cannot use the MacOS app in offline mode. Most of my downloaded playlists are not available and all I get is the error in the picture.

 

When I try to add a song to another playlist, the app freezes because it cannot load any of my playlists (no error shown though) and I have to shut it down.

 

When I go offline after being connected to the internet, it says to reload the page (even when I am in the desktop app) and the button doesn't work.

 

I know that nowadays people don't go offline very often but it is one of your key features and I bet people still use it a lot.

 

I will be more than happy when the humanity will finally get to the stage, where updates actually fix and upgrade things rather than break them. You are the #1 music app, don't screw up please.

 

Thank you!

Screenshot 2020-05-19 at 15.04.00.png
Reply

Accepted Solutions
Marked as solution

Hey there @Johnny_Unar!

 

Thanks for reaching out about this.

 

We'll be happy to help you sort this out. You can start off by performing a clean reinstall of the app with the steps here. This will ensure that old data will not be causing any trouble.

 

It's also a good idea to give your device a quick restart before you open the newly installed app.

 

In case you still experience the issue, could you let us know if it happens om your computer or on a different device as well?

 

We'll be on the lookout for your reply!

ElenaModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

View solution in original post

5 Replies
Marked as solution

Hey there @Johnny_Unar!

 

Thanks for reaching out about this.

 

We'll be happy to help you sort this out. You can start off by performing a clean reinstall of the app with the steps here. This will ensure that old data will not be causing any trouble.

 

It's also a good idea to give your device a quick restart before you open the newly installed app.

 

In case you still experience the issue, could you let us know if it happens om your computer or on a different device as well?

 

We'll be on the lookout for your reply!

ElenaModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Hi Elena, I'm having the same problem as above, and I'm only struggling to access my music offline on my macbook pro 13" (post-2020 model). I tried a clean reinstall, and it didn't work. Please let me know what to do next as I often need to listen to my playlists offline.

Hi @Ashwarapillay!

 

You can try deleting the prefs file to see if that would do the trick:

  1. Open Finder on your Mac and click Go > Library (if you don't have hidden folders enabled, press the option key first and it should appear).
  2. Go to Application Support > Spotify.
  3. There you'll find a file called prefs, which holds info about the currently logged in account. Simply delete it.
  4. While in the Spotify folder, you'll also find a Users folder. Open it and delete its contents as well.
  5. Restart the Spotify app.

Note that you'll be logged out and your preferences will be reset, so you'll have to adjust them again. You'll also have to redownload your downloaded music for offline listening. Your library, however, will not be affected, so no worries there.

 

In case the issue persists, a short screen recording which shows the app's behavior in action would be greatly appreciated.

 

Let us know how it goes. Cheers!

YordanModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a "Like".
Are you new to the Community? Take a moment to introduce yourself!

Hi Yordan, this worked! Thanks so much for the help! 🙂

Hey @Ashwarapillay,

Thank you for keeping in contact.

We're glad to know that everything is working fine by now. We appreciate the time you took following the troubleshooting steps and sharing what works for you. 

If anything else comes up, the Community will be here for you. 

Cheers!

OscarDCModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Suggested posts