Spotify still auto-updates after trying different solution

Solved!
Reply

Spotify still auto-updates after trying different solution

alexlo1209
Regular

Hey guys! I

 

know there are many people giving a lot of solutions to stop Spotify from auto-updating but I have tried many methods but it still doesn't work and I have no idea what to do fix it. 

 

I am now using the old version of Spotify which is 0.9.15.27 and I am using Mac which is OS X Yosmite (10.10.2). I have tried to make blank texts and put them in the spotify folder but it doesn't work. Then I reinstalled spotify and tried again but the original sportify folder was gone and I couldn't find it in Application support. 

 

It bothers me a lot and I am tired of uninstalling and reinstalling it. Does anyone know how to solve the problem? Thanks guys! 

 

2 ACCEPTED SOLUTIONS

Accepted Solutions
Solution!

iaggy
Casual Listener

The library-folder in [username] is hidden.

 

open the finder, press  Shift + cmd + g  and open ~/library . There should be the right application-supply-folder with the spotify-folder in it.

 

 

View solution in original post

Solution!

iaggy
Casual Listener
9 Replies

Scharfohr
Regular

Sounds like the same mistake i made. 

 

You must activate the file endings beforehand so it change the type of the file when you rename the txt files.(And dont forget to set it to read only). 

 

and then rest like others posted before.

 

 

Go to C:/Users/<Name>/Appdata/Roaming/Spotify

 

1. Make a new empy text file

2. Name it Spotify_new.exe

3. Right click the file and make the file read only

 

1. Make a new empty text file

2. Name it Spotify_new.exe.sig

3. Right click the file and make the file read only

 

i hope it hels

iaggy
Casual Listener
 

tapenoon
Roadie

Make sure you are here: Macintosh HD -> Users -> [Your username] -> Library -> Application Support -> Spotify. Create the blank documents and save them here. Also make sure you have the' hide extension' option unchecked and that the file name is correct. then right click on each file and check the option 'Locked'. that should do it.

alexlo1209
Regular

Thank you guys for the reply! Well yeah.. the funniest part is that there was a Spotify folder in Application support but after I wanted to try to uninstall and reinstall again, the Spotify folder is no longer there. 

 

I did follow the steps to make the plain text files and logged them putting in the Spotify folder I opened in Application support. But I guess this method doesn't work so I have no idea what I can do to fix it. 

 

tapenoon
Roadie

are you sure you followed the path above? you must follow the path above because if you go to Macintonsh HD -> Library -> Application support, there is no Spotify folder there indeed. it drove me nuts for a week.

alexlo1209
Regular

Not sure if my mac is different from you guys' cause my path getting to Application support is Macintonsh HD -> Library -> Application support which I couldn't find Application Support after Users -> my username. It's so confusing.. 

Solution!

iaggy
Casual Listener

The library-folder in [username] is hidden.

 

open the finder, press  Shift + cmd + g  and open ~/library . There should be the right application-supply-folder with the spotify-folder in it.

 

 

alexlo1209
Regular

omg! Thank you so much! I finally found the folder and I didn't know the folder is hidden.. So I just make the plain text files and replace those two in the folder?

Solution!

iaggy
Casual Listener
 
SUGGESTED POSTS