Autoplay not working

Solved!
Reply

Autoplay not working

moozzy
Regular

Plan

Premium

Country

United States

Device

PC

Operating System

Windows 10

 

My Question or Issue

I updated my Spotify to the most recent version and the autoplay option is now back. I have it enabled, but it still will not work.

 

I have already done a clean reinstall, I have tried toggling the option off and then on again. I tried logging out and logging back in again, but still this feature does not work for me.

 

1 ACCEPTED SOLUTION

Accepted Solutions
Solution!

Re: Autoplay not working

moozzy
Regular

I got it! I found the solution in a related issue, which was that some songs would just load up a blank album cover and blank info. This fix helped with that problem as well as the autoplay issue:

 

1. open Notepad as an administrator (right-click - Open as Administrator)
2. go to File - Open and navigate to

C:\Windows\System32\drivers\etc

3. Choose "All Files" instead of "Text Documents" next to the File Name box. You'll see a handful of files. Pick hosts and click on Open.
4. The file is opened. You will see a block of text with # in front of each line and might see entries like

0.0.0.0 website.com
127.0.0.1 website2.com

Check for any entries with spotify or fastly in the address. Examples may look like:

0.0.0.0 weblb-wg.gslb.spotify.com
0.0.0.0 prod.b.ssl.us-eu.fastlylb.net 

(and any variations inbetween)
5. If you do find any, you can delete the line. You can also add a # in front of the line, that's 'commenting out'.
6. Save your changes. Restart Spotify.

 

Originally from this thread (comment is on page 2 by Smexyskeletor)

https://community.spotify.com/t5/Ongoing-Issues/Playlists-appear-empty-on-desktop-app/idi-p/4680137/...

4 Replies

Re: Autoplay not working

facetiousfrau
Casual Listener

Having the same issue on mac.

Highlighted

Re: Autoplay not working

moozzy
Regular

I'm going to try to uninstall and then manually make sure all folders/files related to Spotify (anything in appdata, for example) is gone to verify there isn't some kind of preference file or something that's causing this. Once I'm relatively certain all files are gone, I'll reinstall and let you all know if that worked. I'm running a search of my C drive now and it did just pull one spotify file up from AppData as I'm typing this, so hopefully this is what needs to happen. 

Re: Autoplay not working

moozzy
Regular

Nope, still no luck. Downloaded a fresh installer and everything, installed. Logged in, checked the setting, and it still doesn't autoplay.

 

Does no one have a solution to this? It's one of the main reasons I've been using Spotify. It works fine on my phone, but for some reason the Windows version seems to not be able to do this. 

Solution!

Re: Autoplay not working

moozzy
Regular

I got it! I found the solution in a related issue, which was that some songs would just load up a blank album cover and blank info. This fix helped with that problem as well as the autoplay issue:

 

1. open Notepad as an administrator (right-click - Open as Administrator)
2. go to File - Open and navigate to

C:\Windows\System32\drivers\etc

3. Choose "All Files" instead of "Text Documents" next to the File Name box. You'll see a handful of files. Pick hosts and click on Open.
4. The file is opened. You will see a block of text with # in front of each line and might see entries like

0.0.0.0 website.com
127.0.0.1 website2.com

Check for any entries with spotify or fastly in the address. Examples may look like:

0.0.0.0 weblb-wg.gslb.spotify.com
0.0.0.0 prod.b.ssl.us-eu.fastlylb.net 

(and any variations inbetween)
5. If you do find any, you can delete the line. You can also add a # in front of the line, that's 'commenting out'.
6. Save your changes. Restart Spotify.

 

Originally from this thread (comment is on page 2 by Smexyskeletor)

https://community.spotify.com/t5/Ongoing-Issues/Playlists-appear-empty-on-desktop-app/idi-p/4680137/...

SUGGESTED POSTS